Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Export custom Preferences(Using org.eclipse.ui.preferenceTransfer to export specific preferences using the export Preferences wizard)
Export custom Preferences [message #673328] Mon, 23 May 2011 09:20 Go to next message
Anas  is currently offline Anas Friend
Messages: 2
Registered: May 2011
Junior Member
Hi Everybody,

I'm new to eclipse plug-in development. I have created a plug-in and it has some configurations - saved as preferences-. I want to export and import these preferences using the eclipse export preferences dialog.

I tried using org.eclipse.ui.preferenceTransfer extension point but nothing appears in the preferences list when I open Export preferences dialog. Here's how I used it:

<extension point="org.eclipse.ui.preferenceTransfer">
      <transfer id="com.anas.assets.tool.preferences.transfer"
            name="Tool Configurations">
         <mapping scope="instance">
            <entry node="com.anas.assets.tool">
               <key match="prefix" name="com.anas.assets.tool.">
               </key>
            </entry>
         </mapping>
      </transfer>
   </extension>


Any ideas what may be the problem? Should the node in <entry node="com.anas.assets.tool"> match a specific object ID in the plug-in? I used the plug-in ID as in the Manifest file.

Any samples of using this extension point or providing similar functionality is appreciated.

thnx
Anas
Re: Export custom Preferences [message #673577 is a reply to message #673328] Tue, 24 May 2011 07:28 Go to previous message
Anas  is currently offline Anas Friend
Messages: 2
Registered: May 2011
Junior Member
The key com.anas.assets.tool. is causing the problem. I don't know why but when I changed it to more specific key (com.anas.assets.tool.colors) it worked fine.

I don't know why?!!! but it finally worked.


Appreciate if someone can clarify why this may happen.
Previous Topic:Plugin works on Eclipse instance but it doesn't on normal Eclipse
Next Topic:Code doesn't compile if bundle referencing jars is in the target platform
Goto Forum:
  


Current Time: Fri Dec 19 11:52:59 GMT 2014

Powered by FUDForum. Page generated in 0.04331 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software