Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Some source features are generated without the "Source for " prefix
Some source features are generated without the "Source for " prefix [message #671909] Thu, 19 May 2011 10:30 Go to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Hi,

I noticed that some of my source features are generated without the "Source for " prefix while others have this prefix. I've attached two install screenshots that illustrate this problem. When I compare the "good" features with the "bad" ones I can see no relevant difference. Is there something i could have overseen or could it be a bug in Bucky?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: Some source features are generated without the "Source for " prefix [message #671960 is a reply to message #671909] Thu, 19 May 2011 13:03 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Hi Eike,

Is the feature name subject to translations in the original feature? What does the feature.properties look like?

- thomas

On 2011-05-19 12:30, Eike Stepper wrote:
> Hi,
>
> I noticed that some of my source features are generated without the "Source for " prefix while others have this prefix.
> I've attached two install screenshots that illustrate this problem. When I compare the "good" features with the "bad"
> ones I can see no relevant difference. Is there something i could have overseen or could it be a bug in Bucky?
>
> Cheers
> /Eike
>
> ----
> http://www.esc-net.de
> http://thegordian.blogspot.com
> http://twitter.com/eikestepper
>
>
Re: Some source features are generated without the "Source for " prefix [message #672043 is a reply to message #671960] Thu, 19 May 2011 16:49 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 19.05.2011 15:03, schrieb Thomas Hallgren:
> Hi Eike,
>
> Is the feature name subject to translations in the original feature? What does the feature.properties look like?
I've attached the two files from the screenshot (2) for you. They look structurally identical and simple.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
> - thomas
>
> On 2011-05-19 12:30, Eike Stepper wrote:
>> Hi,
>>
>> I noticed that some of my source features are generated without the "Source for " prefix while others have this prefix.
>> I've attached two install screenshots that illustrate this problem. When I compare the "good" features with the "bad"
>> ones I can see no relevant difference. Is there something i could have overseen or could it be a bug in Bucky?
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://www.esc-net.de
>> http://thegordian.blogspot.com
>> http://twitter.com/eikestepper
>>
>>
>

# Copyright (c) 2004 - 2011 Eike Stepper (Berlin, Germany) and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html

featureName = CDO Dawn Tests
description = Contains the CDO Dawn test plugins and sources. Ensure that SWTBot is already installed! Visit http://download.eclipse.org/technology/swtbot/helios/dev-build/update-site for a p2 repository that contains SWTBot.

# Copyright (c) 2004 - 2011 Eike Stepper (Berlin, Germany) and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html

featureName = CDO Dawn Examples
description = Contains example plugins to demonstrate a range of functions of Dawn.
Re: Some source features are generated without the "Source for " prefix [message #672061 is a reply to message #672043] Thu, 19 May 2011 18:14 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Just to make sure. Do both feature.xml files use %featureName?

Do you see any other pattern? Do you have bundles with the same name as the feature? Just wild guessing here as I have
no clue why this happens.

- thomas

On 2011-05-19 18:49, Eike Stepper wrote:
> Am 19.05.2011 15:03, schrieb Thomas Hallgren:
>> Hi Eike,
>>
>> Is the feature name subject to translations in the original feature? What does the feature.properties look like?
> I've attached the two files from the screenshot (2) for you. They look structurally identical and simple.
>
> Cheers
> /Eike
>
> ----
> http://www.esc-net.de
> http://thegordian.blogspot.com
> http://twitter.com/eikestepper
>
>
>>
>> - thomas
>>
>> On 2011-05-19 12:30, Eike Stepper wrote:
>>> Hi,
>>>
>>> I noticed that some of my source features are generated without the "Source for " prefix while others have this prefix.
>>> I've attached two install screenshots that illustrate this problem. When I compare the "good" features with the "bad"
>>> ones I can see no relevant difference. Is there something i could have overseen or could it be a bug in Bucky?
>>>
>>> Cheers
>>> /Eike
>>>
>>> ----
>>> http://www.esc-net.de
>>> http://thegordian.blogspot.com
>>> http://twitter.com/eikestepper
>>>
>>>
>>
Re: Some source features are generated without the "Source for " prefix [message #672097 is a reply to message #672061] Thu, 19 May 2011 21:29 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 19.05.2011 20:14, schrieb Thomas Hallgren:
> Just to make sure. Do both feature.xml files use %featureName?
Yes, see the attached files.

>
> Do you see any other pattern?
Not yet ;-(

> Do you have bundles with the same name as the feature?
Definitely! They are the "branding plugins" of their features.

> Just wild guessing here as I have no clue why this happens.

;-)

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
> - thomas
>
> On 2011-05-19 18:49, Eike Stepper wrote:
>> Am 19.05.2011 15:03, schrieb Thomas Hallgren:
>>> Hi Eike,
>>>
>>> Is the feature name subject to translations in the original feature? What does the feature.properties look like?
>> I've attached the two files from the screenshot (2) for you. They look structurally identical and simple.
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://www.esc-net.de
>> http://thegordian.blogspot.com
>> http://twitter.com/eikestepper
>>
>>
>>>
>>> - thomas
>>>
>>> On 2011-05-19 12:30, Eike Stepper wrote:
>>>> Hi,
>>>>
>>>> I noticed that some of my source features are generated without the "Source for " prefix while others have this prefix.
>>>> I've attached two install screenshots that illustrate this problem. When I compare the "good" features with the "bad"
>>>> ones I can see no relevant difference. Is there something i could have overseen or could it be a bug in Bucky?
>>>>
>>>> Cheers
>>>> /Eike
>>>>
>>>> ----
>>>> http://www.esc-net.de
>>>> http://thegordian.blogspot.com
>>>> http://twitter.com/eikestepper
>>>>
>>>>
>>>
>
Re: Some source features are generated without the "Source for " prefix [message #673454 is a reply to message #672061] Mon, 23 May 2011 16:55 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 19.05.2011 20:14, schrieb Thomas Hallgren:
> Do you see any other pattern?
It seems that the entire feature.properties file in the wrong source features is an *exact* copy of their code features. Also the description is wrong...

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: Some source features are generated without the "Source for " prefix [message #673550 is a reply to message #673454] Tue, 24 May 2011 05:05 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Eike, please file a bugzilla on this where you declare a priority and blocking status that reflects your situation.

Thanks,
Thomas Hallgren


On 2011-05-23 18:55, Eike Stepper wrote:
> Am 19.05.2011 20:14, schrieb Thomas Hallgren:
>> Do you see any other pattern?
> It seems that the entire feature.properties file in the wrong source features is an *exact* copy of their code features.
> Also the description is wrong...
>
> Cheers
> /Eike
>
> ----
> http://www.esc-net.de
> http://thegordian.blogspot.com
> http://twitter.com/eikestepper
>
>
Re: Some source features are generated without the "Source for " prefix [message #673573 is a reply to message #673550] Tue, 24 May 2011 07:14 Go to previous message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 24.05.2011 07:05, schrieb Thomas Hallgren:
> Eike, please file a bugzilla on this where you declare a priority and blocking status that reflects your situation.
I've submitted https://bugs.eclipse.org/bugs/show_bug.cgi?id=346936

Note that I've elevated the severity to major because I think that the first time
experience of users is during install time and it looks quite confusing if
features (feature names) appear duplicated in the p2 client. It would be very
nice to have this fixed for Indigo RC3 or RC4 latest.

Thanks and

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


>
> Thanks,
> Thomas Hallgren
>
>
> On 2011-05-23 18:55, Eike Stepper wrote:
>> Am 19.05.2011 20:14, schrieb Thomas Hallgren:
>>> Do you see any other pattern?
>> It seems that the entire feature.properties file in the wrong source features is an *exact* copy of their code features.
>> Also the description is wrong...
>>
>> Cheers
>> /Eike
>>
>> ----
>> http://www.esc-net.de
>> http://thegordian.blogspot.com
>> http://twitter.com/eikestepper
>>
>>
>
Previous Topic:Specify in the cquery that you want the materialization to be performed to the workspace
Next Topic:Dump p2 URLs
Goto Forum:
  


Current Time: Mon Sep 22 08:24:49 GMT 2014

Powered by FUDForum. Page generated in 0.01995 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software