Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Install from repositories fails
Install from repositories fails [message #668403] Thu, 05 May 2011 15:00 Go to next message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 155
Registered: July 2009
Senior Member
Dear all,

I have Eclipse 3.6.1 and would like to start using WTP. I'm trying to install from the repositories using the address:

http://download.eclipse.org/webtools/repository/helios/

And am sellecting the following packages:

* Web Tools Platform (WTP) 3.2.3

* Web Tools Platform SDK (WTP SDK) 3.2.3

* Web Tools Platform Tests (WTP Tests) 3.2.2

The installation fails with the message "The operation cannot be completed". The following details are provided:

Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Axis2 Tools 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj (org.eclipse.jst.ws.axis2tools.feature.feature.group 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
Missing requirement: Web Services Consumption 1.0.507.v201004211805 (org.eclipse.jst.ws.consumption 1.0.507.v201004211805) requires 'bundle org.eclipse.xsd [2.2.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Webservice Axis2 Creation UI Plug-in 1.0.104.v201004211805 (org.eclipse.jst.ws.axis2.creation.ui 1.0.104.v201004211805)
To: bundle org.eclipse.jst.ws.consumption.ui 0.0.0
Cannot satisfy dependency:
From: Axis2 Tools 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj (org.eclipse.jst.ws.axis2tools.feature.feature.group 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
To: org.eclipse.jst.ws.axis2.creation.ui [1.0.104.v201004211805]
Cannot satisfy dependency:
From: Web Services Consumption Graphical User Interface 1.1.204.v201006011553 (org.eclipse.jst.ws.consumption.ui 1.1.204.v201006011553)
To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
Cannot satisfy dependency:
From: Web Services Consumption Graphical User Interface 1.1.300.v201008252303 (org.eclipse.jst.ws.consumption.ui 1.1.300.v201008252303)
To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
Cannot satisfy dependency:
From: Web Services Consumption Graphical User Interface 1.1.302.v201101191731 (org.eclipse.jst.ws.consumption.ui 1.1.302.v201101191731)
To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)


How can I overcome this? Thank you,

Luís
Re: Install from repositories fails [message #668431 is a reply to message #668403] Thu, 05 May 2011 16:18 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3266
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

The easiest way is merely to download Eclipse IDE for JEE Developers.
Or, you can wait here until someone helps you finesse it into your
existing Eclipse installation.

On 05-May-11 09:00, Luí­s de Sousa wrote:
> Dear all,
>
> I have Eclipse 3.6.1 and would like to start using WTP. I'm trying to
> install from the repositories using the address:
>
> http://download.eclipse.org/webtools/repository/helios/
>
> And am sellecting the following packages:
>
> * Web Tools Platform (WTP) 3.2.3
>
> * Web Tools Platform SDK (WTP SDK) 3.2.3
>
> * Web Tools Platform Tests (WTP Tests) 3.2.2
>
> The installation fails with the message "The operation cannot be
> completed". The following details are provided:
>
> Quote:
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software being installed: Axis2 Tools
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj
>> (org.eclipse.jst.ws.axis2tools.feature.feature.group
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
>> Missing requirement: Web Services Consumption 1.0.507.v201004211805
>> (org.eclipse.jst.ws.consumption 1.0.507.v201004211805) requires
>> 'bundle org.eclipse.xsd [2.2.0,3.0.0)' but it could not be found
>> Cannot satisfy dependency:
>> From: Webservice Axis2 Creation UI Plug-in 1.0.104.v201004211805
>> (org.eclipse.jst.ws.axis2.creation.ui 1.0.104.v201004211805)
>> To: bundle org.eclipse.jst.ws.consumption.ui 0.0.0
>> Cannot satisfy dependency:
>> From: Axis2 Tools 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj
>> (org.eclipse.jst.ws.axis2tools.feature.feature.group
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
>> To: org.eclipse.jst.ws.axis2.creation.ui [1.0.104.v201004211805]
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.204.v201006011553 (org.eclipse.jst.ws.consumption.ui
>> 1.1.204.v201006011553)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.300.v201008252303 (org.eclipse.jst.ws.consumption.ui
>> 1.1.300.v201008252303)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.302.v201101191731 (org.eclipse.jst.ws.consumption.ui
>> 1.1.302.v201101191731)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>
>
> How can I overcome this? Thank you,
>
> Luís
Re: Install from repositories fails [message #668443 is a reply to message #668403] Thu, 05 May 2011 16:44 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1313
Registered: July 2009
Senior Member
On 5/5/2011 11:00 AM, Luí­s de Sousa wrote:
> Dear all,
>
> I have Eclipse 3.6.1 and would like to start using WTP. I'm trying to
> install from the repositories using the address:
>
> http://download.eclipse.org/webtools/repository/helios/
>
> And am sellecting the following packages:
>
> * Web Tools Platform (WTP) 3.2.3
>
> * Web Tools Platform SDK (WTP SDK) 3.2.3
>
> * Web Tools Platform Tests (WTP Tests) 3.2.2
>
> The installation fails with the message "The operation cannot be
> completed". The following details are provided:
>
> Quote:
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software being installed: Axis2 Tools
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj
>> (org.eclipse.jst.ws.axis2tools.feature.feature.group
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
>> Missing requirement: Web Services Consumption 1.0.507.v201004211805
>> (org.eclipse.jst.ws.consumption 1.0.507.v201004211805) requires
>> 'bundle org.eclipse.xsd [2.2.0,3.0.0)' but it could not be found
>> Cannot satisfy dependency:
>> From: Webservice Axis2 Creation UI Plug-in 1.0.104.v201004211805
>> (org.eclipse.jst.ws.axis2.creation.ui 1.0.104.v201004211805)
>> To: bundle org.eclipse.jst.ws.consumption.ui 0.0.0
>> Cannot satisfy dependency:
>> From: Axis2 Tools 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj
>> (org.eclipse.jst.ws.axis2tools.feature.feature.group
>> 1.1.100.v201005241530-78-FF0DZRDKDDePSKwHj)
>> To: org.eclipse.jst.ws.axis2.creation.ui [1.0.104.v201004211805]
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.204.v201006011553 (org.eclipse.jst.ws.consumption.ui
>> 1.1.204.v201006011553)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.300.v201008252303 (org.eclipse.jst.ws.consumption.ui
>> 1.1.300.v201008252303)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>> Cannot satisfy dependency:
>> From: Web Services Consumption Graphical User Interface
>> 1.1.302.v201101191731 (org.eclipse.jst.ws.consumption.ui
>> 1.1.302.v201101191731)
>> To: bundle org.eclipse.jst.ws.consumption [1.0.101,1.1.0)
>
>
> How can I overcome this? Thank you,
>
> Luís

I believe you would be able to install the 3.2.2 version of WTP with
Eclipse 3.6.1. The 3.2.3 version of WTP expects to run with Eclipse
3.6.2 and may have dependencies that 3.6.1 cannot satisfy.

Also, I doubt you would want WTP Tests since it just contains JUnit
tests for the various plug-ins. You would get extra "funny" stuff in
your UI as these plug-ins try to verify that certain UI related features
are working correctly.

Cheers,
Larry
Re: Install from repositories fails [message #668638 is a reply to message #668403] Fri, 06 May 2011 14:00 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 176
Registered: July 2009
Senior Member
>
> http://download.eclipse.org/webtools/repository/helios/
>
>
One tell-tale msg is the one that says "... requires 'bundle
org.eclipse.xsd [2.2.0,3.0.0)' but it could not be found".

That bundle is one of WTP pre-reqs that comes from emf project, and is
not in the wtp repo, which is just wtp stuff.

One approach to solve is be sure the general ".../releases/helios/" repo
is also enabled enabled in your software site list, and that the
checkbox is ticked for "Contact all update sites during install to find
required software".

I say "one approach", since even doing that, you _might_ run into other
issues ... "update" and "install new software" often depends on how your
installation of your eclipse ide was created in the first place ... but,
wouldn't hurt for you to try it.

Here's some more tips ...

Unless there's something specific you know you need from the webtools
specific site, you can probably get what you need from the
..../releases/helios site. It has nearly all the "webtools stuff" except
for "SDK stuff", unit tests, and sometimes incubating things and tools
(though, don't recall helios having any). The advantage of using
..../releases/helios is that there, all pre-reqs should be easily found,
when needed, and it is better tested to be consistent, have matching
stuff, etc.

As others have said, you probably don't want/need "tests" (and that path
has not been well tested, and might even be conflicting dependencies due
to selecting that).

You dont' need to check "WTP SDK" and "WTP" at the same time ... the
latter is a subset of the former.

As a general rule, if you run into issues, you might try selecting just
one feature (either high level one, like the Jave EE one, or a low level
one, like the XML one) and and seeing if you can get that one thing to
update/install ... once that works, you can go back and install more if
needed (or, just to confirm you got everything).

And ... if worse comes to worst ... the Java EE IDE package from Eclipse
download site is easiest.

HTH ... good luck!
Re: Install from repositories fails [message #669205 is a reply to message #668403] Mon, 09 May 2011 13:24 Go to previous message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 155
Registered: July 2009
Senior Member
Thank you all for the replies.

It turns out that I hadn't the "Contact all update sites during install to find required software" box checked, which was likely the main source of trouble. I also tried with version 3.2.2 instead of 3.2.3, as Larry suggested.

Installation now running without trouble. Thank you very much,

Luís
Previous Topic:Adding a Java XSLT Processor
Next Topic:Update Project Explorer with new contents of war file
Goto Forum:
  


Current Time: Sat Dec 20 16:39:49 GMT 2014

Powered by FUDForum. Page generated in 0.01688 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software