Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP product: start issues / missing classes or resources in org.eclipse.osgi
RCP product: start issues / missing classes or resources in org.eclipse.osgi [message #664510] Sun, 10 April 2011 14:19 Go to next message
AvH  is currently offline AvH Friend
Messages: 7
Registered: April 2010
Junior Member
Hi!

I work on a product based on Eclipse RCP and I like it, as long as it stays in my workspace. However I really have serious troubles as soon as I try to export it as a product and run it like that.

First problem was an external library (jar) which I added to my plugin. To be more exact, I have a main plugin which depends on another plugin which includes a jar file. I learned about the differences between plugin dependencies and imported packages, found that buddy policies are a cool thing, and got everything working in my workspace. As soon as I export, the app won't start. Classes from the jar are not found. I have no idea why, because I really read and tried everything.

I ended up with merging the external jar directly into my plugin, which was possible since it was a jar which I wrote myself. Starting my app afterwards does not work either, it has some troubles finding other resources (see below for error message).

During my tries I found that with each start, the app creates a folder org.eclipse.osgi in the configuration folder. This folder remains empty all the times. I think this may be a hint about what's going wrong. Once I copied accidently this folder to my test machine which was not empty, and my app was working. It took me a day to notice that this was not because of my changes, but only because of the contents of the directory "org.eclipse.osgi". I looked inside and found some structure with jars and resources.

Putting this together, I think that eclipse unzips its plugins when starting and copies all resources in there. With my app something goes wrong, which is not written in the log or anywhere else, and so all I get is the missing class or resources error.

Please gimme a hint! I already checked read/write rights on the filesystem but this all seems ok. I have no idea and feel like I tried everything twice!

Alexander

!SESSION 2011-04-10 15:59:35.840 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_14
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2011-04-10 15:59:40.199
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
at org.eclipse.jface.resource.URLImageDescriptor.getFilePath(UR LImageDescriptor.java:138)
at org.eclipse.jface.resource.URLImageDescriptor.createImage(UR LImageDescriptor.java:157)
at org.eclipse.jface.resource.ImageDescriptor.createImage(Image Descriptor.java:227)
at org.eclipse.jface.resource.ImageDescriptor.createImage(Image Descriptor.java:205)
at org.eclipse.ui.internal.Workbench.initializeImages(Workbench .java:1487)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.ja va:539)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at my.little.Application.start(Application.java:25)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
Re: RCP product: start issues / missing classes or resources in org.eclipse.osgi [solved] [message #664561 is a reply to message #664510] Mon, 11 April 2011 07:47 Go to previous message
AvH  is currently offline AvH Friend
Messages: 7
Registered: April 2010
Junior Member
Well, writing things to a message board sometimes helps.

The problem was finally found in the config.ini, where the configuration dir was specified as "readOnly"...

Since it seems crucial for any eclipse app to create files here, I do not understand the reason for this option. However I learned something how eclipse apps work Smile

Cheers,
Alexander

[Updated on: Mon, 11 April 2011 07:47]

Report message to a moderator

Previous Topic:make update site( https protocol)
Next Topic:Perspective bar to the left of Coolbar
Goto Forum:
  


Current Time: Sat Dec 20 23:53:19 GMT 2014

Powered by FUDForum. Page generated in 0.07480 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software