Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » How to debug JavaScript(I'm having trouble starting a debug session using Rhino)
How to debug JavaScript [message #661506] Thu, 24 March 2011 20:06
Theodore Norvell is currently offline Theodore Norvell
Messages: 1
Registered: March 2011
Junior Member
I'm getting errors on launching a debug session for a JavaScript project.
This happens on both Win 7 and Mac OS X 10.6.

Here is what I did on Win 7. I downloaded a fresh copy of
eclipse-javascript-helios-SR2-win32

and started eclipse. I created a new JavaScript project and created .js file with a short script in it. Set a breakpoint. (fig 0)

Then I created a JavaScript debug configuration with the following parameters Connector: "Mozilla Rhino -- Attaching Connector", Port: 9000, Host: localhost, Source Lookup Path: Default. (fig 1)

On launching the configuration, I get the following message
    Problem Occurred
       'Launching tryrhino' has encountered a problem.
       Error occured while launching
           [OK] [ <<Details]
         Error occured while launching
            Connection refused: connect

(fig2)

Any help would be greatly appreciated.
Previous Topic:Reload a webapp? (module start/stop/restart grayed out)
Next Topic:Failed to create Java virtual machine-Eclipse Halios EE
Goto Forum:
  


Current Time: Fri Jul 25 07:23:07 EDT 2014

Powered by FUDForum. Page generated in 0.01582 seconds