Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Import target definition problem with plugin version conflict
Import target definition problem with plugin version conflict [message #661341] Thu, 24 March 2011 06:23 Go to next message
Dao Hoang is currently offline Dao Hoang
Messages: 12
Registered: October 2010
Junior Member

Hi,

I have 2 target platforms and my workspace is using both at once.
Plugin org.apache.commons.logging is included in both target directory. One is 1.0.04v201005080501 , one is 1.1.1v201005080502.

When importtargetdefinition I got an warning :
[WARNING 0005]: Component request org.apache.commons.logging :osgi.bundle[1.0.4v201005080501] is inconflct with request org.apache.commons.logging:osgi.bundle[1.1.1v201005080502]

With Buckminster installed from Mid Dec-2010 , the build continues and build successed.
But with current Buckminster, the upper version org.apache.commons.logging_1.1.1v2010205080502 is required to import to workspace. Consequence, I got error when importing resource :" Unable to find SearchPath for org.apache.commons.logging..."

In case, I want to keep both versions of this plugins in target platform. Is there any way to to let Bucky accept that?

Thanks in advance,
Hoang
Re: Import target definition problem with plugin version conflict [message #661351 is a reply to message #661341] Thu, 24 March 2011 06:41 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3228
Registered: July 2009
Senior Member
On 2011-03-24 11:23, Dao Hoang wrote:
> Hi,
>
> I have 2 target platforms and my workspace is using both at once.

I doubt that. The PDE target platform manager (and Buckminster) will only allow one active target platform at a time.

> Plugin org.apache.commons.logging is included in both target directory. One is 1.0.04v201005080501 , one is
> 1.1.1v201005080502.
>
> When importtargetdefinition I got an warning :
> [WARNING 0005]: Component request org.apache.commons.logging :osgi.bundle[1.0.4v201005080501] is inconflct with request
> org.apache.commons.logging:osgi.bundle[1.1.1v201005080502]
>
> With Buckminster installed from Mid Dec-2010 , the build continues and build successed.
> But with current Buckminster, the upper version org.apache.commons.logging_1.1.1v2010205080502 is required to import to
> workspace. Consequence, I got error when importing resource :" Unable to find SearchPath for org.apache.commons.logging..."
>
> In case, I want to keep both versions of this plugins in target platform. Is there any way to to let Bucky accept that?
> Thanks in advance,
> Hoang

Bucky does accept that. What you see is a warning, not an error and it shouldn't be the cause of the "unable to find
SearchPath" message.

You should be aware though, that even if Bucky accepts it, chances are high that the target platform will never make the
lower version available to the build.

- thomas
Re: Import target definition problem with plugin version conflict [message #661356 is a reply to message #661351] Thu, 24 March 2011 07:04 Go to previous messageGo to next message
Dao Hoang is currently offline Dao Hoang
Messages: 12
Registered: October 2010
Junior Member

Thanks for your quick answer.
Bucky accepts both versions of the plugin. But as you said, the lower version may be not available in target platform with high chance. But in my case, the greater version seems to be not available and it is required to import to workspace. My searchPath, off couse, are not provided for target plug-ins.

I did not get any trouble with older version of Bucky.
Do you have any advise to make the build run again?

Thanks so much,
Hoang


Smile Smile
Re: Import target definition problem with plugin version conflict [message #661362 is a reply to message #661356] Thu, 24 March 2011 07:15 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3228
Registered: July 2009
Senior Member
On 2011-03-24 12:04, Dao Hoang wrote:
> Thanks for your quick answer.
> Bucky accepts both versions of the plugin. But as you said, the lower version may be not available in target platform
> with high chance. But in my case, the greater version seems to be not available and it is required to import to
> workspace. My searchPath, off couse, are not provided for target plug-ins.
>
> I did not get any trouble with older version of Bucky.

If you had an older version of Bucky, it's likely that you also had an older version of things that Bucky relies on (the
PDE target platform manager for instance), so pinning down exactly what's causing this behavior is difficult.

> Do you have any advise to make the build run again?
>
Unless you tell it not to, Buckminster will consult the *currently active* target platform during resolution. Is the
higher version of the bundle available there? I.e. can you see it being present when you view the active target platform
content using Preferences -> Plug-in Development -> Target Platform ?

- thomas
Re: Import target definition problem with plugin version conflict [message #661547 is a reply to message #661362] Fri, 25 March 2011 05:15 Go to previous messageGo to next message
Dao Hoang is currently offline Dao Hoang
Messages: 12
Registered: October 2010
Junior Member

> Is the higher version of the bundle available there?
> I.e. can you see it >being present when you view the active target
> platform content using Preferences -> Plug-in Development -> Target Platform ?

Sorry for my unclear description.
I meant that I have 2 target directories and used both of them in target platform. So the plug-ins duplication happened. This target platform is active and I can see both versions of the plugin in target platform.
But why Bucky asks to import it ( in my case it is the greater version) to workspace while both versions are available in target platform? Even though if only one is available, the greater version should be the one as you said. So I put a question in quite strange behavior.

Thanks,


Smile Smile
Re: Import target definition problem with plugin version conflict [message #661565 is a reply to message #661547] Fri, 25 March 2011 07:41 Go to previous message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3228
Registered: July 2009
Senior Member
On 2011-03-25 10:15, Dao Hoang wrote:
>> Is the higher version of the bundle available there? I.e. can you see it >being present when you view the active
>> target platform content using Preferences -> Plug-in Development -> Target Platform ?
>
> Sorry for my unclear description.
> I meant that I have 2 target directories and used both of them in target platform. So the plug-ins duplication happened.
> This target platform is active and I can see both versions of the plugin in target platform. But why Bucky asks to
> import it ( in my case it is the greater version) to workspace while both versions are available in target platform?

The error comes when Buckminster resolver ensures that the bundle can be found. If it is found in the TP, no import will
be done, so that part is probably OK.

> Even though if only one is available, the greater version should be the one as you said. So I put a question in quite
> strange behavior.
>
I can take a look if you care to create an example that contains a target platform definition and projects needed to
reproduce the error and attach that to a bugzilla.

- thomas
Previous Topic:Howto exclude packages from the emma coverage report
Next Topic:target platform materialization with zipped components
Goto Forum:
  


Current Time: Fri Aug 22 08:00:39 EDT 2014

Powered by FUDForum. Page generated in 0.12753 seconds