Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Components' properties(Customizing components properties via XML)
icon5.gif  Components' properties [message #657637] Thu, 03 March 2011 14:31 Go to next message
Funkl is currently offline Funkl
Messages: 5
Registered: February 2011
Junior Member
Hello,

i've troubles customizing a components' properties via the XML-file *.wbp-component.xml. I've configured it's description via the XML, which is correctly displayed in the components palette. Further i've tried to customize its properties (preferred, advanced and hidden) via the XML which is ignored all the time. In elder WindowBuilder versions (7.1, 8.1) the customization of properties worked that way.
Was there anything changed? Is there a documentation for the new WindowBuilder available (not found any so far)?

Regards,
Martin

MyJComponent.wbp-component.xml:
<?xml version="1.0" encoding="UTF-8"?>
<component xmlns="http://www.instantiations.com/D2/WBPComponent">
	<description>
	   Testkomponenten fuer die Sichtbarkeit von Feldern
	</description>
	<properties-advanced names="state font" />
</component>

Re: Components' properties [message #658573 is a reply to message #657637] Wed, 09 March 2011 03:30 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric Clayberg
Messages: 860
Registered: July 2009
Location: Boston, MA
Senior Member
Nothing has changed in the latest WindowBuilder release, so the docs have not changed.

We would need to see a complete test case in order to investigate the problem you are having.
Re: Components' properties [message #659461 is a reply to message #658573] Mon, 14 March 2011 07:20 Go to previous message
Funkl is currently offline Funkl
Messages: 5
Registered: February 2011
Junior Member
Hello,

i could locate the problem myself - a package called "org.eclipse.wb.swing.ams_xxx" caused some strange behaviour with configuring my components. The solution: simply deleting it from the windowbuilder installation.

Thanks,
Martin
Previous Topic:Trouble installing d2wbpro from the update sites URL
Next Topic:Nebula
Goto Forum:
  


Current Time: Tue Sep 23 12:33:13 GMT 2014

Powered by FUDForum. Page generated in 0.01760 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software