Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Prepackaging Eclipse with my plug-in(Trouble deploying Eclipse with my plug-in baked-in)
Prepackaging Eclipse with my plug-in [message #648354] Wed, 12 January 2011 10:04
Joey Mink is currently offline Joey Mink
Messages: 87
Registered: July 2009
Location: Centreville, VA, USA
Member

Hi,

We have a nightly build that:

  1. Builds our feature and plug-ins
  2. Extracts an Eclipse Helios zip file (as obtained from http://eclipse.org/downloads)
  3. Copies our feature and plug-ins to the eclipse/plugins and eclipse/features directory
  4. Rezips Eclipse up for distribution


We've been using this for a while internally and it works great - our plug-in is there and initializes the 1st time Eclipse is run.

However, we just tried installing it into c:\Program Files\... for the first time, and ran into the read-only issues that arise in Windows Vista/7/etc (I believe they call it "Virtual Store"). Basically, Eclipse doesn't find our feature/plug-in like it usually does.

I can see that Eclipse recognized its configuration directory was read-only, and it creates c:\Users\<user>\.eclipse\... and puts some stuff in there. But it has absolutely no reaction to our prepackaged feature and plug-ins.

Can anyone recommend a better way for us to add our feature/plug-ins to an Eclipse zip file that will be deployed to c:\Program Files?

Thanks!
Previous Topic:Error handling in RCP, especially on Workbench Parts
Next Topic:Data Source Explorer in RCP Application
Goto Forum:
  


Current Time: Fri Apr 18 14:25:49 EDT 2014

Powered by FUDForum. Page generated in 0.02847 seconds