Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Install failed for bundle ### version '0.0.0'.(Problem by bundle installation into Virgo server.)
Install failed for bundle ### version '0.0.0'. [message #640014] Thu, 18 November 2010 11:40 Go to next message
Bojan Kraut is currently offline Bojan Kraut
Messages: 22
Registered: July 2009
Location: Maribor
Junior Member

When deploying par to Virgo server, I get folloving. error:

[2010-11-18 17:25:17.267] TCP Connection(34)-127.0.0.1 <DE0003E> Install failed for bundle 'objectverse.core' version '0.0.0'. 
[2010-11-18 17:25:17.271] TCP Connection(34)-127.0.0.1 <DE0003E> Install failed for bundle 'objectverse-1-objectverse.web' version '1.0.0'. 
[2010-11-18 17:25:17.276] TCP Connection(34)-127.0.0.1 <DE0003E> Install failed for par 'objectverse' version '1.0.0'. 


I checked all bundles and they all have version 1.0.0 defined.

Where could I search an error for objectverse.core 0.0.0. Why is bundle number wrong?

Best regrads,
Bojan
Re: Install failed for bundle ### version '0.0.0'. [message #640015 is a reply to message #640014] Thu, 18 November 2010 11:44 Go to previous messageGo to next message
Dmitry Sklyut is currently offline Dmitry Sklyut
Messages: 272
Registered: January 2010
Senior Member
Mind showing your manifests for those bundles?
Re: Install failed for bundle ### version '0.0.0'. [message #640066 is a reply to message #640014] Thu, 18 November 2010 16:55 Go to previous messageGo to next message
Bojan Kraut is currently offline Bojan Kraut
Messages: 22
Registered: July 2009
Location: Maribor
Junior Member

I found out why this happens. I'm using the same structure as the greenpages. I have META-INF directory in src/main/resources. The problem is when bundle is deployed into the Virgo server, the META-INF directory with the MANTIFEST.MF is deployed into the WEB-INF folder. I have no ideas why, I'm suspecting that .classpath file has some missconfiguration.

Did this happen to somebody else?
Thanx.
Re: Install failed for bundle ### version '0.0.0'. [message #640093 is a reply to message #640066] Thu, 18 November 2010 23:40 Go to previous messageGo to next message
guofeng zhang is currently offline guofeng zhang
Messages: 49
Registered: July 2009
Member
I solved it by the following:
      <plugin>
	 <groupId>com.springsource.bundlor</groupId>
         <artifactId>com.springsource.bundlor.maven</artifactId>
         <version>1.0.0.RELEASE</version>
         <executions>
            <execution>
               <id>bundlor</id>
               <goals>
                 <goal>bundlor</goal>
               </goals>
               <phase>process-classes</phase>
            </execution>
         </executions>
      </plugin>

      <plugin>
         <groupId>org.apache.maven.plugins</groupId>
         <artifactId>maven-war-plugin</artifactId>
         <version>2.1</version>
         <configuration>
              <archive>
                  <manifestFile>${project.build.outputDirectory}/META-INF/MANIFEST.MF</manifestFile>
              </archive>
             <!--packagingExcludes>WEB-INF/classes/META-INF/MANIFEST.MF,WEB-INF/lib/**</packagingExcludes-->
         </configuration>
      </plugin>
Re: Install failed for bundle ### version '0.0.0'. [message #640198 is a reply to message #640093] Fri, 19 November 2010 09:33 Go to previous messageGo to next message
Bojan Kraut is currently offline Bojan Kraut
Messages: 22
Registered: July 2009
Location: Maribor
Junior Member

I tried your solution and it didn't work for me.

Anyway I was digging a little deeper and found out that there is a problem in the project file .settings/org.eclipse.wst.common.component. In this file there are following lines:

<?xml version="1.0" encoding="UTF-8"?>
<project-modules id="moduleCoreId" project-version="1.5.0">
	<wb-module deploy-name="objectverse.web">
		<wb-resource deploy-path="/" source-path="/src/main/webapp"/>
		<wb-resource deploy-path="/WEB-INF/classes" source-path="/src/main/java"/>
		<wb-resource deploy-path="/" source-path="/src/main/resources"/>
		<wb-resource deploy-path="/WEB-INF/classes" source-path="/src/test/java"/>
		<wb-resource deploy-path="/WEB-INF/classes" source-path="/src/test/resources"/>
        <dependent-module deploy-path="/WEB-INF/lib" handle="module:/resource/objectverse.core/objectverse.core">
            <dependency-type>uses</dependency-type>
        </dependent-module>
		<property name="context-root" value="objectverse"/>
		<property name="java-output-path"/>
	</wb-module>
</project-modules>

If deploy path is incorrect the files are deployed in the wrong directory. I corrected it and now everything works.

The case is that I didn't change this in the beggining, but I noticed several times that occasionaly something happens in Eclipse project files configuration. I don't know - maybe it is some sort of bug.

Hope it helps someone else.

Bojan
Re: Install failed for bundle ### version '0.0.0'. [message #760458 is a reply to message #640198] Fri, 02 December 2011 07:53 Go to previous message
karthik elavan is currently offline karthik elavan
Messages: 70
Registered: August 2011
Location: Chennai
Member
can you please help me now i am using virgo server and spring osgi technology it's working with fine for version 2.1.0 and 2.1.1 but still now i move to 3.0.0 and 3.0.2 version having bundle web application failed issue how can i solve it? please help me

I had create war file deploy the virgo 2.1.0 and 2.1.1 is load and working fine but i using higher version for 3.0.0 and 3.0.2 it's not working any workaround for my application or server side?

[Updated on: Fri, 02 December 2011 07:55]

Report message to a moderator

Previous Topic:Is Virgo web container capable of using OSGI bundles?
Next Topic:How to detect log4j config file in bundle fragment
Goto Forum:
  


Current Time: Sat Aug 30 22:37:23 EDT 2014

Powered by FUDForum. Page generated in 0.01922 seconds