Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » New Install "Not a valid win32 application"(Can't get Eclipse Helios to run first php test scripts)
New Install "Not a valid win32 application" [message #637619] Sun, 07 November 2010 23:56
bluepost22  is currently offline bluepost22
Messages: 2
Registered: November 2010
Junior Member
Just installed Eclipse Helios on Windows XP.

I can't execute the first PHP test script.

I get :

Cannot Run Program
c:\(long path to a php script)\xyz.php
Createprocess error=193, %1 is not a valid Win32 application.

It looks to me like something is trying to run xyz.php as the php interpeter itself, or as some Win32 app.

xyz.php is the very first test script that I opened with Eclipse.

The windows PATH looks ok, and the path to php.exe is the first path. It is set in Eclipse Window/Preferences/PHP/PHP Executables.

The path to xyz.php is not in the windows PATH.

I've done a complete new re-install and the same thing occurs, so somehow Eclipse is maintaining the same bad idea about where to execute PHP from, if that is indeed the problem.

I'm using WAMP 2.0 with PHP 5.3, running test scripts and CakePHP successfully. Also evaluating Nusphere and that runs ok, along with Cygwin.

Any ideas?

Thanks,
bluepost

Previous Topic:PDT/Zend Framework/Debugging
Next Topic:How can I get three IDEs into one?
Goto Forum:
  


Current Time: Wed Oct 01 14:33:23 GMT 2014

Powered by FUDForum. Page generated in 0.03121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software