Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Cannot install nightly build
Cannot install nightly build [message #632872] Thu, 14 October 2010 10:27 Go to next message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
I would like to test the new features in the nightly build, but get errors when attempting to install from a local update site. Is this build compatible with Helios? Is anyone else able to install a nightly build?

Thanks,
Dave Carlson
Re: Cannot install nightly build [message #632894 is a reply to message #632872] Thu, 14 October 2010 11:25 Go to previous messageGo to next message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
A part of the .log is copied here. It appears that there is a conflict in required versions of GEF. Doe 0.7.1 require a new unreleased version of GEF?

!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2010-10-14 08:21:37.796
!MESSAGE Software being installed: MDT Papyrus - Activity Diagram editor 0.7.1.v201010140458 (org.eclipse.papyrus.diagram.activity.feature.group 0.7.1.v201010140458)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2010-10-14 08:21:37.796
!MESSAGE Software currently installed: Graphical Editing Framework GEF SDK 3.6.0.v20100519-2050-7G7R-A5WNc7QL_fXBGjRZPUUiKPJ (org.eclipse.gef.sdk.feature.group 3.6.0.v20100519-2050-7G7R-A5WNc7QL_fXBGjRZPUUiKPJ)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2010-10-14 08:21:37.796
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2010-10-14 08:21:37.796
!MESSAGE Graphical Editing Framework GEF 3.6.0.v20100525-1225 (org.eclipse.gef 3.6.0.v20100525-1225)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2010-10-14 08:21:37.796
!MESSAGE Graphical Editing Framework GEF 3.6.1.v20100712-1224 (org.eclipse.gef 3.6.1.v20100712-1224)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2010-10-14 08:21:37.796
!MESSAGE Cannot satisfy dependency:
Re: Cannot install nightly build [message #633998 is a reply to message #632894] Wed, 20 October 2010 04:40 Go to previous message
Remi Schnekenburger is currently offline Remi Schnekenburger
Messages: 127
Registered: July 2009
Senior Member
Hi Dave,

We use only released version of the tools. For the current nightly build, we use generally the 3.6 SR1 version of the tools.

I add difficulties in the past to correctly set the dependencies in the Hudson nightly build. They have been fixed since a few days.
Could you try again with the latest version and tell me if every thing worked well?

Thanks,
RĂ©mi


Previous Topic:Refresh Component view
Next Topic:How to create UML elements from own popupactions
Goto Forum:
  


Current Time: Wed Jul 23 18:19:19 EDT 2014

Powered by FUDForum. Page generated in 0.03271 seconds