Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How to upgrade to 2.2.1?(Guidance requested to upgrade to bug solution)
How to upgrade to 2.2.1? [message #632024] Mon, 11 October 2010 09:09 Go to next message
Iain Houston is currently offline Iain Houston
Messages: 3
Registered: September 2010
Junior Member
I filed a bug I came across in PDT available from Eclipse download page (Build 20100917-0705). Apparently there is a fix for this bug included in Eclipse 2.2.1.
How do I upgrade to 2.2.1 without destroying all the plugins and settings in my Eclipse configuration?
Is there some way I can add a 2.2.1 "Available Software Site" so that updates are obtained from there?
The official PDT download site's latest release is 2.1.

I'd be very grateful for guidance out of my confusion! Thanks.


Using Eclipse PDT on Mac OS X to develop and debug Drupal modules on Ubuntu Linux.
icon14.gif  [Solved] How to upgrade to 2.2.1 [message #632436 is a reply to message #632024] Tue, 12 October 2010 22:13 Go to previous message
Iain Houston is currently offline Iain Houston
Messages: 3
Registered: September 2010
Junior Member
Help was given in the bug report.
Upgrade was achieved by adding: http://download.eclipse.org/tools/pdt/updates/2.2/milestones to Preferences >> Install/Update >> Available Software Sites.
Then "work with" this site in Help >> Install New Software
Select "Name" PDT 2.2.1 .....
Click Next and complete the download and update (restart required).
This seems to have fixed the problem and now remote debugging seems to be working.


Using Eclipse PDT on Mac OS X to develop and debug Drupal modules on Ubuntu Linux.

[Updated on: Tue, 12 October 2010 22:14]

Report message to a moderator

Previous Topic:Project -> Properties -> HTML Preview Where is PHP equivalent?
Next Topic:Error in debugger settings
Goto Forum:
  


Current Time: Tue Sep 16 01:01:03 GMT 2014

Powered by FUDForum. Page generated in 0.01651 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software