Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » problem installing the 64 bit (3.6.1)
problem installing the 64 bit (3.6.1) [message #630808] Tue, 05 October 2010 02:45 Go to next message
za  is currently offline za
Messages: 2
Registered: October 2010
Junior Member
When starting eclipse, it did not find Java. I manually added C:\Windows\SysWOW64 to the path. Now the program started but returned these messages (below). I have a 64 bit Windows 7 home premium. (the 32 bit version works fine both on this computer and on a 32 bit machine.) Any ideas?

Java was started but returned exit code=13
C:\Windows\SysWOW64\java.exe
-Xms40m
-Xmx384m
-XX:MaxPermSize=256m
-jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar
-os win32
-ws win32
-arch x86_64
-showsplash
-launcher C:\eclipse\eclipsec.exe
-name Eclipsec
--launcher.library C:\eclipse\plugins/org.eclipse.equinox.launcher.win32.win32. x86_64_1.1.1.R36x_v20100810\eclipse_1309.dll
-startup C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar
-exitdata 1238_50
-vm C:\Windows\SysWOW64\java.exe
-vmargs
-Xms40m
-Xmx384m
-XX:MaxPermSize=256m
-jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar
Re: problem installing the 64 bit (3.6.1) [message #630903 is a reply to message #630808] Tue, 05 October 2010 10:32 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3168
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2010.10.05 0:45, za wrote:
> When starting eclipse, it did not find Java. I manually added
> C:\Windows\SysWOW64 to the path. Now the program started but returned
> these messages (below). I have a 64 bit Windows 7 home premium. (the 32
> bit version works fine both on this computer and on a 32 bit machine.)
> Any ideas?
>
> Java was started but returned exit code=13
> C:\Windows\SysWOW64\java.exe
> -Xms40m
> -Xmx384m
> -XX:MaxPermSize=256m
> -jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar
> -os win32
> -ws win32
> -arch x86_64
> -showsplash
> -launcher C:\eclipse\eclipsec.exe
> -name Eclipsec
> --launcher.library
> C:\eclipse\plugins/org.eclipse.equinox.launcher.win32.win32.
> x86_64_1.1.1.R36x_v20100810\eclipse_1309.dll
> -startup C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100
> 507.jar
> -exitdata 1238_50
> -vm C:\Windows\SysWOW64\java.exe
> -vmargs
> -Xms40m
> -Xmx384m
> -XX:MaxPermSize=256m
> -jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar

1) Don't attempt to run Eclipse off anything but a Sun JDK you've
freshly downloaded when you set up Eclipse. You can, but it's not in my
opinion "best practice". Right now, that means downloading, whether
32-bit or 64-bit, jdk1.6.0_21 from the Sun Java site. I even suggest
downloading and not actually installing the JDK, but keeping it as a
private copy for use only by Eclipse. This frees you from anything going
on in the rest of your computer host.

2) Remember: Ensure that your Eclipse and your JDK are of identical
bittedness.

3) I assume that the lack of a newline in your -mv argument above is an
artifact of copying and pasting. There should be one. See
http://wiki.eclipse.org/Eclipse.ini

I hope this helps.
Re: problem installing the 64 bit (3.6.1) [message #631705 is a reply to message #630808] Fri, 08 October 2010 10:05 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2235
Registered: July 2009
Senior Member
On 10/5/10 2:45 AM, za wrote:
> When starting eclipse, it did not find Java. I manually added
> C:\Windows\SysWOW64 to the path. Now the program started but returned
> these messages (below). I have a 64 bit Windows 7 home premium. (the 32
> bit version works fine both on this computer and on a 32 bit machine.)
> Any ideas?
>
> Java was started but returned exit code=13
> C:\Windows\SysWOW64\java.exe
> -Xms40m
> -Xmx384m
> -XX:MaxPermSize=256m
> -jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar
> -os win32
> -ws win32
> -arch x86_64
> -showsplash
> -launcher C:\eclipse\eclipsec.exe
> -name Eclipsec
> --launcher.library
> C:\eclipse\plugins/org.eclipse.equinox.launcher.win32.win32.
> x86_64_1.1.1.R36x_v20100810\eclipse_1309.dll
> -startup C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100
> 507.jar
> -exitdata 1238_50
> -vm C:\Windows\SysWOW64\java.exe
> -vmargs
> -Xms40m
> -Xmx384m
> -XX:MaxPermSize=256m
> -jar C:\eclipse\plugins/org.eclipse.equinox.launcher_1.1.0.v20100 507.jar

It looks like you might be trying to run 32-bit Eclipse on a 64-bit
JVM/JDK. That won't work. Either use a 32-bit Java or download 64-bit
Eclipse.

Eric
Re: problem installing the 64 bit (3.6.1) [message #631791 is a reply to message #631705] Fri, 08 October 2010 14:38 Go to previous messageGo to next message
za  is currently offline za
Messages: 2
Registered: October 2010
Junior Member
I followed Russell Bateman advice and it worked. I loaded the 64 bit JDK as I should have. The Eclipse is and was the 64 bit all the time.

the problem in -vm line is not due to any error of mine, this is what the unzip/installation had, but I did not have to touch that at all.

Thank you all
ZA

[Updated on: Fri, 08 October 2010 14:39]

Report message to a moderator

Re: problem installing the 64 bit (3.6.1) [message #722116 is a reply to message #631791] Sun, 04 September 2011 09:59 Go to previous messageGo to next message
Yashwanth  is currently offline Yashwanth
Messages: 1
Registered: September 2011
Junior Member
I have the same problem. I'm jus a beginner and i don't know what to do. Please help.
Thanls Smile
Re: problem installing the 64 bit (3.6.1) [message #722134 is a reply to message #722116] Sun, 04 September 2011 11:43 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3168
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2011.09.04 7:59, Yashwanth wrote:
> I have the same problem. I'm jus a beginner and i don't know what to do.
> Please help.
> Thanls :)

If you don't feel that the information already given in the thread is
enough, consider perusing
http://www.javahotchocolate.com/tutorials/eclipse-summary.html

....or, come back to this forum and ask specific questions (not under
this thread, but under a new one you create).
Re: problem installing the 64 bit (3.6.1) [message #956504 is a reply to message #630903] Wed, 24 October 2012 11:12 Go to previous message
Ahmet Ekrem SABAN is currently offline Ahmet Ekrem SABAN
Messages: 12
Registered: April 2011
Location: Austria
Junior Member
Good answer! I had downloaded a 64-bit JRE & a 32-bit eclipse. Making the latter 64 bit solved the problem. Razz

Best regards!
Ekrem
Previous Topic:Troubles getting a build to work.
Next Topic:Failed to install Package of "Eclipse IDE for C/C++ Developers"
Goto Forum:
  


Current Time: Tue Sep 02 13:02:24 EDT 2014

Powered by FUDForum. Page generated in 0.03433 seconds