Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » B3 » UnsupportedOperationException with 3 repositories
UnsupportedOperationException with 3 repositories [message #630112] Thu, 30 September 2010 16:31 Go to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello,

I'm still trying to mirror the eclipse helios update sites with the b3
aggregator.

Until now I was able to mirror the one repository on
http://download.eclipse.org/releases/helios/

Now I use a contribution with 3 mapped repositories:
- http://download.eclipse.org/releases/helios/
- http://download.eclipse.org/eclipse/updates/3.6/
- http://download.eclipse.org/technology/epp/packages/helios/

trying to run CLEAN_BUILD I only get this error:

Loading all repositories
Starting generation of composite repository Adding child meta-data
repository http://download.eclipse.org/releases/helios Adding child
meta-data repository http://download.eclipse.org/eclipse/updates/3.6
Adding child meta-data repository
http://download.eclipse.org/technology/epp/packages/helios Done. Took 0
seconds Starting generation of verification feature
Done. Took 0 seconds Starting generation of categories Build failed!
Exception was java.lang.UnsupportedOperationException:
java.lang.UnsupportedOperationException Finished: FAILURE

Where is my mistake?

Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #630164 is a reply to message #630112] Thu, 30 September 2010 20:45 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
Hi,

this does not look like your mistake :-)

Could you please enter a bugzilla issue and attach your b3aggr file so that both of us would work with exactly the same thing?

In addition to this, let me know which version of b3 aggregator you are using. Thanks.


I will look into that in the beginning of next week (I can't make it by the end of this week, sorry).

Regards
Filip


Dne 30.9.2010 18:31, Lars Fischer napsal(a):
> Hello,
>
> I'm still trying to mirror the eclipse helios update sites with the b3 aggregator.
>
> Until now I was able to mirror the one repository on http://download.eclipse.org/releases/helios/
>
> Now I use a contribution with 3 mapped repositories:
> - http://download.eclipse.org/releases/helios/
> - http://download.eclipse.org/eclipse/updates/3.6/
> - http://download.eclipse.org/technology/epp/packages/helios/
>
> trying to run CLEAN_BUILD I only get this error:
>
> Loading all repositories
> Starting generation of composite repository Adding child meta-data repository http://download.eclipse.org/releases/helios Adding child meta-data repository http://download.eclipse.org/eclipse/updates/3.6 Adding child meta-data repository http://download.eclipse.org/technology/epp/packages/helios Done. Took 0 seconds Starting generation of verification feature
> Done. Took 0 seconds Starting generation of categories Build failed! Exception was java.lang.UnsupportedOperationException: java.lang.UnsupportedOperationException Finished: FAILURE
>
> Where is my mistake?
>
> Regards,
> Lars
>
Re: UnsupportedOperationException with 3 repositories [message #630220 is a reply to message #630164] Fri, 01 October 2010 08:14 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello Filip,

On 30.09.2010 22:45, Filip Hrbek wrote:
> this does not look like your mistake :-)

Puh... ;)


> Could you please enter a bugzilla issue and attach your b3aggr file so
> that both of us would work with exactly the same thing?
>
> In addition to this, let me know which version of b3 aggregator you are
> using. Thanks.

I filed a new issue at https://bugs.eclipse.org/bugs/show_bug.cgi?id=326742


> I will look into that in the beginning of next week (I can't make it by
> the end of this week, sorry).

Next week would be soon enough. Thank you very much!


Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #632104 is a reply to message #630220] Mon, 11 October 2010 14:36 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello Filip,

I apologize for asking again.

On 01.10.2010 10:14, Lars Fischer wrote:
>
>> Could you please enter a bugzilla issue and attach your b3aggr file so
>> that both of us would work with exactly the same thing?
> >
>> In addition to this, let me know which version of b3 aggregator you are
>> using. Thanks.
>
> I filed a new issue at https://bugs.eclipse.org/bugs/show_bug.cgi?id=326742

Is there something else, what I could provide to you?

Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #632170 is a reply to message #632104] Mon, 11 October 2010 21:09 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
I think I have all I need, I just need to find some time. Hopefully tomorrow.

Filip

Dne 11.10.2010 16:36, Lars Fischer napsal(a):
> Hello Filip,
>
> I apologize for asking again.
>
> On 01.10.2010 10:14, Lars Fischer wrote:
>>
>>> Could you please enter a bugzilla issue and attach your b3aggr file so
>>> that both of us would work with exactly the same thing?
>> >
>>> In addition to this, let me know which version of b3 aggregator you are
>>> using. Thanks.
>>
>> I filed a new issue at https://bugs.eclipse.org/bugs/show_bug.cgi?id=326742
>
> Is there something else, what I could provide to you?
>
> Regards,
> Lars
>
Re: UnsupportedOperationException with 3 repositories [message #632505 is a reply to message #632104] Wed, 13 October 2010 09:04 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
Hello Lars,

I have found & fixed the bug. However, we have problems setting up a hudson build for updating the site on the new Eclipse build server. Stay tuned, I hope we'll fix it within a few days.

Regards,

Filip


On 11.10.2010 16:36, Lars Fischer wrote:
> Hello Filip,
>
> I apologize for asking again.
>
> On 01.10.2010 10:14, Lars Fischer wrote:
>>
>>> Could you please enter a bugzilla issue and attach your b3aggr file so
>>> that both of us would work with exactly the same thing?
>> >
>>> In addition to this, let me know which version of b3 aggregator you are
>>> using. Thanks.
>>
>> I filed a new issue at https://bugs.eclipse.org/bugs/show_bug.cgi?id=326742
>
> Is there something else, what I could provide to you?
>
> Regards,
> Lars
>
Re: UnsupportedOperationException with 3 repositories [message #632515 is a reply to message #632505] Wed, 13 October 2010 09:37 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
On 13.10.2010 11:04, Filip Hrbek wrote:
>
> I have found & fixed the bug.

Thank you very much!


> However, we have problems setting up a
> hudson build for updating the site on the new Eclipse build server. Stay
> tuned, I hope we'll fix it within a few days.

No problem, I will watch this group.


Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #640504 is a reply to message #632515] Mon, 22 November 2010 11:25 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
On 13.10.2010 11:37, Lars Fischer wrote:
> On 13.10.2010 11:04, Filip Hrbek wrote:
>> However, we have problems setting up a
>> hudson build for updating the site on the new Eclipse build server. Stay
>> tuned, I hope we'll fix it within a few days.
>
> No problem, I will watch this group.

Are there any news about a new build?

Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #640521 is a reply to message #640504] Mon, 22 November 2010 12:24 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
Yes, we are already able to build it. The latest build is supposed to be published later today to the 3.6 update site, and we will also modify the build for 3.7milestones (currently there is a new build but it is actually based on 3.6 and we want to change it to 3.7).

I'll let you know when it all gets stable (hopefully later today).

Filip

Dne 22.11.2010 12:25, Lars Fischer napsal(a):
> On 13.10.2010 11:37, Lars Fischer wrote:
>> On 13.10.2010 11:04, Filip Hrbek wrote:
>>> However, we have problems setting up a
>>> hudson build for updating the site on the new Eclipse build server. Stay
>>> tuned, I hope we'll fix it within a few days.
>>
>> No problem, I will watch this group.
>
> Are there any news about a new build?
>
> Regards,
> Lars
>
>
Re: UnsupportedOperationException with 3 repositories [message #641083 is a reply to message #640521] Wed, 24 November 2010 08:36 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
The new build for 3.6 is now available. Please try it out to see if it fixes your problem.

Filip

Dne 22.11.2010 13:24, Filip Hrbek napsal(a):
> Yes, we are already able to build it. The latest build is supposed to be published later today to the 3.6 update site, and we will also modify the build for 3.7milestones (currently there is a new build but it is actually based on 3.6 and we want to change it to 3.7).
>
> I'll let you know when it all gets stable (hopefully later today).
>
> Filip
>
> Dne 22.11.2010 12:25, Lars Fischer napsal(a):
>> On 13.10.2010 11:37, Lars Fischer wrote:
>>> On 13.10.2010 11:04, Filip Hrbek wrote:
>>>> However, we have problems setting up a
>>>> hudson build for updating the site on the new Eclipse build server. Stay
>>>> tuned, I hope we'll fix it within a few days.
>>>
>>> No problem, I will watch this group.
>>
>> Are there any news about a new build?
>>
>> Regards,
>> Lars
>>
>>
>
Re: UnsupportedOperationException with 3 repositories [message #641120 is a reply to message #641083] Wed, 24 November 2010 10:10 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
On 24.11.2010 09:36, Filip Hrbek wrote:
> The new build for 3.6 is now available. Please try it out to see if it fixes your problem.

I was not able to install the new 3.6 build (0.1.0.r01408) from the
update site (http://download.eclipse.org/modeling/emft/b3/updates-3.6)
into my Eclipse 3.6.1:

Your original request has been modified.
"b3 Aggregator Editor (Incubation)" is already installed, so an
update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: b3 Aggregator Editor (Incubation)
0.1.0.r01408 (org.eclipse.b3.aggregator.editor.feature.feature.group
0.1.0.r01408)
Software currently installed: Eclipse for RCP and RAP Developers
1.3.0.20100617-0521 (epp.package.rcp 1.3.0.20100617-0521)
Only one of the following can be installed at once:
Core Resource Management 3.6.0.v20100526-0737
(org.eclipse.core.resources 3.6.0.v20100526-0737)
Core Resource Management 3.6.0.R36x_v20100825-0600
(org.eclipse.core.resources 3.6.0.R36x_v20100825-0600)
Cannot satisfy dependency:
From: Eclipse for RCP and RAP Developers 1.3.0.20100617-0521
(epp.package.rcp 1.3.0.20100617-0521)
To: org.eclipse.epp.package.rcp.feature.feature.group
[1.3.0.20100617-0521]
Cannot satisfy dependency:
From: b3 Aggregator Editor (Incubation) 0.1.0.r01408
(org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01408)
To: org.eclipse.b3.aggregator.engine.feature.feature.group
[0.1.0.r01408]
Cannot satisfy dependency:
From: b3 Aggregator Engine (Incubation) 0.1.0.r01408
(org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01408)
To: org.eclipse.core.resources [3.6.0.R36x_v20100825-0600]
Cannot satisfy dependency:
From: EPP RCP/RAP Feature 1.3.0.20100617-0521
(org.eclipse.epp.package.rcp.feature.feature.group 1.3.0.20100617-0521)
To: org.eclipse.platform.feature.group
[3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
Cannot satisfy dependency:
From: Eclipse Platform
3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
(org.eclipse.platform.feature.group
3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
To: org.eclipse.core.resources [3.6.0.v20100526-0737]

Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #641145 is a reply to message #641120] Wed, 24 November 2010 12:15 Go to previous messageGo to next message
Filip Hrbek is currently offline Filip HrbekFriend
Messages: 233
Registered: July 2009
Senior Member
The aggregator build is set up to include proper version of org.eclipse.core.resources (3.6.0.R36x_v20100825-0600) which would normally be considered as older than 3.6.0.v20100526-0737 but in fact it is not (see bug 327234). This could be fixed by upgrading epp.package.rcp if it is already available with the dependency modified to the newer org.eclipse.core.resources bundle. I am afraid that I can't help more at the moment :-(

Filip



Dne 24.11.2010 11:10, Lars Fischer napsal(a):
> On 24.11.2010 09:36, Filip Hrbek wrote:
>> The new build for 3.6 is now available. Please try it out to see if it
>> fixes your problem.
>
> I was not able to install the new 3.6 build (0.1.0.r01408) from the
> update site (http://download.eclipse.org/modeling/emft/b3/updates-3.6)
> into my Eclipse 3.6.1:
>
> Your original request has been modified.
> "b3 Aggregator Editor (Incubation)" is already installed, so an update
> will be performed instead.
> Cannot complete the install because of a conflicting dependency.
> Software being installed: b3 Aggregator Editor (Incubation)
> 0.1.0.r01408 (org.eclipse.b3.aggregator.editor.feature.feature.group
> 0.1.0.r01408)
> Software currently installed: Eclipse for RCP and RAP Developers
> 1.3.0.20100617-0521 (epp.package.rcp 1.3.0.20100617-0521)
> Only one of the following can be installed at once:
> Core Resource Management 3.6.0.v20100526-0737
> (org.eclipse.core.resources 3.6.0.v20100526-0737)
> Core Resource Management 3.6.0.R36x_v20100825-0600
> (org.eclipse.core.resources 3.6.0.R36x_v20100825-0600)
> Cannot satisfy dependency:
> From: Eclipse for RCP and RAP Developers 1.3.0.20100617-0521
> (epp.package.rcp 1.3.0.20100617-0521)
> To: org.eclipse.epp.package.rcp.feature.feature.group
> [1.3.0.20100617-0521]
> Cannot satisfy dependency:
> From: b3 Aggregator Editor (Incubation) 0.1.0.r01408
> (org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01408)
> To: org.eclipse.b3.aggregator.engine.feature.feature.group
> [0.1.0.r01408]
> Cannot satisfy dependency:
> From: b3 Aggregator Engine (Incubation) 0.1.0.r01408
> (org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01408)
> To: org.eclipse.core.resources [3.6.0.R36x_v20100825-0600]
> Cannot satisfy dependency:
> From: EPP RCP/RAP Feature 1.3.0.20100617-0521
> (org.eclipse.epp.package.rcp.feature.feature.group 1.3.0.20100617-0521)
> To: org.eclipse.platform.feature.group
> [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
> (org.eclipse.platform.feature.group
> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
> To: org.eclipse.core.resources [3.6.0.v20100526-0737]
>
> Regards,
> Lars
>
Re: UnsupportedOperationException with 3 repositories [message #641178 is a reply to message #641145] Wed, 24 November 2010 13:08 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3231
Registered: July 2009
Senior Member
Hi Lars,

The new aggregator will install into a new untainted Eclipse 3.6.1. This only happens when an old aggregator was first
installed into your 3.6.1 since p2 considers the o.e.core.resources bundle has been updated due to the qualifier debacle.

Regards,
Thomas Hallgren


On 2010-11-24 13:15, Filip Hrbek wrote:
> The aggregator build is set up to include proper version of org.eclipse.core.resources (3.6.0.R36x_v20100825-0600) which would normally be considered as older than 3.6.0.v20100526-0737 but in fact it is not (see bug 327234). This could be fixed by upgrading epp.package.rcp if it is already available with the dependency modified to the newer org.eclipse.core.resources bundle. I am afraid that I can't help more at the moment :-(
>
> Filip
>
>
>
> Dne 24.11.2010 11:10, Lars Fischer napsal(a):
>> On 24.11.2010 09:36, Filip Hrbek wrote:
>>> The new build for 3.6 is now available. Please try it out to see if it
>>> fixes your problem.
>>
>> I was not able to install the new 3.6 build (0.1.0.r01408) from the
>> update site (http://download.eclipse.org/modeling/emft/b3/updates-3.6)
>> into my Eclipse 3.6.1:
>>
>> Your original request has been modified.
>> "b3 Aggregator Editor (Incubation)" is already installed, so an update
>> will be performed instead.
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: b3 Aggregator Editor (Incubation)
>> 0.1.0.r01408 (org.eclipse.b3.aggregator.editor.feature.feature.group
>> 0.1.0.r01408)
>> Software currently installed: Eclipse for RCP and RAP Developers
>> 1.3.0.20100617-0521 (epp.package.rcp 1.3.0.20100617-0521)
>> Only one of the following can be installed at once:
>> Core Resource Management 3.6.0.v20100526-0737
>> (org.eclipse.core.resources 3.6.0.v20100526-0737)
>> Core Resource Management 3.6.0.R36x_v20100825-0600
>> (org.eclipse.core.resources 3.6.0.R36x_v20100825-0600)
>> Cannot satisfy dependency:
>> From: Eclipse for RCP and RAP Developers 1.3.0.20100617-0521
>> (epp.package.rcp 1.3.0.20100617-0521)
>> To: org.eclipse.epp.package.rcp.feature.feature.group
>> [1.3.0.20100617-0521]
>> Cannot satisfy dependency:
>> From: b3 Aggregator Editor (Incubation) 0.1.0.r01408
>> (org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01408)
>> To: org.eclipse.b3.aggregator.engine.feature.feature.group
>> [0.1.0.r01408]
>> Cannot satisfy dependency:
>> From: b3 Aggregator Engine (Incubation) 0.1.0.r01408
>> (org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01408)
>> To: org.eclipse.core.resources [3.6.0.R36x_v20100825-0600]
>> Cannot satisfy dependency:
>> From: EPP RCP/RAP Feature 1.3.0.20100617-0521
>> (org.eclipse.epp.package.rcp.feature.feature.group 1.3.0.20100617-0521)
>> To: org.eclipse.platform.feature.group
>> [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
>> Cannot satisfy dependency:
>> From: Eclipse Platform
>> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
>> (org.eclipse.platform.feature.group
>> 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
>> To: org.eclipse.core.resources [3.6.0.v20100526-0737]
>>
>> Regards,
>> Lars
>>
>
Re: UnsupportedOperationException with 3 repositories [message #641197 is a reply to message #641178] Wed, 24 November 2010 14:19 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello Thomas,

On 24.11.2010 14:08, Thomas Hallgren wrote:
>
> The new aggregator will install into a new untainted Eclipse 3.6.1. This
> only happens when an old aggregator was first installed into your 3.6.1
> since p2 considers the o.e.core.resources bundle has been updated due to
> the qualifier debacle.

I tried to first uninstall the old aggregator, but there is still an
error. Trying to use a clean Eclipse 3.6.1 may take some time.
Does this error also belong to Bug 327234?

Cannot complete the install because of a conflicting dependency.
Software being installed: b3 Aggregator Editor (Incubation)
0.1.0.r01408 (org.eclipse.b3.aggregator.editor.feature.feature.group
0.1.0.r01408)
Software currently installed: Eclipse for RCP and RAP Developers
1.3.0.20100617-0521 (epp.package.rcp 1.3.0.20100617-0521)
Only one of the following can be installed at once:
Update site repository adapter bundle (Incubation)
1.0.201.R36x_v20100823 (org.eclipse.equinox.p2.updatesite
1.0.201.R36x_v20100823)
Update site repository adapter bundle (Incubation)
1.0.200.v20100503 (org.eclipse.equinox.p2.updatesite 1.0.200.v20100503)
Only one of the following can be installed at once:
Eclipse Platform 3.6.0.v201006080911 (org.eclipse.platform
3.6.0.v201006080911)
Eclipse Platform 3.6.1.v201009090800 (org.eclipse.platform
3.6.1.v201009090800)
Cannot satisfy dependency:
From: Eclipse for RCP and RAP Developers 1.3.0.20100617-0521
(epp.package.rcp 1.3.0.20100617-0521)
To: org.eclipse.epp.package.rcp.feature.feature.group
[1.3.0.20100617-0521]
Cannot satisfy dependency:
From: Eclipse for RCP and RAP Developers 1.3.0.20100617-0521
(epp.package.rcp 1.3.0.20100617-0521)
To: org.eclipse.platform.ide 0.0.0
Cannot satisfy dependency:
From: b3 Aggregator Editor (Incubation) 0.1.0.r01408
(org.eclipse.b3.aggregator.editor.feature.feature.group 0.1.0.r01408)
To: org.eclipse.b3.aggregator.engine.feature.feature.group
[0.1.0.r01408]
Cannot satisfy dependency:
From: b3 Aggregator Engine (Incubation) 0.1.0.r01408
(org.eclipse.b3.aggregator.engine.feature.feature.group 0.1.0.r01408)
To: org.eclipse.equinox.p2.updatesite [1.0.201.R36x_v20100823]
Cannot satisfy dependency:
From: EPP RCP/RAP Feature 1.3.0.20100617-0521
(org.eclipse.epp.package.rcp.feature.feature.group 1.3.0.20100617-0521)
To: org.eclipse.platform.feature.group
[3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
Cannot satisfy dependency:
From: Equinox p2 Provisioning
2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt
(org.eclipse.equinox.p2.user.ui.feature.group
2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt)
To: org.eclipse.equinox.p2.updatesite [1.0.200.v20100503]
Cannot satisfy dependency:
From: Eclipse Platform
3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
(org.eclipse.platform.feature.group
3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
To: org.eclipse.platform [3.6.0.v201006080911]
Cannot satisfy dependency:
From: Eclipse Platform
3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L
(org.eclipse.platform.feature.group
3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.platform [3.6.1.v201009090800]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.0.I20100608-0911
(org.eclipse.platform.ide 3.6.0.I20100608-0911)
To: org.eclipse.equinox.p2.user.ui.feature.group
[2.0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.M20100909-0800
(org.eclipse.platform.ide 3.6.1.M20100909-0800)
To: org.eclipse.platform.feature.group
[3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L]


Regards,
Lars
Re: UnsupportedOperationException with 3 repositories [message #641230 is a reply to message #641197] Wed, 24 November 2010 15:19 Go to previous message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
On 24.11.2010 15:19, Lars Fischer wrote:
>
> I tried to first uninstall the old aggregator, but there is still an
> error. Trying to use a clean Eclipse 3.6.1 may take some time.
> Does this error also belong to Bug 327234?

Some update tries later: now its running fine.

Regards,
Lars
Previous Topic:Cannot install b3 Aggregator into 3.7 M3.
Next Topic:Do you have any interest in a opensource feature to preconfigure distributions
Goto Forum:
  


Current Time: Wed Dec 17 21:29:11 GMT 2014

Powered by FUDForum. Page generated in 0.24754 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software