Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » P2 Repository can not be found
P2 Repository can not be found [message #629666] Wed, 29 September 2010 08:10 Go to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Hi all

The Problem which I have is, that my P2 repository not can be found by Buckminster.
I have generated a P2 repository in Eclipse with buckminster and this should be imported with Buckminster in an other workspace in the target platform.
But Buckminster can not found this by the import, I have the following error:

ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in resourceMap file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.developer.releng/developer.rmap
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath internalBinaries
    ERROR   [0002] : Resolution attempt ended with exception: Provider local(file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2): Missing CSpec source required by component type eclipse.feature
      ERROR   Provider local(file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2): Missing CSpec source required by component type eclipse.feature
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath sources
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site]): Components of type eclipse.feature are not supported
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}-feature[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site-feature]): No component match was found


But if I try to install this P2 Repository over eclipse installer, is everything works...


RMAP:
<?xml version="1.0" encoding="UTF-8"?>
<rm:rmap xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0" xmlns:rm="http://www.eclipse.org/buckminster/RMap-1.0">
  <rm:property key="build.type" mutable="true" value="N"/>
  <rm:locator pattern="^com\.csg.*" searchPathRef="internalBinaries" failOnError="false"/>
  <rm:locator pattern="^com\.csg.*" searchPathRef="sources"/>
  <rm:locator searchPathRef="externalBinaries"/>
  <rm:searchPath name="internalBinaries">
    <rm:provider componentTypes="eclipse.feature,osgi.bundle" readerType="p2" source="false" mutable="false">
      <rm:uri format="file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2"/> <!--My P2-->
    </rm:provider>
  </rm:searchPath>

  <rm:searchPath name="sources">
....
  </rm:searchPath>

  <rm:searchPath name="externalBinaries">
....
  </rm:searchPath>
</rm:rmap>



CSPEC:
<?xml version="1.0" encoding="UTF-8"?>
<cs:cspec xmlns:cs="http://www.eclipse.org/buckminster/CSpec-1.0"
	name="com.csg.crs.carat.developer.releng"
	componentType="buckminster"
	version="1.0.0.qualifier">

	<cs:dependencies>
 		<cs:dependency name="com.csg.crs.carat.toolsmith.site" componentType="eclipse.feature"/> <!--My P2-->

		<cs:dependency name="org.eclipse.equinox.executable" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.platform" componentType="eclipse.feature"/>

		<cs:dependency name="org.eclipse.emf" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.emf.source" componentType="eclipse.feature"/>

		<cs:dependency name="org.eclipse.xpand" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.xpand.source" componentType="eclipse.feature"/>
	</cs:dependencies>

</cs:cspec>


Knows some one, what I have done wrong?

And is it possible, to use a SVN URL / Location for the p2 repository?


Cheers,


Cheers,
Markus
Re: P2 Repository can not be found [message #629952 is a reply to message #629666] Thu, 30 September 2010 06:14 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Are you using a 'local' reader to find your p2 repository? From the
looks of it, a local reader finds the directory and makes an attempt to
extract a feature in source form from that directory. That's not what
you want, is it?

If that's the case, then try using readerType="p2" instead.

Regards,
Thomas Hallgren


On 09/29/2010 10:10 AM, M. Stutz wrote:
> Hi all
>
> The Problem which I have is, that my P2 repository not can be found by
> Buckminster. I have generated a P2 repository in Eclipse with
> buckminster and this should be imported with Buckminster in an other
> workspace in the target platform. But Buckminster can not found this by
> the import, I have the following error:
>
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in
> resourceMap
> file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.devel oper.releng/developer.rmap
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> internalBinaries
> ERROR [0002] : Resolution attempt ended with exception: Provider
> local( file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2):
> Missing CSpec source required by component type eclipse.feature
> ERROR Provider
> local( file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2):
> Missing CSpec source required by component type eclipse.feature
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> sources
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site]):
> Components of type eclipse.feature are not supported
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}-feature[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site-feature]):
> No component match was found
>
>
> But if I try to install this P2 Repository over eclipse installer, is
> everything works...
>
>
> RMAP:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <rm:rmap xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0"
> xmlns:rm="http://www.eclipse.org/buckminster/RMap-1.0">
> <rm:property key="build.type" mutable="true" value="N"/>
> <rm:locator pattern="^com\.csg.*" searchPathRef="internalBinaries"
> failOnError="false"/>
> <rm:locator pattern="^com\.csg.*" searchPathRef="sources"/>
> <rm:locator searchPathRef="externalBinaries"/>
> <rm:searchPath name="internalBinaries">
> <rm:provider componentTypes="eclipse.feature,osgi.bundle"
> readerType="p2" source="false" mutable="false">
> <rm:uri
> format=" file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2"/>
> <!--My P2-->
> </rm:provider>
> </rm:searchPath>
>
> <rm:searchPath name="sources">
> ...
> </rm:searchPath>
>
> <rm:searchPath name="externalBinaries">
> ...
> </rm:searchPath>
> </rm:rmap>
>
>
>
> CSPEC:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <cs:cspec xmlns:cs="http://www.eclipse.org/buckminster/CSpec-1.0"
> name="com.csg.crs.carat.developer.releng"
> componentType="buckminster"
> version="1.0.0.qualifier">
>
> <cs:dependencies>
> <cs:dependency name="com.csg.crs.carat.toolsmith.site"
> componentType="eclipse.feature"/> <!--My P2-->
>
> <cs:dependency name="org.eclipse.equinox.executable"
> componentType="eclipse.feature"/>
> <cs:dependency name="org.eclipse.platform"
> componentType="eclipse.feature"/>
>
> <cs:dependency name="org.eclipse.emf" componentType="eclipse.feature"/>
> <cs:dependency name="org.eclipse.emf.source"
> componentType="eclipse.feature"/>
>
> <cs:dependency name="org.eclipse.xpand" componentType="eclipse.feature"/>
> <cs:dependency name="org.eclipse.xpand.source"
> componentType="eclipse.feature"/>
> </cs:dependencies>
>
> </cs:cspec>
>
>
> Knows some one, what I have done wrong?
> And is it possible, to use a SVN URL / Location for the p2 repository?
>
>
> Cheers,
Re: P2 Repository can not be found [message #629955 is a reply to message #629952] Thu, 30 September 2010 06:35 Go to previous messageGo to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Thomas Hallgren wrote on Thu, 30 September 2010 02:14
Are you using a 'local' reader to find your p2 repository? From the
looks of it, a local reader finds the directory and makes an attempt to
extract a feature in source form from that directory. That's not what
you want, is it?

If that's the case, then try using readerType="p2" instead.

Regards,
Thomas Hallgren





Yes you have right, that's not what I want. But I had also tried "p2" this is also not working.
(And for my SVN Repository ha have also tried SVN)

ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in resourceMap file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.developer.releng/developer.rmap
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath internalBinaries
    ERROR   [0002] : Rejecting provider p2(file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2[file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2]): No component match was found
      ERROR   No repository found at file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2/.
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath sources
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site]): Components of type eclipse.feature are not supported
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}-feature[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site-feature]): No component match was found



Thank you & Cheers,



Cheers,
Markus
Re: P2 Repository can not be found [message #629968 is a reply to message #629955] Thu, 30 September 2010 07:24 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
What kind of errors do you get when using p2 ?

An SVN repository can read source projects from SVN. It cannot read a p2
repository stored in SVN (well, it can read it but it doesn't understand
it's semantics). If you want to read p2 repositories that are checked
into an SVN repository, then you must use the p2 readerType and access
the SVN artifacts using a URL. http or https should be fine if your SVN
repo is set up to support that.

- thomas

On 09/30/2010 08:35 AM, M. Stutz wrote:
> Thomas Hallgren wrote on Thu, 30 September 2010 02:14
>> Are you using a 'local' reader to find your p2 repository? From the
>> looks of it, a local reader finds the directory and makes an attempt
>> to extract a feature in source form from that directory. That's not
>> what you want, is it?
>>
>> If that's the case, then try using readerType="p2" instead.
>>
>> Regards,
>> Thomas Hallgren
>
>
>
> Yes you have right, that's not what I want. But I had also tried "p2"
> this is also not working. (And for my SVN Repository ha have also tried
> SVN)
>
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in
> resourceMap
> file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.devel oper.releng/developer.rmap
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> internalBinaries
> ERROR [0002] : Rejecting provider
> p2( file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2[ file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2]):
> No component match was found
> ERROR No repository found at
> file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2/
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> sources
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site]):
> Components of type eclipse.feature are not supported
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}-feature[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site-feature]):
> No component match was found
>
>
>
> Thank you & Cheers,
>
>
Re: P2 Repository can not be found [message #629972 is a reply to message #629968] Thu, 30 September 2010 07:49 Go to previous messageGo to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Thomas Hallgren wrote on Thu, 30 September 2010 03:24
What kind of errors do you get when using p2 ?

An SVN repository can read source projects from SVN. It cannot read a p2
repository stored in SVN (well, it can read it but it doesn't understand
it's semantics). If you want to read p2 repositories that are checked
into an SVN repository, then you must use the p2 readerType and access
the SVN artifacts using a URL. http or https should be fine if your SVN
repo is set up to support that.




I get this error:

ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in resourceMap file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.developer.releng/developer.rmap
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath internalBinaries
    ERROR   [0002] : Rejecting provider p2(file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2[file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2]): No component match was found
      ERROR   No repository found at file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2/.
  ERROR   [0002] : No suitable provider for component com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath sources
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site]): Components of type eclipse.feature are not supported
    ERROR   [0002] : Rejecting provider svn(https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/{0}-feature[https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/Product/developer/com.csg.crs.carat.toolsmith.site-feature]): No component match was found


The path is the right one and the p2 repository has all featers. And over the Eclipse installer will be all found.


Thomas Hallgren wrote on Thu, 30 September 2010 03:24

An SVN repository can read source projects from SVN. It cannot read a p2
repository stored in SVN (well, it can read it but it doesn't understand
it's semantics). If you want to read p2 repositories that are checked
into an SVN repository, then you must use the p2 readerType and access
the SVN artifacts using a URL. http or https should be fine if your SVN
repo is set up to support that.



Perfect thank you, now I understand the principle of these rederTypes.

Thank you & Cheers,


Cheers,
Markus

[Updated on: Thu, 30 September 2010 07:49]

Report message to a moderator

Re: P2 Repository can not be found [message #629980 is a reply to message #629972] Thu, 30 September 2010 08:12 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
I see that your svn provider says "Components of type eclipse.feature
are not supported". Did you include 'eclipse.feature' in the
componentTypes attribute?

- thomas

On 09/30/2010 09:49 AM, M. Stutz wrote:
> Thomas Hallgren wrote on Thu, 30 September 2010 03:24
>> What kind of errors do you get when using p2 ?
>>
>> An SVN repository can read source projects from SVN. It cannot read a
>> p2 repository stored in SVN (well, it can read it but it doesn't
>> understand it's semantics). If you want to read p2 repositories that
>> are checked into an SVN repository, then you must use the p2
>> readerType and access the SVN artifacts using a URL. http or https
>> should be fine if your SVN repo is set up to support that.
>
>
> I get this error:
>
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in
> resourceMap
> file:/C:/Data/projects/MDA/Developer/com.csg.crs.carat.devel oper.releng/developer.rmap
>
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> internalBinaries
> ERROR [0002] : Rejecting provider
> p2( file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2[ file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2]):
> No component match was found
> ERROR No repository found at
> file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site .p2/
> ERROR [0002] : No suitable provider for component
> com.csg.crs.carat.toolsmith.site:eclipse.feature was found in searchPath
> sources
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site]):
> Components of type eclipse.feature are not supported
> ERROR [0002] : Rejecting provider
> svn( https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/{0}-feature[ https://svn.rowini.net/svnrep/cana/trunk/SE_Implementation/P roduct/developer/com.csg.crs.carat.toolsmith.site-feature]):
> No component match was found
>
>
> The path is the right one and the p2 repository has all featers. And
> over the Eclipse installer will be all found.
>
>
> Thomas Hallgren wrote on Thu, 30 September 2010 03:24
>> An SVN repository can read source projects from SVN. It cannot read a
>> p2 repository stored in SVN (well, it can read it but it doesn't
>> understand it's semantics). If you want to read p2 repositories that
>> are checked into an SVN repository, then you must use the p2
>> readerType and access the SVN artifacts using a URL. http or https
>> should be fine if your SVN repo is set up to support that.
>
>
> Perfect thank you, know I understand the principle of these rederTypes.
> Thank you & Cheers,
>
Re: P2 Repository can not be found [message #629982 is a reply to message #629980] Thu, 30 September 2010 08:40 Go to previous messageGo to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Thomas Hallgren wrote on Thu, 30 September 2010 04:12
I see that your svn provider says "Components of type eclipse.feature
are not supported". Did you include 'eclipse.feature' in the
componentTypes attribute?



You mean in the cspec? There I have following statement:

<cs:dependency name="com.csg.crs.carat.toolsmith.site" componentType="eclipse.feature"/>


All other packages which I have there defined, are also with componentType "eclispe.feature" and these works.

		<cs:dependency name="org.eclipse.equinox.executable" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.platform" componentType="eclipse.feature"/>

		<cs:dependency name="org.eclipse.emf" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.emf.source" componentType="eclipse.feature"/>

		<cs:dependency name="org.eclipse.xpand" componentType="eclipse.feature"/>
		<cs:dependency name="org.eclipse.xpand.source" componentType="eclipse.feature"/>


Cheers,


Cheers,
Markus
Re: P2 Repository can not be found [message #629987 is a reply to message #629982] Thu, 30 September 2010 08:59 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
On 09/30/2010 10:40 AM, M. Stutz wrote:
> Thomas Hallgren wrote on Thu, 30 September 2010 04:12
>> I see that your svn provider says "Components of type eclipse.feature
>> are not supported". Did you include 'eclipse.feature' in the
>> componentTypes attribute?
>
>
> You mean in the cspec? There I have following statement:
>
No, I mean <provider componentTypes="xxx" ...> in your rmap.

- thomas
Re: P2 Repository can not be found [message #629996 is a reply to message #629987] Thu, 30 September 2010 09:28 Go to previous messageGo to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Thomas Hallgren wrote on Thu, 30 September 2010 04:59

No, I mean <provider componentTypes="xxx" ...> in your rmap.



A ok, yes this is also definet:

  <rm:searchPath name="internalBinaries">
    <rm:provider componentTypes="eclipse.feature,osgi.bundle" readerType="p2" source="false" mutable="false">
      <rm:uri format="file://C:/Data/projects/MDA/com.csg.crs.carat.p2.update/site.p2"/>
    </rm:provider>
  </rm:searchPath>


Cheers,


Cheers,
Markus
Re: P2 Repository can not be found [message #630082 is a reply to message #629996] Thu, 30 September 2010 15:17 Go to previous message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
I have fixed it. It had a '/' to much after the "file:" tag.


Thank you & Cheers,


Cheers,
Markus
Previous Topic:How to setup local reader, getting message: missing CSpec source required by component type eclipse.
Next Topic:NoClassDefFoundError when trying to create target platform using Hudson/Buckminster
Goto Forum:
  


Current Time: Sun Sep 21 16:07:44 GMT 2014

Powered by FUDForum. Page generated in 0.01978 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software