Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Infocenter: Absolute URLs in printing
Infocenter: Absolute URLs in printing [message #621803] Mon, 10 November 2008 14:07
Daniel Walter is currently offline Daniel Walter
Messages: 10
Registered: July 2009
Junior Member
Hello,

I am running Infocenter as a stand-alone app and bring it to the enduser
by using Apache's mod_proxy, like it is proposed in the documentation.

Unfortunately there are problems with this approach.
When I use "Print selected topic and all subtopics" then most of the
links are broken because the point to 127.0.0.1:8888. Images and CSS are
missing completely.
Reason for that is that the page contains absolute links and those are
ignored by mod_proxy. Printing the selected topic works like expected,
because it only prints the content frame.

Of course, mod_proxy_html could do the job, but I start to wonder, why
the printing preview uses the absolute URLs in the first place. I don't
see any sense in that behaviour and would regard it as a bug.

Any comments on this?

Thanks,
Daniel
Previous Topic:Plugins list show up in 3.4 but not in 3.3 during installation
Next Topic:Infocenter: Bookmarks only for IE?
Goto Forum:
  


Current Time: Thu Oct 30 13:56:23 GMT 2014

Powered by FUDForum. Page generated in 0.14781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software