Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » AJDT 2.0.0 for Eclipse 3.5
AJDT 2.0.0 for Eclipse 3.5 [message #600928] Tue, 23 March 2010 23:26 Go to next message
Victor Llorens is currently offline Victor Llorens
Messages: 60
Registered: July 2009
Member
Hi all,

Where can i download AJDT 2.0.0?

My framework needs AJDT v2.0.0 for eclipse 3.5 in order to work properly. I have it in localhost but dunno if it is still avaliable in eclipse servers (it may :S).

Version: 2.0.0.e35x-20090624-1600
AspectJ version: 1.6.5.20090618034232

Thanks in advance.
Re: AJDT 2.0.0 for Eclipse 3.5 [message #600933 is a reply to message #600928] Wed, 24 March 2010 15:49 Go to previous messageGo to next message
Andrew Eisenberg is currently offline Andrew Eisenberg
Messages: 368
Registered: July 2009
Senior Member
You can download the zip:
http://download.eclipse.org/tools/ajdt/35/update/ajdt_2.0.0_ for_eclipse_3.5.zip

This must be installed manually into your workspace. See: http://wiki.eclipse.org/JDT_weaving_features#Manual_Install

Why the requirement on 2.0.0? Has there been some breaking api change or other problem?
Re: AJDT 2.0.0 for Eclipse 3.5 [message #600937 is a reply to message #600933] Wed, 24 March 2010 16:28 Go to previous messageGo to next message
Victor Llorens is currently offline Victor Llorens
Messages: 60
Registered: July 2009
Member
Thanks Andrew,

there is an human way to get to this link via AJDT Main/downloads page??
By the way this link is very usefull for me.

I could try to explain why I need this version:

Eclipse: 3.5.x
MTJ: 0.9.1 / 1.0.1
AJDT: >2.0.0
Sun Wireless ToolKit: 2.5.2

The framework has to log timmings between Frames in a J2ME Mobile Aplication (MIDLET). This log timmings are calculated via Aspects.

To log that data, I don't need Reflection, and much other features of J2SE, so my aspectjrt library has been patched deleting those classes. In order to the preveryfier preverify correctly.

To build the project builders order run as follows:

1) AspectJ Builder
2) MTJ Preverifyer (WTK Emulator's one)
3) MTJ package builder (Deployment)


With this scenario AJDT 2.0.0 works correctly. Newer versions work -almost- correctly too, but when package builder finishes the eclipse project keeps saying tha the project has errors (and it does not).
It's only when you refresh workspace state (F5) when errors dissapear. Even if you try to run the application in the emulator, aspects are working correctly and the 'X' marking errors in project icon dissapears. Maybe when you run/debug a project, workspace is syncronized with HDD.

I must say too that with AJDT 2.0.0 the 'x' marking error does not dissapear until the end of the building. It seems like it refreshes the view or runs builders two times. Dunno.

I hope to help in some way with that info.

Greetings,
Victor Llorens Vilella.
Re: AJDT 2.0.0 for Eclipse 3.5 [message #600941 is a reply to message #600937] Fri, 26 March 2010 18:08 Go to previous message
Andrew Eisenberg is currently offline Andrew Eisenberg
Messages: 368
Registered: July 2009
Senior Member
I'll add the link to the downloads page.
Previous Topic:AJDT 2.0.0 for Eclipse 3.5
Next Topic:How to convert to an aspectJ project?
Goto Forum:
  


Current Time: Fri Aug 01 01:49:33 EDT 2014

Powered by FUDForum. Page generated in 0.04795 seconds