Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Exported product and new plugin discovey problem
Exported product and new plugin discovey problem [message #599417] Thu, 16 July 2009 16:24
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
I am creating a custom eclipse product for our own language. I have a
product file that depends on two features. One feature includes the set of
internally developed plugins, and the another for required dependencies
for these plugins. When i export the product, i receive an eclipse,
binary, and repository folders. If i place some external plugins into the
eclipse/plugins directory, it will not recognize the new plugins in the
product environment.

After hours of trying to figure out why my development environment could
recognize new plugins, but my product could not, i found a setting in
configuration/config.ini 'org.eclipse.update.reconcile', which i changed
to true and the product continued to find the external plugins.

I have two questions:

1) Why does my development environment have this reconcile option set to
false but still recognize new plugins in if dropped in the plugins folder?
Ideally, i would like to mimic what my development environment is doing
for the product.

2) If i have to set this to true for my product to recognize new plugins,
is there a way to set this option during the export of the product?

Any help is appreciated. Also, please let me know if i'm completely on the
wrong path here. Thanks!

-Rob
Previous Topic:Unsatisfied version constraint
Next Topic:ctrl+c/v/x in Eclipse 3.5
Goto Forum:
  


Current Time: Sun Dec 21 13:46:05 GMT 2014

Powered by FUDForum. Page generated in 0.01441 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software