Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Eclipse remote help server (BindException)
Eclipse remote help server (BindException) [message #589054] Wed, 24 October 2007 17:33
Lyndsey Padget is currently offline Lyndsey PadgetFriend
Messages: 2
Registered: July 2009
Junior Member
One of the documented limitations of Java Web Start is that the Eclipse
help system cannot be deployed [1]. As a workaround, Eclipse suggests
running your own help server (also known as running help in “infocenter”
mode), which I have done on the server serving our application [2]. This
server can be reached by hitting
http://<serverName>:<portNumber>/help/index.jsp in a browser. Note that
I'm using version 3.2.0 to 3.2.2 for most of my Eclipse plugins.

Now I would like to configure our application to use this help server
rather than trying to start its own help server. I have tried to
accomplish this in two ways:

1) use the product customization options as
defined here [3] and

2) use the host and port fields in the Help Server preference page [4]

Of course, I use <serverName> as the host name and <portNumber> as the
server port in both cases. However, when I try to start help by going to
Help -> Help Contents in the workbench, I get a message stating the

“Help cannot be displayed. The embedded application server could not run
help web application. Check the log for details.”

I find a stack trace in the log file, but it seems vague to me:

!ENTRY 4 0 2007-10-23 13:19:28.273
!MESSAGE The embedded application server could not run help web
org.eclipse.core.runtime.CoreException: Exception occurred starting
application server.
at appServer(
at rver(
at nning(
!SUBENTRY 1 org.eclipse.tomcat 4 0 2007-10-23 13:19:28.273
!MESSAGE Exception occurred starting application server.

I found this, which describes where the REAL exception can be found:

Looking in the Tomcat Catalina log (as described in the link), I see the
following exception. Note that this log file is on the client (the one
trying to connect to the help server), not the machine running the help
server. Replace <portNumber> with the actual port number below. I’ve
tried several different ports, and there is a specific exception I should
be seeing if the port was already in use. Since I’m not seeing that
exception, it must be something else…

LifecycleException: Protocol handler initialization failed: Cannot assign requested address:
org.apache.catalina.startup.Embedded.addConnector(Embedded.j ava:432)
at appServer(
at rver(

Any insight would be appreciated.

[1] platform.doc.isv/guide/java_web_start.htm
[2] platform.doc.isv/guide/ua_help_setup_infocenter.htm
[3] platform.doc.isv/guide/ua_help_setup_preferences.htm
[4] platform.doc.user/reference/help_preferences_server.htm
Previous Topic:Disable cheat sheet in dialog tray?
Next Topic:Embedding HTML Entities in Table of Contents?
Goto Forum:

Current Time: Sun Nov 29 01:51:15 GMT 2015

Powered by FUDForum. Page generated in 0.02874 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software