Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Unable to get DTP 1.5 + Eclipse 3.3 to work
Unable to get DTP 1.5 + Eclipse 3.3 to work [message #586060] Thu, 05 July 2007 02:07
Eclipse UserFriend
Originally posted by: jack.ukleja.no.spam.macquarie.com

Hi there,

I have the *strong* desire to find a SQL management tool where I can
develop and manage a variety of DBMS all from one tool. We have Sybase,
Oracle and SQL Server here at work.

I discovered DTP yesterday and had high hopes for it. Interface and
features look good.

Unfortunately I cannot report much success!

I followed the instructions exactly as described on
http://www.eclipse.org/datatools/ I tried the Eclipse 3.3 path first:
* Eclipse 3.3 SDK
* EMF 2.3 (EMF + SDO)
* GEF 3.3
* DTP 1.5

After placing all the plugins/features in the correct folders, I ran
Eclipse. I could see all the plugins, although some were not enabled. So I
enabled them all and restarted.

Even then I could not see 'Database development' appear in the Perspective
list! I could create a connection to a Sybase 12.5 server but it would
refuse to display any schema info in the data explorer. I also could not
work out how to run any SQL code - no such view shows in the list of
available views.

I tried installing it all over again from scratch but this time using the
Software Updates -> Find and Install screen. I could see DTP 1.5 so
selected all the relevant components and got Eclipse to select the
dependancies automatically. Everything downloaded and Eclipse restarted.
BUT exactly the same problem ... 'Database Developement' does not show in
the Perspectives!

I am assuming this is a bug (quite a bad one considering standard install
does not work!). Only thing I can think is I am running Windows 2000 so
maybe it wasnt tested with Win2k. If this is not a bug then there is
definately some complication that needs to be exaplined in detail to
newbies like myself on how to get DTP up and running. Maybe DTP does not
provide and tools you can use out the box - only a framework?

Anyway I gave up with the e3.3 packages and tried e3.2. I have had more
success with 3.2 unfortunately it does not support Sybase 12.x. So again I
was unable to view my Sybase databases properly.

On top of all that I still cannot work out how to actually run a query.

So to sum up, all these tools look great and have a potentially great
future but there are two stumbling blocks I can see:
1) e3.3 does not seem to work with DTP 1.5 out of the box on Win2k! :(
2) It's way to hard for a newbie to figure out where to begin with this
stuff (no tutorials I have found). Oracle have one but only for e3.3 not
3.2. It's all a bit confusing really. Sybase seem to offer no clear
solution out-of-the-box to managing/developing Sybase ASA out of the box
with DTP.

Maybe I just need to spend more time playing with this stuff.

Regards,
Jack
Previous Topic:europa jpa schema persistence.xml
Next Topic:Unable to get DTP 1.5 + Eclipse 3.3 to work
Goto Forum:
  


Current Time: Mon Nov 24 00:16:43 GMT 2014

Powered by FUDForum. Page generated in 0.02252 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software