Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Java 1.5 Compliance Problem
Java 1.5 Compliance Problem [message #583648] Wed, 09 December 2009 17:00 Go to next message
Baptiste Mesta is currently offline Baptiste Mesta
Messages: 31
Registered: September 2009
Member
Hello,
I'm currently trying to use the EVL validation in my RCP application but it's not working with Java 1.5:

here is a part of the stack trace.

!MESSAGE Plug-in org.eclipse.epsilon.evl.emf.validation was unable to load class org.eclipse.epsilon.evl.emf.validation.EValidatorPopulator.
!STACK 0
java.lang.UnsupportedClassVersionError: Bad version number in .class file

the bundle is in the version:
0.8.8.200911161330

Is this a known problem?

Thank you in advance.
--
Baptiste Mesta
http://www.bonitasoft.com/


Re: Java 1.5 Compliance Problem [message #583658 is a reply to message #583648] Wed, 09 December 2009 18:20 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi,

This seems to be related to
https://bugs.eclipse.org/bugs/show_bug.cgi?id=297012 I'll apply
Enrico's patch and we'll roll out a new interim version tomorrow.

Cheers,
Dimitris

On 09/12/2009 17:00, Baptiste Mesta wrote:
> Hello,
> I'm currently trying to use the EVL validation in my RCP application but
> it's not working with Java 1.5:
>
> here is a part of the stack trace.
>
> !MESSAGE Plug-in org.eclipse.epsilon.evl.emf.validation was unable to
> load class org.eclipse.epsilon.evl.emf.validation.EValidatorPopulator.
> !STACK 0
> java.lang.UnsupportedClassVersionError: Bad version number in .class file
>
> the bundle is in the version: 0.8.8.200911161330
>
> Is this a known problem?
>
> Thank you in advance.
Previous Topic:Problem using EVL on a UML 2.1 meta-model?
Next Topic:Java 1.5 Compliance Problem
Goto Forum:
  


Current Time: Thu Oct 02 04:25:46 GMT 2014

Powered by FUDForum. Page generated in 0.01810 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software