Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Modeling (top-level project) » EMF code generation error (bug report)
EMF code generation error (bug report) [message #582343] Thu, 02 November 2006 11:10
Eclipse User
Originally posted by: vkrastev.gmx.de

Hi All,

we have following problem(bug) with the EMF code generation tool.

I will explain the process and then the error.

We make new EMF project from our ecore model. Then from the generate model
(ourmodel.genmodel) we generate the Model Code. And we have the following
syntax errors in the generated code.

In our ecore model there are variable names and method names which exceed
the maximum lenght

of the screen. The length of the whole line is 74 characters it will be
split by generation in the position 57 with new line character and the
remaining 17 characters are put on the next line.

Example:

it should be like this:

private EDataType xsDbuildInPrimitiveTypeNamesObjectEdataType = null ;

but after the code generation we have the following:

private EDataType xsDbuildInPrimitiveTypeNamesObject

EdataType = null ;

That means now we have two independent lines code and we get after compile
the syntax error:

"on token "EDataType", delete this token"

We dont want to make changes on our model in order to avoid this error.

Is it a bug? Can you fix it?

We suppose it is an error in the JET code generation.

Please advise solution.

Thanks in advance.

Regards

V.Krastev
Previous Topic:GEMS: a new component under eclipse.modeling.gmt
Next Topic:EMF code generation error (bug report)
Goto Forum:
  


Current Time: Sat Sep 20 22:11:52 GMT 2014

Powered by FUDForum. Page generated in 0.01972 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software