Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [xPand]template doesn't recognise metamodel data
[xPand]template doesn't recognise metamodel data [message #580289] Thu, 19 April 2007 06:52
Chetan Kumar is currently offline Chetan KumarFriend
Messages: 70
Registered: July 2009
Dear all,

I have a problem in writing xPand template. The situation is as follows:
1. i have a model (emf meta model) in a plugin.
2. i have an oAW plugin which has the workflow and templates
3. model plugin is added as a dependancy to the oAW plugin.

Now when I try to write template based on my emf meta model, xPand editor
shows the following errors: "Couldn't find Company", "unknown enumeration
literal or ... ". the template looks like so:
«IMPORT com::project::company»

«DEFINE Root FOR Company»
«EXPAND expandProject FOR project»

«DEFINE expandEcu FOR Project»
«EXPAND expandEmp FOREACH employee»

i tried to ignore the errors and ran the workflow, then i got the
following exceptions:
workflow-description on line 1 'EXPAND template::Root::Root FOR model'
org.openarchitectureware.expression.EvaluationException: No Definition
'template::Root::Root for' found! in

in properties of the oAW plugin, EMF Meta model is checked. I tried
reloading the workbench, but still problem persists. Can anyone help me
out on this.

Chetan Kumar and Sandeepthi
Previous Topic:[Epsilon] Re: Comparative study between ATL and ETL
Next Topic:[TCS]User issues
Goto Forum:

Current Time: Tue Dec 01 22:18:57 GMT 2015

Powered by FUDForum. Page generated in 0.10455 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software