Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » de.itemis.xtext.antlr breaks
de.itemis.xtext.antlr breaks [message #58464] Sat, 14 March 2009 20:29 Go to next message
Hasan Ceylan is currently offline Hasan Ceylan
Messages: 198
Registered: July 2009
Senior Member
Hello,

Latest mwe, xpand and xtext breaks with incompatibility with the
de.itemis.xtext.antlr plugin.

Would someone please post an update to the new parser?

Here's the output...
0 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
------------------------------------------------------------ --------------------------
20 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - EMF Modeling
Workflow Engine 0.7.0, Build v200903110130
21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - (c) 2005-2009
openarchitectureware.org and contributors
21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
------------------------------------------------------------ --------------------------
21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - running workflow:
org/batoo/ui/forms/GenerateModel.mwe
21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - [ERROR]: Class not
found: 'de.itemis.xtext.antlr.XtextAntlrGeneratorFragment'(Element: bean
fragment class='de.itemis.xtext.antlr.XtextAntlrGeneratorFragment' in
org/eclipse/xtext/generator/StandardRuntimeFragments.mwe:4; Reported by: -
UNKNOWN-)
602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - Workflow
interrupted because of configuration errors.


Thanks,
Hasan Ceylan
Re: de.itemis.xtext.antlr breaks [message #58475 is a reply to message #58464] Sun, 15 March 2009 10:19 Go to previous messageGo to next message
Hasan Ceylan is currently offline Hasan Ceylan
Messages: 198
Registered: July 2009
Senior Member
Nevermind, got it. Fo the record for the other users, it is on oaw
sourceforge site...

Hasan Ceylan wrote:

> Hello,
>
> Latest mwe, xpand and xtext breaks with incompatibility with the
> de.itemis.xtext.antlr plugin.
>
> Would someone please post an update to the new parser?
>
> Here's the output...
> 0 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>
------------------------------------------------------------ --------------------------
> 20 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - EMF Modeling
> Workflow Engine 0.7.0, Build v200903110130
> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - (c) 2005-2009
> openarchitectureware.org and contributors
> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>
------------------------------------------------------------ --------------------------
> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - running workflow:
> org/batoo/ui/forms/GenerateModel.mwe
> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - [ERROR]: Class
> not found: 'de.itemis.xtext.antlr.XtextAntlrGeneratorFragment'(Element:
> bean fragment class='de.itemis.xtext.antlr.XtextAntlrGeneratorFragment' in
> org/eclipse/xtext/generator/StandardRuntimeFragments.mwe:4; Reported by: -
> UNKNOWN-)
> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - Workflow
> interrupted because of configuration errors.
>
>
> Thanks,
> Hasan Ceylan
Re: de.itemis.xtext.antlr breaks [message #58573 is a reply to message #58475] Mon, 16 March 2009 16:47 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2807
Registered: July 2009
Senior Member
Hi Hasan,

I'll crosspost your solution to the TMF newsgroup.

If you have any further questions, please don't hesitate to ask us.

Regards,
Sebastian

Hasan Ceylan schrieb:
> Nevermind, got it. Fo the record for the other users, it is on oaw
> sourceforge site...
>
> Hasan Ceylan wrote:
>
>> Hello,
>>
>> Latest mwe, xpand and xtext breaks with incompatibility with the
>> de.itemis.xtext.antlr plugin.
>>
>> Would someone please post an update to the new parser?
>>
>> Here's the output...
>> 0 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>>
> ------------------------------------------------------------ --------------------------
>> 20 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - EMF Modeling
>> Workflow Engine 0.7.0, Build v200903110130
>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - (c) 2005-2009
>> openarchitectureware.org and contributors
>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>>
> ------------------------------------------------------------ --------------------------
>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - running workflow:
>> org/batoo/ui/forms/GenerateModel.mwe
>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - [ERROR]: Class
>> not found: 'de.itemis.xtext.antlr.XtextAntlrGeneratorFragment'(Element:
>> bean fragment class='de.itemis.xtext.antlr.XtextAntlrGeneratorFragment' in
>> org/eclipse/xtext/generator/StandardRuntimeFragments.mwe:4; Reported by: -
>> UNKNOWN-)
>> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - Workflow
>> interrupted because of configuration errors.
>>
>>
>> Thanks,
>> Hasan Ceylan
>
>
Re: de.itemis.xtext.antlr breaks [message #58620 is a reply to message #58573] Tue, 17 March 2009 02:27 Go to previous messageGo to next message
Hasan Ceylan is currently offline Hasan Ceylan
Messages: 198
Registered: July 2009
Senior Member
Thx...
Sebastian Zarnekow wrote:

> Hi Hasan,
>
> I'll crosspost your solution to the TMF newsgroup.
>
> If you have any further questions, please don't hesitate to ask us.
>
> Regards,
> Sebastian
>
> Hasan Ceylan schrieb:
>> Nevermind, got it. Fo the record for the other users, it is on oaw
>> sourceforge site...
>>
>> Hasan Ceylan wrote:
>>
>>> Hello,
>>>
>>> Latest mwe, xpand and xtext breaks with incompatibility with the
>>> de.itemis.xtext.antlr plugin.
>>>
>>> Would someone please post an update to the new parser?
>>>
>>> Here's the output...
>>> 0 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>>>
>>
------------------------------------------------------------ --------------------------
>>> 20 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - EMF Modeling
>>> Workflow Engine 0.7.0, Build v200903110130
>>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - (c) 2005-2009
>>> openarchitectureware.org and contributors
>>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>>>
>>
------------------------------------------------------------ --------------------------
>>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner - running
>>> workflow: org/batoo/ui/forms/GenerateModel.mwe
>>> 21 [main] INFO eclipse.emf.mwe.core.WorkflowRunner -
>>> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - [ERROR]: Class
>>> not found: 'de.itemis.xtext.antlr.XtextAntlrGeneratorFragment'(Element:
>>> bean fragment class='de.itemis.xtext.antlr.XtextAntlrGeneratorFragment'
>>> in org/eclipse/xtext/generator/StandardRuntimeFragments.mwe:4; Reported
>>> by: - UNKNOWN-)
>>> 602 [main] ERROR eclipse.emf.mwe.core.WorkflowRunner - Workflow
>>> interrupted because of configuration errors.
>>>
>>>
>>> Thanks,
>>> Hasan Ceylan
>>
>>
Re: de.itemis.xtext.antlr breaks [message #58692 is a reply to message #58620] Tue, 17 March 2009 12:05 Go to previous messageGo to next message
Ilyas Keser is currently offline Ilyas Keser
Messages: 85
Registered: July 2009
Member
Hi,

I checked out the de.itemis.xtext.antlr Plugin from
http://architecturware.cvs.sourceforge.net/viewvc/architectu rware/xtext_external/de.itemis.antlr.xtext.updatesite/plugin s/
and placed it in my dropins folder. Generating artifacts reports an
attention.

4531 [main] WARN nerator.DelegatingGeneratorFragment - ---- ATTENTION
----
4531 [main] WARN nerator.DelegatingGeneratorFragment - You are
generating without ANTLR. If this was not desired, please install the
missing plugin 'de.itemis.xtext.antlr'.

How can I configure Xtext to use the ANTLR Parser?

Thanks
ILyas
Re: de.itemis.xtext.antlr breaks [message #58716 is a reply to message #58620] Tue, 17 March 2009 12:38 Go to previous messageGo to next message
Ilyas Keser is currently offline Ilyas Keser
Messages: 85
Registered: July 2009
Member
Hi,

I checked out the de.itemis.xtext.antlr Plugin from
http://architecturware.cvs.sourceforge.net/viewvc/architectu rware/xtext_external/de.itemis.antlr.xtext.updatesite/plugin s/
and placed it in my dropins folder. Generating artifacts reports an
attention.

4531 [main] WARN nerator.DelegatingGeneratorFragment - ---- ATTENTION
----
4531 [main] WARN nerator.DelegatingGeneratorFragment - You are
generating without ANTLR. If this was not desired, please install the
missing plugin 'de.itemis.xtext.antlr'.

How can I configure Xtext to use the ANTLR Parser?

Thanks
ILyas
Re: de.itemis.xtext.antlr breaks [message #59039 is a reply to message #58692] Sun, 22 March 2009 17:43 Go to previous message
Hasan Ceylan is currently offline Hasan Ceylan
Messages: 198
Registered: July 2009
Senior Member
Ilyas,

What I did was to check out

de.artemis.xtext.antlr
de.artemis.xtext.antlr.feature
org.antlr

into workspace and export the feature to main platform.

I think it should still be OK to have them in your workspace, but my guess
is that you are missing org.antlr . The org.antlr plugin comes from
eclipse.org has a dummy implementation in it so the plugin from the sf.net
should override it.

Hope this helps,

Hasan

Ilyas Keser wrote:

> Hi,
>
> I checked out the de.itemis.xtext.antlr Plugin from
>
http://architecturware.cvs.sourceforge.net/viewvc/architectu rware/xtext_external/de.itemis.antlr.xtext.updatesite/plugin s/
> and placed it in my dropins folder. Generating artifacts reports an
> attention.
>
> 4531 [main] WARN nerator.DelegatingGeneratorFragment - ---- ATTENTION
> ----
> 4531 [main] WARN nerator.DelegatingGeneratorFragment - You are
> generating without ANTLR. If this was not desired, please install the
> missing plugin 'de.itemis.xtext.antlr'.
>
> How can I configure Xtext to use the ANTLR Parser?
>
> Thanks
> ILyas
Previous Topic:Sample Workflow for Eclipse MWE
Next Topic:UML2 to Java class without any ECore dependencies
Goto Forum:
  


Current Time: Thu Apr 24 06:32:51 EDT 2014

Powered by FUDForum. Page generated in 0.02475 seconds