Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » Latest Dali Milestone build - M1: dali-N-0.5M1-200603170005 problem
Latest Dali Milestone build - M1: dali-N-0.5M1-200603170005 problem [message #578340] Mon, 10 April 2006 15:29
No real name is currently offline No real name
Messages: 10
Registered: July 2009
Junior Member
Hi,

I'm just trying latest M1 build (see subj). I have all the prereqs.
Eclipse 3.1.2 and WTP 1.0.1.

My problem is that Dali plugin fails when I try to map @OneToMany.

The plugin fails when I go in the persistence properties to the [Join
Table] tab and try to edit "join columns".

The error is:
java.lang.ClassCastException:
org.eclipse.dali.core.impl.OneToManyMappingImpl
at
org.eclipse.dali.ui.views.JoinColumnDialog.populateReference dNameCombo(JoinColumnDialog.java:96)
at
org.eclipse.dali.ui.views.JoinColumnDialog.createDialogArea( JoinColumnDialog.java:72)
at org.eclipse.jface.dialogs.Dialog.createContents(Dialog.java: 687)
at org.eclipse.jface.window.Window.create(Window.java:418)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:996)
at org.eclipse.jface.window.Window.open(Window.java:776)
at
org.eclipse.dali.ui.views.JoinTableComposite.editJoinColumnF romDialog(JoinTableComposite.java:326)
at
org.eclipse.dali.ui.views.JoinTableComposite.editJoinColumn( JoinTableComposite.java:318)
at
org.eclipse.dali.ui.views.JoinTableComposite.access$0(JoinTa bleComposite.java:315)
at
org.eclipse.dali.ui.views.JoinTableComposite$1.widgetSelecte d(JoinTableComposite.java:131)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:90)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3125)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2758)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:103)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:226)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)

Can some one fix it or tell me what is wrong?
Previous Topic:Update scenario
Next Topic:Unalble to see the list of tables to map to my Entity
Goto Forum:
  


Current Time: Thu Oct 23 06:56:26 GMT 2014

Powered by FUDForum. Page generated in 0.01423 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software