Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Babel » Illegal token characters in babel fragment names
Illegal token characters in babel fragment names [message #575350] Thu, 23 October 2008 16:45
Sebastian Fuchs is currently offline Sebastian Fuchs
Messages: 94
Registered: July 2009
Member
Hi !

First let me thank you all for the great work on tranlation / tools
already been done.

I recently updated to the new language packs (German).
I noticed a change in the names of the fragments.

The old pattern was *.nl_de
which is now *.nl-de
So the underscore changed to minus.

Unfortunattely the minus is an illegal value for fragment tokens.
When I manually add NL-fragments to a Feature of my RCP-application, I
recieve warnings like this from PDE:

Illegal value 'org.eclipse.ant.core.nl-de' for attribute 'id'. Legal
token characters are "a-z", "A-Z", "0-9", "_". Tokens must be
separated by "." feature.xml

Furthermore I have to change my runtime configuration which is annoying.


Is it a bug or a feature ?
Would it be possible to switch back to the traditional naming convention ?

Sebastian
Previous Topic:Re: how to internationalize a product-file
Next Topic:Illegal token characters in babel fragment names
Goto Forum:
  


Current Time: Sun Sep 21 02:09:26 GMT 2014

Powered by FUDForum. Page generated in 0.01510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software