Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Problems with obfusctaion
Problems with obfusctaion [message #573822] Fri, 05 June 2009 13:57
erik is currently offline erik
Messages: 6
Registered: July 2009
Junior Member
Hi!
I have installed Eclipse 3.4.2 with mtj 1.0 RC3. Seems to work fine and I
can run my midlet in the emulator, debug it and create a signed package.

But when I try to create an obfuscated package I get the following error:
Errors during build.
Errors running builder 'Package Builder' on project 'XXXX'.
Failed to inflate jar file.
C:\ver9.00\Source\XXXX\.mtj.tmp\emulation\XXXX_obf.jar (The system
cannot find the file specified)

There is of course np XXXX_obf.jar. A proguard.conf file is created with
the following content:
-libraryjars
C:\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\eswt.jar;C:\S60\devi ces\S60_3rd_FP2_SDK_v1.1\lib\JSR135.jar;C:\S60\devices\S60_3 rd_FP2_SDK_v1.1\lib\JSR139.jar;C:\S60\devices\S60_3rd_FP2_SD K_v1.1\lib\JSR172.jar;C:\S60\devices\S60_3rd_FP2_SDK_v1.1\li b\JSR177.jar;C:\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\JSR179. jar;C:\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\JSR180.jar;C:\S6 0\devices\S60_3rd_FP2_SDK_v1.1\lib\JSR184.jar;C:\S60\devices \S60_3rd_FP2_SDK_v1.1\lib\JSR226.jar;C:\S60\devices\S60_3rd_ FP2_SDK_v1.1\lib\JSR234.jar;C:\S60\devices\S60_3rd_FP2_SDK_v 1.1\lib\JSR75.jar;C:\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\JS R82.jar;C:\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\midp20.jar;C :\S60\devices\S60_3rd_FP2_SDK_v1.1\lib\midp21.jar;C:\S60\dev ices\S60_3rd_FP2_SDK_v1.1\lib\wma11.jar;C:\S60\devices\S60_3 rd_FP2_SDK_v1.1\lib\wma20.jar
-injars C:\ver9.00\Source\XXXX\.mtj.tmp\emulation\XXXX.jar
-outjar C:\ver9.00\Source\XXXX\.mtj.tmp\emulation\XXXX_obf.jar
-printseeds C:\ver9.00\Source\XXXX\deployed\pro_seeds.txt
-printmapping C:\ver9.00\Source\XXXX\deployed\pro_map.txt
-dontusemixedcaseclassnames -dontnote -defaultpackage ''

-keep public class * extends javax.microedition.midlet.MIDlet

The XXXX.jar file exists, but none of the others. I Use proguard 4.3 and
have set the 'Proguard Root Directory' in Window/Preferences/Java
ME/Packaging/Obfuscation. When I try the parameters in Proguard GUI the
obfuscation completes successfully.

I have tried adding -vmargs -Dmtj.build.logging=all on Eclipse startup
parameters, but I don't get any additional information really. I don't
think proguard is run at all. I have tried with Proguard 4.2 also, but
that does not help. I have also tried other WTK's but there is no
difference.

What could be the problem? Is there some way to verify that Proguard is
installed correctly and can be started from Eclipse? I am really stuck on
this...

Erik
Previous Topic:On-device debugging
Next Topic:Problems with obfusctaion
Goto Forum:
  


Current Time: Thu Oct 02 02:23:00 GMT 2014

Powered by FUDForum. Page generated in 0.07922 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software