Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » PrefSpec Wizard Not Working?
PrefSpec Wizard Not Working? [message #572764] Thu, 07 August 2008 15:34
Eclipse UserFriend
Originally posted by: mcriley.CohesionForce.com

I'm attempting to run the Preferences Specification wizard for a language
IDE.

When doing so I get the wizard dialog, accept all the defaults for the
language, and click Finish.

The only thing that appears to happen then is that an <extension> element
is added to the plugin.xml file. No code for the preferences specification
capability is generated (such as the
"Ada.imp.preferences.AdaPreferencesInitiailizer" class that is referenced
in the extension element), nor do I see any "pfsp" file that I can select
and edit with the PrefSpecs editor.

Right-clicking on my plug-in project I see that there are menu entries for
"Enable Presentation Spec Builder"--which I'm told "is not currently
available" when I select it--and "Enable prefspecs Builder", which appears
to do nothing other than flash a brief "Building workspace" message down
in the status line. If there is supposed to be some sort of "toggle
indicator" for the latter, as there is for "Enable LPG Builder", that's
not appearing.

To the best of my knowledge I've got all the IMP components and have been
making steady progress up to this point.

I'm running IMP 0.1.74 on Eclipse 3.3.2 on a Windows XP box.

Thanks...

Marc A. Criley
Cohesion Force, Inc.
Previous Topic:IDE crash because of lpg executable?
Next Topic:Is there some kind of Guide to Prefspec field definitions?
Goto Forum:
  


Current Time: Sat Dec 20 20:51:06 GMT 2014

Powered by FUDForum. Page generated in 0.01977 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software