Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » Generating an update site with AJDT plug-in
Generating an update site with AJDT plug-in [message #57466] Sun, 16 October 2005 11:54 Go to next message
Eclipse User
Originally posted by: s_gutz.yahoo.com

When I try to create a new Eclipse update site with plug-ins that contain
aspects I get errors because the builder can't find the AspectJ runtime.
Basically my aspects can't be resolved.

Is there a way to generate a site with aspects or am I missing something
obvious?
Re: Generating an update site with AJDT plug-in [message #57732 is a reply to message #57466] Tue, 18 October 2005 11:23 Go to previous message
Sian January is currently offline Sian January
Messages: 83
Registered: July 2009
Member
Hi Steve,

How are you trying to export your plug-ins? If you are using the export
plug-in wizard in Eclipse there is a corresponding "Export plug-in with
AspectJ support" wizard. If you are using an ant build script you can
also create a suitable one of these by right clicking on plugin.xml and
selecting "Create Ant Build File With AspectJ Support".

Thanks,

Sian


Steve Gutz wrote:
> When I try to create a new Eclipse update site with plug-ins that contain
> aspects I get errors because the builder can't find the AspectJ runtime.
> Basically my aspects can't be resolved.
>
> Is there a way to generate a site with aspects or am I missing something
> obvious?
>
>
Re: Generating an update site with AJDT plug-in [message #590554 is a reply to message #57466] Tue, 18 October 2005 11:23 Go to previous message
Sian January is currently offline Sian January
Messages: 83
Registered: July 2009
Member
Hi Steve,

How are you trying to export your plug-ins? If you are using the export
plug-in wizard in Eclipse there is a corresponding "Export plug-in with
AspectJ support" wizard. If you are using an ant build script you can
also create a suitable one of these by right clicking on plugin.xml and
selecting "Create Ant Build File With AspectJ Support".

Thanks,

Sian


Steve Gutz wrote:
> When I try to create a new Eclipse update site with plug-ins that contain
> aspects I get errors because the builder can't find the AspectJ runtime.
> Basically my aspects can't be resolved.
>
> Is there a way to generate a site with aspects or am I missing something
> obvious?
>
>
Previous Topic:AspectJ 5 M4
Next Topic:Can't download 3.1 AspectJ 5 version
Goto Forum:
  


Current Time: Thu Jul 24 23:38:42 EDT 2014

Powered by FUDForum. Page generated in 0.02129 seconds