Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » elementFormDefault="qualified"
elementFormDefault="qualified" [message #564540] Wed, 08 January 2003 14:09
Eclipse UserFriend
Originally posted by: carman.itc.it

Does xsd have a problem dealing with the attribute declaration
elementFormDefault="qualified" in the schema element?

I have been analysing lots (a few hundred) wsdl documents by converting
them to schema documents (see previous email) and then loading them into
xsd. Most of them load without any problems! I have noticed, however,
that those with elementFormDefault set to "qualified" produce empty schema
objects (without type definitions and element declarations).

Some examples of wsdl documents from which I was unable to load the schema:
(Note that all of these files have probably been generated automatically
using the same software package - apache axis maybe? - which could have a
bug causing all the schemas to be invalid in the same way.)

http://dotnet.cyberthink.net/computerdictionary/computerdict ionary.asmx?wsdl
http://ntg.webs.innerhost.com/RSAFunctions/RSAFuncs.asmx?WSD L
http://terraservice.net/TerraService.asmx?WSDL
http://ws2.serviceobjects.net/ev/EmailValidate.asmx?WSDL
http://www.esynaps.com/WebServices/NFLNews.asmx?WSDL

Thanks a lot for all your help,

Mark

PS. Thanks Dave for your response about resolution returning dummy types.
Previous Topic:restricting attributes
Next Topic:elementFormDefault="qualified"
Goto Forum:
  


Current Time: Sun Dec 21 03:34:22 GMT 2014

Powered by FUDForum. Page generated in 0.01770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software