Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » javax.xml api versions
javax.xml api versions [message #563222] Fri, 11 April 2008 14:12
Paul Gardiner is currently offline Paul GardinerFriend
Messages: 94
Registered: July 2009
Member
The javax.xml bundle has a bundle version (1.3.4), but no api versions, many
of which are different from the budle version, so automatic association
won't work. In cases where other bundles use versions on their import
package headers, such as org.xml.sax;version="2.0.2", they won't resolve.
I think the versions are as follows (used this to fix my issues):

Export-Package: javax.xml;version="1.3.4",
javax.xml.datatype;version="1.3.4",
javax.xml.namespace;version="1.3.4",
javax.xml.parsers;version="1.3.4",
javax.xml.transform;version="1.3.4",
javax.xml.transform.dom;version="1.3.4",
javax.xml.transform.sax;version="1.3.4",
javax.xml.transform.stream;version="1.3.4",
javax.xml.validation;version="1.3.4",
javax.xml.xpath;version="1.3.4",
org.apache.xmlcommons;version="1.3.4",
org.w3c.dom;version="1.0",
org.w3c.dom.bootstrap;version="1.0",
org.w3c.dom.css;version="1.0",
org.w3c.dom.events;version="1.0",
org.w3c.dom.html;version="1.0",
org.w3c.dom.ls;version="1.0",
org.w3c.dom.ranges;version="1.0",
org.w3c.dom.stylesheets;version="1.0",
org.w3c.dom.traversal;version="1.0",
org.w3c.dom.views;version="1.0",
org.w3c.dom.xpath;version="1.0",
org.xml.sax;version="2.0.2",
org.xml.sax.ext;version="2.0.2",
org.xml.sax.helpers;version="2.0.2"

Thanks,
Paul
Previous Topic:xalan and serializer
Next Topic:Re: Unable to load localized model for javax.xml.soap
Goto Forum:
  


Current Time: Fri Dec 19 21:51:16 GMT 2014

Powered by FUDForum. Page generated in 0.02436 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software