Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP on eclipse 3.2M5?
TPTP on eclipse 3.2M5? [message #56706] Wed, 08 March 2006 21:35 Go to next message
Michael Moser is currently offline Michael MoserFriend
Messages: 914
Registered: July 2009
Senior Member
I was trying to run TPTP on eclipse 3.2M5 but I seem to get caught in a
version frenzy. While the installation of TPTP and agent controller, the
agent controller's configuration, the setting of the profiling
preferences and the specification of a profiling set all worked fine,
the actual execution& profiling always fails.

Since some error messages (depending on the VM used) indicated some
EMF/SDO/XSD error (java.lang.NoSuchMethodError:
org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;)
I tried with 3 different versions (2.1.0, 2.1.2, 2.2.0M5), but none
worked. I also tried using different VMs (IBM JSDK1.4.2, Sun VM 1.4.2
and Sun VM 1.5.0)

With Sun J2SDK 1.4.2 the error I get is:
---------------------------------------------
!ENTRY org.eclipse.core.jobs 4 2 2006-03-08 22:25:09.226
!MESSAGE An internal error occurred during: "Launching".
!STACK 0
java.lang.NoClassDefFoundError
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
at
org.eclipse.hyades.trace.internal.ui.TraceUIManager.getResou rceSet(TraceUIManager.java:193)
at
org.eclipse.hyades.trace.ui.UIPlugin.getResourceSet(UIPlugin .java:252)
at
org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.createM onitor(PDCoreUtil.java:389)
at
org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.launchT race(PDCoreUtil.java:662)
at
org.eclipse.hyades.trace.ui.internal.launcher.ProfileJavaApp licationDelegate.launch(ProfileJavaApplicationDelegate.java: 83)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:639)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:565)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:753)
at
org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlu gin.java:943)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
---------------------------------------------

With the IBM 1.4.2 JSDK and Sun's Java 5 VM the error is:
---------------------------------------------
!ENTRY org.eclipse.osgi 4 0 2006-03-08 22:27:59.986
!MESSAGE An error occurred while automatically activating bundle
org.eclipse.hyades.statistical.ui (380).
!STACK 0
org.osgi.framework.BundleException: The activator
org.eclipse.hyades.statistical.ui.UiPlugin for bundle
org.eclipse.hyades.statistical.ui is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:965)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:314)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:256)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .preFindLocalClass(EclipseLazyStarter.java:83)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:402)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:186)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:338)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:390)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugi n.java:241)
at
org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:51)
at
org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Work benchPlugin.java:237)
at
org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(EarlyStartupRunnable.java:115)
at
org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.runtime.Platform.run(Platform.java:816)
at org.eclipse.ui.internal.Workbench$20.run(Workbench.java:1745 )
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
Caused by: java.lang.NoSuchMethodError:
org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyFactoryImp l.init(HierarchyFactoryImpl.java:65)
at
org.eclipse.hyades.models.hierarchy.HierarchyFactory.<clinit >(HierarchyFactory.java:38)
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
at
org.eclipse.hyades.models.hierarchy.HierarchyPackage.<clinit >(HierarchyPackage.java:78)
at sun.misc.Unsafe.ensureClassInitialized(Native Method)
at
sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(Unsa feFieldAccessorFactory.java:25)
at
sun.reflect.ReflectionFactory.newFieldAccessor(ReflectionFac tory.java:122)
at java.lang.reflect.Field.acquireFieldAccessor(Field.java:917)
at java.lang.reflect.Field.getFieldAccessor(Field.java:898)
at java.lang.reflect.Field.get(Field.java:357)
at
org.eclipse.emf.ecore.plugin.RegistryReader$EPackageDescript or.getEPackage(RegistryReader.java:167)
at
org.eclipse.emf.ecore.impl.EPackageRegistryImpl.getEPackage( EPackageRegistryImpl.java:107)
at
org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:302)
at
org.eclipse.hyades.model.statistical.impl.StatisticalPackage Impl.init(StatisticalPackageImpl.java:222)
at org.eclipse.hyades.statistical.ui.UiPlugin.<init>(UiPlugin.java:97)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e
Method)
at
sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:4 94)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:136)
... 27 more
---------------------------------------------

Is there a combination of TPTP, EMF&SDO&XSD & VMs that works with
eclipse 3.2M5? Or do I also have to install yet another eclipse version
to do my profiling?

Michael
Re: TPTP on eclipse 3.2M5? [message #56733 is a reply to message #56706] Thu, 09 March 2006 05:25 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
You've done a really good job of documenting your Eclipse version
(3.2M5), EMF/XSD/SDO versions (2.1.0, 2.1.2, and 2.2.0M5), and even your
JVMs (okay, I'm tired of duplicating your extensive efforts... I'm sure
you are too!).

But you missed a key piece of information... what version of TPTP are
you using??!?

My recollection (and unfortunately it's been hectic shifting to i2 work
on 4.2 once i1 was over) is that THE version for 4.2i1 is ... (checks
web page) TPTP-4.2.0-200602281515 (the latest "stable build ... go to
TPTP downloads, and click the 4.2.0 download tab).

At the bottom of that download page are the Requirements:
3.2M5a (<== NOTE THE ****a****)
2.2.0M5 EMF/XSD/SDO
etc.

I seem to recall that the 3.2M5a was specifically introduced to fix the
problems you saw with the 3.2M5/2.2.0M5/4.2.0[M5?... wonder why the page
doesn't call it that... I think that is what it is!] combination.

I'm sorry for the troubles you're running into. 4.2 is "in development",
and yes, there has been an effort to get everything on the same
(Callisto) "train" with the M5 effort. You were close... just not quite
there.
--
RDS

Michael Moser wrote:
> I was trying to run TPTP on eclipse 3.2M5 but I seem to get caught in a
> version frenzy. While the installation of TPTP and agent controller, the
> agent controller's configuration, the setting of the profiling
> preferences and the specification of a profiling set all worked fine,
> the actual execution& profiling always fails.
>
> Since some error messages (depending on the VM used) indicated some
> EMF/SDO/XSD error (java.lang.NoSuchMethodError:
> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;)
> I tried with 3 different versions (2.1.0, 2.1.2, 2.2.0M5), but none
> worked. I also tried using different VMs (IBM JSDK1.4.2, Sun VM 1.4.2
> and Sun VM 1.5.0)
>
> With Sun J2SDK 1.4.2 the error I get is:
> ---------------------------------------------
> !ENTRY org.eclipse.core.jobs 4 2 2006-03-08 22:25:09.226
> !MESSAGE An internal error occurred during: "Launching".
> !STACK 0
> java.lang.NoClassDefFoundError
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>
> at
> org.eclipse.hyades.trace.internal.ui.TraceUIManager.getResou rceSet(TraceUIManager.java:193)
>
> at org.eclipse.hyades.trace.ui.UIPlugin.getResourceSet(UIPlugin .java:252)
> at
> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.createM onitor(PDCoreUtil.java:389)
>
> at
> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.launchT race(PDCoreUtil.java:662)
>
> at
> org.eclipse.hyades.trace.ui.internal.launcher.ProfileJavaApp licationDelegate.launch(ProfileJavaApplicationDelegate.java: 83)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:639)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:565)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:753)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlu gin.java:943)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
> ---------------------------------------------
>
> With the IBM 1.4.2 JSDK and Sun's Java 5 VM the error is:
> ---------------------------------------------
> !ENTRY org.eclipse.osgi 4 0 2006-03-08 22:27:59.986
> !MESSAGE An error occurred while automatically activating bundle
> org.eclipse.hyades.statistical.ui (380).
> !STACK 0
> org.osgi.framework.BundleException: The activator
> org.eclipse.hyades.statistical.ui.UiPlugin for bundle
> org.eclipse.hyades.statistical.ui is invalid
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:965)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:314)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:256)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .preFindLocalClass(EclipseLazyStarter.java:83)
>
> at
> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:402)
>
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:186)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:338)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:390)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
>
> at
> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
>
> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> at
> org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
>
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
>
> at
> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
>
> at
> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
>
> at
> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
>
> at
> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
>
> at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugi n.java:241)
> at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:51)
> at
> org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Work benchPlugin.java:237)
>
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(EarlyStartupRunnable.java:115)
>
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
>
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
> at org.eclipse.core.runtime.Platform.run(Platform.java:816)
> at org.eclipse.ui.internal.Workbench$20.run(Workbench.java:1745 )
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
> Caused by: java.lang.NoSuchMethodError:
> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;
>
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyFactoryImp l.init(HierarchyFactoryImpl.java:65)
>
> at
> org.eclipse.hyades.models.hierarchy.HierarchyFactory.<clinit >(HierarchyFactory.java:38)
>
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>
> at
> org.eclipse.hyades.models.hierarchy.HierarchyPackage.<clinit >(HierarchyPackage.java:78)
>
> at sun.misc.Unsafe.ensureClassInitialized(Native Method)
> at
> sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(Unsa feFieldAccessorFactory.java:25)
>
> at
> sun.reflect.ReflectionFactory.newFieldAccessor(ReflectionFac tory.java:122)
> at java.lang.reflect.Field.acquireFieldAccessor(Field.java:917)
> at java.lang.reflect.Field.getFieldAccessor(Field.java:898)
> at java.lang.reflect.Field.get(Field.java:357)
> at
> org.eclipse.emf.ecore.plugin.RegistryReader$EPackageDescript or.getEPackage(RegistryReader.java:167)
>
> at
> org.eclipse.emf.ecore.impl.EPackageRegistryImpl.getEPackage( EPackageRegistryImpl.java:107)
>
> at
> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:302)
>
> at
> org.eclipse.hyades.model.statistical.impl.StatisticalPackage Impl.init(StatisticalPackageImpl.java:222)
>
> at org.eclipse.hyades.statistical.ui.UiPlugin.<init>(UiPlugin.java:97)
> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e Method)
> at
> sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
>
> at
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
>
> at java.lang.reflect.Constructor.newInstance(Constructor.java:4 94)
> at java.lang.Class.newInstance0(Class.java:350)
> at java.lang.Class.newInstance(Class.java:303)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:136)
>
> ... 27 more
> ---------------------------------------------
>
> Is there a combination of TPTP, EMF&SDO&XSD & VMs that works with
> eclipse 3.2M5? Or do I also have to install yet another eclipse version
> to do my profiling?
>
> Michael
>
Re: TPTP on eclipse 3.2M5? [message #56760 is a reply to message #56733] Thu, 09 March 2006 05:40 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
Ahhh, found it... The main project page for TPTP (<
http://www.eclipse.org/tptp/index.html >) has, under "What's New", "TPTP
4.2 i1/M5 stable build available", and the accompanying "download" link
there takes you right to that 02281515 download page.
--
RDS

Randy D. Smith wrote:
> You've done a really good job of documenting your Eclipse version
> (3.2M5), EMF/XSD/SDO versions (2.1.0, 2.1.2, and 2.2.0M5), and even your
> JVMs (okay, I'm tired of duplicating your extensive efforts... I'm sure
> you are too!).
>
> But you missed a key piece of information... what version of TPTP are
> you using??!?
>
> My recollection (and unfortunately it's been hectic shifting to i2 work
> on 4.2 once i1 was over) is that THE version for 4.2i1 is ... (checks
> web page) TPTP-4.2.0-200602281515 (the latest "stable build ... go to
> TPTP downloads, and click the 4.2.0 download tab).
>
> At the bottom of that download page are the Requirements:
> 3.2M5a (<== NOTE THE ****a****)
> 2.2.0M5 EMF/XSD/SDO
> etc.
>
> I seem to recall that the 3.2M5a was specifically introduced to fix the
> problems you saw with the 3.2M5/2.2.0M5/4.2.0[M5?... wonder why the page
> doesn't call it that... I think that is what it is!] combination.
>
> I'm sorry for the troubles you're running into. 4.2 is "in development",
> and yes, there has been an effort to get everything on the same
> (Callisto) "train" with the M5 effort. You were close... just not quite
> there.
> --
> RDS
>
> Michael Moser wrote:
>
>> I was trying to run TPTP on eclipse 3.2M5 but I seem to get caught in
>> a version frenzy. While the installation of TPTP and agent controller,
>> the agent controller's configuration, the setting of the profiling
>> preferences and the specification of a profiling set all worked fine,
>> the actual execution& profiling always fails.
>>
>> Since some error messages (depending on the VM used) indicated some
>> EMF/SDO/XSD error (java.lang.NoSuchMethodError:
>> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;)
>> I tried with 3 different versions (2.1.0, 2.1.2, 2.2.0M5), but none
>> worked. I also tried using different VMs (IBM JSDK1.4.2, Sun VM 1.4.2
>> and Sun VM 1.5.0)
>>
>> With Sun J2SDK 1.4.2 the error I get is:
>> ---------------------------------------------
>> !ENTRY org.eclipse.core.jobs 4 2 2006-03-08 22:25:09.226
>> !MESSAGE An internal error occurred during: "Launching".
>> !STACK 0
>> java.lang.NoClassDefFoundError
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>>
>> at
>> org.eclipse.hyades.trace.internal.ui.TraceUIManager.getResou rceSet(TraceUIManager.java:193)
>>
>> at org.eclipse.hyades.trace.ui.UIPlugin.getResourceSet(UIPlugin .java:252)
>> at
>> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.createM onitor(PDCoreUtil.java:389)
>>
>> at
>> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.launchT race(PDCoreUtil.java:662)
>>
>> at
>> org.eclipse.hyades.trace.ui.internal.launcher.ProfileJavaApp licationDelegate.launch(ProfileJavaApplicationDelegate.java: 83)
>>
>> at
>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:639)
>>
>> at
>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:565)
>>
>> at
>> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:753)
>>
>> at
>> org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlu gin.java:943)
>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>> ---------------------------------------------
>>
>> With the IBM 1.4.2 JSDK and Sun's Java 5 VM the error is:
>> ---------------------------------------------
>> !ENTRY org.eclipse.osgi 4 0 2006-03-08 22:27:59.986
>> !MESSAGE An error occurred while automatically activating bundle
>> org.eclipse.hyades.statistical.ui (380).
>> !STACK 0
>> org.osgi.framework.BundleException: The activator
>> org.eclipse.hyades.statistical.ui.UiPlugin for bundle
>> org.eclipse.hyades.statistical.ui is invalid
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:965)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:314)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:256)
>>
>> at
>> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .preFindLocalClass(EclipseLazyStarter.java:83)
>>
>> at
>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:402)
>>
>> at
>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:186)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:338)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:390)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
>>
>> at
>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
>>
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
>> at
>> org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
>>
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
>>
>> at
>> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
>>
>> at
>> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
>>
>> at
>> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
>>
>> at
>> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
>>
>> at
>> org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugi n.java:241)
>> at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:51)
>> at
>> org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Work benchPlugin.java:237)
>>
>> at
>> org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(EarlyStartupRunnable.java:115)
>>
>> at
>> org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
>>
>> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
>> at org.eclipse.core.runtime.Platform.run(Platform.java:816)
>> at org.eclipse.ui.internal.Workbench$20.run(Workbench.java:1745 )
>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>> Caused by: java.lang.NoSuchMethodError:
>> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;
>>
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyFactoryImp l.init(HierarchyFactoryImpl.java:65)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.HierarchyFactory.<clinit >(HierarchyFactory.java:38)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.HierarchyPackage.<clinit >(HierarchyPackage.java:78)
>>
>> at sun.misc.Unsafe.ensureClassInitialized(Native Method)
>> at
>> sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(Unsa feFieldAccessorFactory.java:25)
>>
>> at
>> sun.reflect.ReflectionFactory.newFieldAccessor(ReflectionFac tory.java:122)
>>
>> at java.lang.reflect.Field.acquireFieldAccessor(Field.java:917)
>> at java.lang.reflect.Field.getFieldAccessor(Field.java:898)
>> at java.lang.reflect.Field.get(Field.java:357)
>> at
>> org.eclipse.emf.ecore.plugin.RegistryReader$EPackageDescript or.getEPackage(RegistryReader.java:167)
>>
>> at
>> org.eclipse.emf.ecore.impl.EPackageRegistryImpl.getEPackage( EPackageRegistryImpl.java:107)
>>
>> at
>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:302)
>>
>> at
>> org.eclipse.hyades.model.statistical.impl.StatisticalPackage Impl.init(StatisticalPackageImpl.java:222)
>>
>> at org.eclipse.hyades.statistical.ui.UiPlugin.<init>(UiPlugin.java:97)
>> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e Method)
>> at
>> sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
>>
>> at
>> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
>>
>> at java.lang.reflect.Constructor.newInstance(Constructor.java:4 94)
>> at java.lang.Class.newInstance0(Class.java:350)
>> at java.lang.Class.newInstance(Class.java:303)
>> at
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:136)
>>
>> ... 27 more
>> ---------------------------------------------
>>
>> Is there a combination of TPTP, EMF&SDO&XSD & VMs that works with
>> eclipse 3.2M5? Or do I also have to install yet another eclipse
>> version to do my profiling?
>>
>> Michael
>>
Re: TPTP on eclipse 3.2M5? [message #56787 is a reply to message #56733] Thu, 09 March 2006 08:37 Go to previous messageGo to next message
Michael Moser is currently offline Michael MoserFriend
Messages: 914
Registered: July 2009
Senior Member
NOW we got some music playing!
I had missed the eclipse 3.2M5a (<<< a!) version...

Thanks for pointing me into the right direction!
Michael
Re: TPTP on eclipse 3.2M5? [message #56814 is a reply to message #56760] Thu, 09 March 2006 08:38 Go to previous message
Michael Moser is currently offline Michael MoserFriend
Messages: 914
Registered: July 2009
Senior Member
Thanks, I had been using this version already. Shortly peeking into the
plugins directory I found it to contain a wild collection of jar files
with mixed 4.1.1 and 4.2.0 version suffixes. But the date is always
200602281515, so I guess that's ok.

Michael


"Randy D. Smith" <randy.d.smith@intel.com> wrote in message
news:duof42$j60$1@utils.eclipse.org...
> Ahhh, found it... The main project page for TPTP (<
> http://www.eclipse.org/tptp/index.html >) has, under "What's New",
> "TPTP 4.2 i1/M5 stable build available", and the accompanying
> "download" link there takes you right to that 02281515 download page.
> --
> RDS
>
> Randy D. Smith wrote:
>> You've done a really good job of documenting your Eclipse version
>> (3.2M5), EMF/XSD/SDO versions (2.1.0, 2.1.2, and 2.2.0M5), and even
>> your JVMs (okay, I'm tired of duplicating your extensive efforts...
>> I'm sure you are too!).
>>
>> But you missed a key piece of information... what version of TPTP are
>> you using??!?
>>
>> My recollection (and unfortunately it's been hectic shifting to i2
>> work on 4.2 once i1 was over) is that THE version for 4.2i1 is ...
>> (checks web page) TPTP-4.2.0-200602281515 (the latest "stable build
>> ... go to TPTP downloads, and click the 4.2.0 download tab).
>>
>> At the bottom of that download page are the Requirements:
>> 3.2M5a (<== NOTE THE ****a****)
>> 2.2.0M5 EMF/XSD/SDO
>> etc.
>>
>> I seem to recall that the 3.2M5a was specifically introduced to fix
>> the problems you saw with the 3.2M5/2.2.0M5/4.2.0[M5?... wonder why
>> the page doesn't call it that... I think that is what it is!]
>> combination.
>>
>> I'm sorry for the troubles you're running into. 4.2 is "in
>> development", and yes, there has been an effort to get everything on
>> the same (Callisto) "train" with the M5 effort. You were close...
>> just not quite there.
>> --
>> RDS
>>
>> Michael Moser wrote:
>>
>>> I was trying to run TPTP on eclipse 3.2M5 but I seem to get caught
>>> in a version frenzy. While the installation of TPTP and agent
>>> controller, the agent controller's configuration, the setting of the
>>> profiling preferences and the specification of a profiling set all
>>> worked fine, the actual execution& profiling always fails.
>>>
>>> Since some error messages (depending on the VM used) indicated some
>>> EMF/SDO/XSD error (java.lang.NoSuchMethodError:
>>> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;)
>>> I tried with 3 different versions (2.1.0, 2.1.2, 2.2.0M5), but none
>>> worked. I also tried using different VMs (IBM JSDK1.4.2, Sun VM
>>> 1.4.2 and Sun VM 1.5.0)
>>>
>>> With Sun J2SDK 1.4.2 the error I get is:
>>> ---------------------------------------------
>>> !ENTRY org.eclipse.core.jobs 4 2 2006-03-08 22:25:09.226
>>> !MESSAGE An internal error occurred during: "Launching".
>>> !STACK 0
>>> java.lang.NoClassDefFoundError
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>>> at
>>> org.eclipse.hyades.trace.internal.ui.TraceUIManager.getResou rceSet(TraceUIManager.java:193)
>>> at
>>> org.eclipse.hyades.trace.ui.UIPlugin.getResourceSet(UIPlugin .java:252)
>>> at
>>> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.createM onitor(PDCoreUtil.java:389)
>>> at
>>> org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.launchT race(PDCoreUtil.java:662)
>>> at
>>> org.eclipse.hyades.trace.ui.internal.launcher.ProfileJavaApp licationDelegate.launch(ProfileJavaApplicationDelegate.java: 83)
>>> at
>>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:639)
>>> at
>>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:565)
>>> at
>>> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:753)
>>> at
>>> org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlu gin.java:943)
>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>>> ---------------------------------------------
>>>
>>> With the IBM 1.4.2 JSDK and Sun's Java 5 VM the error is:
>>> ---------------------------------------------
>>> !ENTRY org.eclipse.osgi 4 0 2006-03-08 22:27:59.986
>>> !MESSAGE An error occurred while automatically activating bundle
>>> org.eclipse.hyades.statistical.ui (380).
>>> !STACK 0
>>> org.osgi.framework.BundleException: The activator
>>> org.eclipse.hyades.statistical.ui.UiPlugin for bundle
>>> org.eclipse.hyades.statistical.ui is invalid
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:965)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:314)
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:256)
>>> at
>>> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .preFindLocalClass(EclipseLazyStarter.java:83)
>>> at
>>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:402)
>>> at
>>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:186)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:338)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:390)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:351)
>>> at
>>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:81)
>>> at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:276)
>>> at
>>> org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1245)
>>> at
>>> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:138)
>>> at
>>> org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:759)
>>> at
>>> org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
>>> at
>>> org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
>>> at
>>> org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugi n.java:241)
>>> at
>>> org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:51)
>>> at
>>> org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Work benchPlugin.java:237)
>>> at
>>> org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(EarlyStartupRunnable.java:115)
>>> at
>>> org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
>>> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
>>> at org.eclipse.core.runtime.Platform.run(Platform.java:816)
>>> at org.eclipse.ui.internal.Workbench$20.run(Workbench.java:1745 )
>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>>> Caused by: java.lang.NoSuchMethodError:
>>> org.eclipse.emf.ecore.EPackage$Registry.getEFactory(Ljava/la ng/String;)Lorg/eclipse/emf/ecore/EFactory;
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyFactoryImp l.init(HierarchyFactoryImpl.java:65)
>>> at
>>> org.eclipse.hyades.models.hierarchy.HierarchyFactory.<clinit >(HierarchyFactory.java:38)
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l. <init>(HierarchyPackageImpl.java:263)
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:304)
>>> at
>>> org.eclipse.hyades.models.hierarchy.HierarchyPackage.<clinit >(HierarchyPackage.java:78)
>>> at sun.misc.Unsafe.ensureClassInitialized(Native Method)
>>> at
>>> sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(Unsa feFieldAccessorFactory.java:25)
>>> at
>>> sun.reflect.ReflectionFactory.newFieldAccessor(ReflectionFac tory.java:122)
>>> at java.lang.reflect.Field.acquireFieldAccessor(Field.java:917)
>>> at java.lang.reflect.Field.getFieldAccessor(Field.java:898)
>>> at java.lang.reflect.Field.get(Field.java:357)
>>> at
>>> org.eclipse.emf.ecore.plugin.RegistryReader$EPackageDescript or.getEPackage(RegistryReader.java:167)
>>> at
>>> org.eclipse.emf.ecore.impl.EPackageRegistryImpl.getEPackage( EPackageRegistryImpl.java:107)
>>> at
>>> org.eclipse.hyades.models.hierarchy.impl.HierarchyPackageImp l.init(HierarchyPackageImpl.java:302)
>>> at
>>> org.eclipse.hyades.model.statistical.impl.StatisticalPackage Impl.init(StatisticalPackageImpl.java:222)
>>> at
>>> org.eclipse.hyades.statistical.ui.UiPlugin.<init>(UiPlugin.java:97)
>>> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e
>>> Method)
>>> at
>>> sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
>>> at
>>> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
>>> at java.lang.reflect.Constructor.newInstance(Constructor.java:4 94)
>>> at java.lang.Class.newInstance0(Class.java:350)
>>> at java.lang.Class.newInstance(Class.java:303)
>>> at
>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:136)
>>> ... 27 more
>>> ---------------------------------------------
>>>
>>> Is there a combination of TPTP, EMF&SDO&XSD & VMs that works with
>>> eclipse 3.2M5? Or do I also have to install yet another eclipse
>>> version to do my profiling?
>>>
>>> Michael
>>>
Previous Topic:Fail to execute "An Introduction to Using TPTP's Automated GUI Recorder"
Next Topic:HTTP Recording
Goto Forum:
  


Current Time: Fri Nov 28 20:48:54 GMT 2014

Powered by FUDForum. Page generated in 0.06768 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software