Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » eRCP » Product Configuration Verification
Product Configuration Verification [message #563115] Wed, 17 June 2009 10:22
Baskaran is currently offline Baskaran
Messages: 5
Registered: July 2009
Junior Member
I have developed a sample application and created a new product
configuration, ie., plug-ins based one. I configured it and can able to
export it and it works fine after exporting.

I have created the product configuration for the same sample application
based on features and added all the features which contains all the
relevant plug-ins referred in my sample application. I have exported it
and it says the following error:
"The Eclipse executable launcher was unable to locate its comapnion shared
library."

Then I have compared the plugins folder contents with both the product
configuration options, namely plug-ins based and the feature based and
found that,

1, "org.eclipse.equinox.launcher" and
2, "org.eclipse.equinox.launcher.win32.win32.x86"

plugins are available in plugins based product and not in the feature
based product.

Then I have added these two plugins in the feature based product
configuration and exported it and it works fine thereafter.

Is it the expecting behaviour?

If those two plugins are automatically added to the plugins based product,
then why not its happening for the feature based product?

Can anybody clarify me?

Thanks.
Previous Topic:Re: Integrating eRCP Javadoc
Next Topic:Product Configuration Verification
Goto Forum:
  


Current Time: Fri Sep 19 03:55:24 GMT 2014

Powered by FUDForum. Page generated in 0.01568 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software