Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Legacy RCP Applications
Legacy RCP Applications [message #561847] Fri, 31 July 2009 17:57
Chris  is currently offline Chris
Messages: 4
Registered: September 2009
Junior Member
It's my understanding that the latest stable build of Eclipse e4 0.9 RC2
should be able to launch legacy RCP applications, but I am not having very
much success. If this is the wrong forum for this discussion, can you
point me to the correct one?

For my first attempt, I tried creating a simple RCP application using
Eclipse 3.5 and the provided template "RCP Application with a view". I
opened up the MANIFEST.MF and I launched my simple RCP application
successfully using the link under "Testing" called "Launch and Eclipse
application".

I then ran Eclipse e4 v0.9 RC2 and created a new workspace and imported
that plugin. When I tried to launch the RCP application using e4, I
received a BundleException that said the Activator is invalid and the root
cause of that exception was a ClassNotFoundException stating it could not
find the Activator.

I checked the /bin directory, everything is there as it should be. It
just seems like it expects the class files to be somewhere else. Are
there any gotchas that I should be aware of when running a legacy RCP
application like the one created using the template?

Thanks,
Chris
Previous Topic:Can not run demo/sample projects
Next Topic:xmi version of the workbench model, can these be used to create a workbench?
Goto Forum:
  


Current Time: Sat Sep 20 02:14:36 GMT 2014

Powered by FUDForum. Page generated in 0.01533 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software