Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Could not instantiate provider org.eclipse.team.svn.core.svnnature(Problems with SVN Installation in buckminster)
Could not instantiate provider org.eclipse.team.svn.core.svnnature [message #559582] Fri, 17 September 2010 09:32 Go to next message
Michael Breu is currently offline Michael Breu
Messages: 19
Registered: April 2010
Location: Inzing, Austria
Junior Member
Hello,

I'm about to set up a Hudson-based provisioning site for our RCP-product with the buckminster-plugin.

I succeeded in setting up the complete resolution stuff based on Buckminster3.5. However now I'm getting the following error.

ERROR: Could not instantiate provider org.eclipse.team.svn.core.svnnature for project info.squam.ocl.evaluator.
org.eclipse.team.core.TeamException: Could not instantiate provider org.eclipse.team.svn.core.svnnature for project info.squam.ocl.evaluator.
    at org.eclipse.team.core.RepositoryProvider.mapNewProvider(RepositoryProvider.java:165)
    at org.eclipse.team.core.RepositoryProvider.mapExistingProvider(RepositoryProvider.java:235)
    at org.eclipse.team.core.RepositoryProvider.getProvider(RepositoryProvider.java:507)
    at org.eclipse.team.internal.core.TeamHookDispatcher.getProvider(TeamHookDispatcher.java:97)
    at org.eclipse.team.internal.core.TeamHookDispatcher.getRuleFactory(TeamHookDispatcher.java:105)
    at org.eclipse.core.internal.resources.Rules.factoryFor(Rules.java:92)
    at org.eclipse.core.internal.resources.Rules.modifyRule(Rules.java:136)
    at org.eclipse.core.internal.resources.Project.open(Project.java:885)
    at org.eclipse.buckminster.core.materializer.WorkspaceMaterializer.createProjectBinding(WorkspaceMaterializer.java:484)
    at org.eclipse.buckminster.core.materializer.WorkspaceMaterializer.installLocal(WorkspaceMaterializer.java:191)
    at org.eclipse.buckminster.core.materializer.WorkspaceMaterializer.performInstallAction(WorkspaceMaterializer.java:220)


I found some advice on setting up the missing svn stuff. However it seems to be related to buckminster 3.6. I experimented a little bit with the repositories. The following command
./director/director -r http://download.eclipse.org/tools/buckminster/headless-3.5,http://download.eclipse.org/releases/galileo/,http://subclipse.tigris.org/update_1.6.x,http://download.eclipse.org/technology/subversive/0.7/headless-update-site/ -d `pwd`/buckminster -P Buckminster -i org.eclipse.buckminster.cmdline.product -i org.eclipse.buckminster.core.headless.feature.feature.group -i org.eclipse.team.svn.feature.group -i org.eclipse.buckminster.pde.headless.feature.feature.group -i org.tigris.subversion.subclipse.feature.group -i org.tigris.subversion.clientadapter.svnkit.feature.feature.group -consolelog


returns
...
17.09.2010 11:26:16 org.apache.commons.httpclient.HttpMethodBase processCookieHeaders
WARNUNG: Cookie rejected: "$Version=0; JSESSIONID=C988EB3DAD82E40042B5DF382F030F8C; $Path=/servlets". Illegal path attribute "/servlets". Path of origin: "/update_1.6.x/content.xml"
Installing org.eclipse.buckminster.cmdline.product 1.1.350.r11146.
Installing org.eclipse.buckminster.core.headless.feature.feature.group 1.1.350.r11409.
Installing org.eclipse.team.svn.feature.group 0.7.8.I20091023-1300.
Installing org.eclipse.buckminster.pde.headless.feature.feature.group 1.1.350.r11409.
Installing org.tigris.subversion.subclipse.feature.group 1.6.13.
Installing org.tigris.subversion.clientadapter.svnkit.feature.feature.group 1.6.12.
Operation completed in 35584 ms.


The warning about incorrect cookies seem neglectable to me.

So it claims to have installed the org.eclipse.team.svn features but I cannot find any in buckminster's plugin directory.
The problem is still there.

What repositories do i need, in order to install the plugins correctly?

Thanks in advance

Michael
Re: Could not instantiate provider org.eclipse.team.svn.core.svnnature [message #559614 is a reply to message #559582] Fri, 17 September 2010 11:46 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
One likely cause is that you use Java 1.5. SVNKit now contains 1.6 specific classes.

- thomas

On 09/17/2010 11:32 AM, Michael Breu wrote:
> Hello,
>
> I'm about to set up a Hudson-based provisioning site for our RCP-product
> with the http://wiki.hudson-ci.org/display/HUDSON/Buckminster+PlugIn
>
> I succeeded in setting up the complete resolution stuff based on
> Buckminster3.5. However now I'm getting the following error.
>
> ERROR: Could not instantiate provider
> org.eclipse.team.svn.core.svnnature for project info.squam.ocl.evaluator.
> org.eclipse.team.core.TeamException: Could not instantiate provider
> org.eclipse.team.svn.core.svnnature for project info.squam.ocl.evaluator.
> at
> org.eclipse.team.core.RepositoryProvider.mapNewProvider(Repo sitoryProvider.java:165)
>
> at
> org.eclipse.team.core.RepositoryProvider.mapExistingProvider (RepositoryProvider.java:235)
>
> at
> org.eclipse.team.core.RepositoryProvider.getProvider(Reposit oryProvider.java:507)
>
> at
> org.eclipse.team.internal.core.TeamHookDispatcher.getProvide r(TeamHookDispatcher.java:97)
>
> at
> org.eclipse.team.internal.core.TeamHookDispatcher.getRuleFac tory(TeamHookDispatcher.java:105)
>
> at org.eclipse.core.internal.resources.Rules.factoryFor(Rules.j ava:92)
> at org.eclipse.core.internal.resources.Rules.modifyRule(Rules.j ava:136)
> at org.eclipse.core.internal.resources.Project.open(Project.jav a:885)
> at
> org.eclipse.buckminster.core.materializer.WorkspaceMateriali zer.createProjectBinding(WorkspaceMaterializer.java:484)
>
> at
> org.eclipse.buckminster.core.materializer.WorkspaceMateriali zer.installLocal(WorkspaceMaterializer.java:191)
>
> at
> org.eclipse.buckminster.core.materializer.WorkspaceMateriali zer.performInstallAction(WorkspaceMaterializer.java:220)
>
>
>
> I found some
> http://heath-tech.blogspot.com/2010/04/bootstrapping-buckmin ster-with.html
> on setting up the missing svn stuff. However it seems to be related to
> buckminster 3.6. I experimented a little bit with the repositories. The
> following command /director/director -r
> http://download.eclipse.org/tools/buckminster/headless-3.5,h ttp://download.eclipse.org/releases/galileo/,http://subclips e.tigris.org/update_1.6.x,http://download.eclipse.org/techno logy/subversive/0.7/headless-update-site/
> -d `pwd`/buckminster -P Buckminster -i
> org.eclipse.buckminster.cmdline.product -i
> org.eclipse.buckminster.core.headless.feature.feature.group -i
> org.eclipse.team.svn.feature.group -i
> org.eclipse.buckminster.pde.headless.feature.feature.group -i
> org.tigris.subversion.subclipse.feature.group -i
> org.tigris.subversion.clientadapter.svnkit.feature.feature.g roup
> -consolelog
>
>
> returns
> ...
> 17.09.2010 11:26:16 org.apache.commons.httpclient.HttpMethodBase
> processCookieHeaders
> WARNUNG: Cookie rejected: "$Version=0;
> JSESSIONID=C988EB3DAD82E40042B5DF382F030F8C; $Path=/servlets". Illegal
> path attribute "/servlets". Path of origin: "/update_1.6.x/content.xml"
> Installing org.eclipse.buckminster.cmdline.product 1.1.350.r11146.
> Installing org.eclipse.buckminster.core.headless.feature.feature.group
> 1.1.350.r11409.
> Installing org.eclipse.team.svn.feature.group 0.7.8.I20091023-1300.
> Installing org.eclipse.buckminster.pde.headless.feature.feature.group
> 1.1.350.r11409.
> Installing org.tigris.subversion.subclipse.feature.group 1.6.13.
> Installing
> org.tigris.subversion.clientadapter.svnkit.feature.feature.g roup 1.6.12.
> Operation completed in 35584 ms.
>
>
> The warning about incorrect cookies seem neglectable to me.
>
> So it claims to have installed the org.eclipse.team.svn features but I
> cannot find any in buckminster's plugin directory.
> The problem is still there.
>
> What repositories do i need, in order to install the plugins correctly?
>
> Thanks in advance
>
> Michael
Re: Could not instantiate provider org.eclipse.team.svn.core.svnnature [message #559800 is a reply to message #559614] Sat, 18 September 2010 16:52 Go to previous message
Michael Breu is currently offline Michael Breu
Messages: 19
Registered: April 2010
Location: Inzing, Austria
Junior Member
Hi Thomas,

I just checked it, The java version is OpenJDK Server VM (build 1.6.0_0-b11, mixed mode) under Debian Lenny.

What puzzles me, is that no org.eclipse.team.svn....jar and no
org.eclipse.team.svn.core....jar gets installed , although director claims
Installing org.eclipse.team.svn.feature.group 0.7.8.I20091023-1300

Perhaps I use the wrong repositories?

Michael
Previous Topic:missing native launcher?
Next Topic:user_homedir ->null ?
Goto Forum:
  


Current Time: Sun Oct 26 05:20:17 GMT 2014

Powered by FUDForum. Page generated in 0.23810 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software