Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » How to start a bundle
How to start a bundle [message #558085] Fri, 10 September 2010 07:15 Go to next message
guofeng zhang is currently offline guofeng zhang
Messages: 49
Registered: July 2009
Member
I am new to Virgo. I developed a "Hello world" bundle (a simple bundle with only a Activator). I copy it to pickup.

I use Virgo Web UI to see the state of the bundle. It displayed as "Starting'.

How to change it to "Active"?

Thanks!
Re: How to start a bundle [message #558088 is a reply to message #558085] Fri, 10 September 2010 07:36 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Bundles normally transition quickly from STARTING to ACTIVE.

It seems that something odd is happening such as the start method in your bundle activator taking a long time to complete or failing in some novel way. You may like to take a thread dump, e.g. using jstack, to see if the activator start method is still running.

What console messages appear? These should show the progress of the bundle.

(I am assuming that you didn't try to use Spring DM in the bundle to create or reference services - that would be beyond a typical hello world.)
Re: How to start a bundle [message #559565 is a reply to message #558088] Fri, 17 September 2010 08:33 Go to previous messageGo to next message
guofeng zhang is currently offline guofeng zhang
Messages: 49
Registered: July 2009
Member
That is my mistake. The sample set "Bundle-ActivationPolicy" to lazy.

Telnet to the console and start it changed it to active

Thanks!
Re: How to start a bundle [message #559598 is a reply to message #559565] Fri, 17 September 2010 10:42 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Glad it's working as expected now.
Previous Topic:how to setup jprofiler with virgo server
Next Topic:Configuration bundles for ManagedServiceFactory
Goto Forum:
  


Current Time: Fri Oct 24 10:29:59 GMT 2014

Powered by FUDForum. Page generated in 0.02669 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software