Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Software updates - can't add update sites
Software updates - can't add update sites [message #557683] Wed, 08 September 2010 09:55 Go to next message
Matthew Dickie is currently offline Matthew Dickie
Messages: 56
Registered: July 2009
Member
Hi all,

I have finally managed to export an Eclipse product (a feature product)
where I can get the Software Updates dialog to appear (by setting
p2.gathering=true).

The problem I now have is that the dialog that appears is missing the
section where update sites are managed (the Work With: section). The
description of the dialog is 'Check the items that you wish to install.'
instead of 'Select a site or enter the location of a site.'. The main
table area of the dialog shows 'There are no categorized items' rather
than 'There is no site selected' as my Eclipse installation does.

This makes it impossible for the user to install any additional software
they may desire. Can anyone please explain why this is, and how I can
fix it?

Thanks in advance...

Matt D.
Re: Software updates - can't add update sites [message #557918 is a reply to message #557683] Thu, 09 September 2010 08:01 Go to previous messageGo to next message
Matthew Dickie is currently offline Matthew Dickie
Messages: 56
Registered: July 2009
Member
I have found the class for this wizard page,
org.eclipse.equinox.internal.p2.ui.dialogs.AvailableIUsPage (I am using
Eclipse 3.5.1). It seems that the repository selection group isn't
created because there isn't a repository manipulator (method
createRepoArea). What on earth that is and how I am supposed to provide
one I don't know. Google didn't really help, neither does the p2 wiki. I
will look into it further.

I have been trying to figure out how to create a product with working
software updates for quite some time, over a month on and off. For some
reason no-one ever answers my questions about it on any of the various
Eclipse newsgroups where I have asked (pde, platform, this one). Can
someone please help me on this? It is taking far too much of my time. If
I can't get it working soon I will probably just create an Eclipse bug,
because it should be easier to work out what to do that this...

Any help would be very much appreciated.

On 08/09/2010 14:55, Matthew Dickie wrote:
> Hi all,
>
> I have finally managed to export an Eclipse product (a feature product)
> where I can get the Software Updates dialog to appear (by setting
> p2.gathering=true).
>
> The problem I now have is that the dialog that appears is missing the
> section where update sites are managed (the Work With: section). The
> description of the dialog is 'Check the items that you wish to install.'
> instead of 'Select a site or enter the location of a site.'. The main
> table area of the dialog shows 'There are no categorized items' rather
> than 'There is no site selected' as my Eclipse installation does.
>
> This makes it impossible for the user to install any additional software
> they may desire. Can anyone please explain why this is, and how I can
> fix it?
>
> Thanks in advance...
>
> Matt D.
Re: Software updates - can't add update sites [message #557993 is a reply to message #557918] Thu, 09 September 2010 13:11 Go to previous message
Matthew Dickie is currently offline Matthew Dickie
Messages: 56
Registered: July 2009
Member
I have finally fixed this by adding the following to the start() method
of the activator for my UI plugin:
Policy policy = new SDKPolicy();
context.registerService(Policy.class.getName(), policy, null);

Now, looking at the documentation on the Eclipse wiki at
http://wiki.eclipse.org/Equinox/p2/Adding_Self_Update_to_an_ RCP_Application-3.5,
the suggestion is that allowing users to add update repositories is the
default behaviour (as the Updating from the Cloud section describes how
to turn this behaviour off). I would expect for a IDE product (where the
application is org.eclipse.ui.ide.workbench), the default policy should
be the SDKPolicy, and clients who wish to have p2 enabled IDEs should
not have to specifiy this themselves. Am I missing something.

Perhaps this is because I am using Eclipse3.5.1 where all this stuff is
a bit flaky. I have tried using Eclipse3.6.0 but I get the error message
'Cannot complete the request. This installation has not be configured
properly for Software Updates'. This is the message I get for Eclipse
3.5.1 if p2.gathering=true is not specified, but here it was? Why is this?

I am still very tempted to create an Eclipse bug for this, because it
should be much easier than this to create a p2 enabled product.
Previous Topic:[CDO] A product with no head
Next Topic:Security Manager confusion
Goto Forum:
  


Current Time: Thu Aug 21 22:16:31 EDT 2014

Powered by FUDForum. Page generated in 0.02273 seconds