Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » Gantt -> Java 5.0?
Gantt -> Java 5.0? [message #55940] Sun, 13 July 2008 16:58 Go to next message
Emil Crumhorn is currently offline Emil Crumhorn
Messages: 169
Registered: July 2009
Senior Member
I was wondering if anyone has any major objections for the Gantt chart to
move to use Java 5.

I'm getting really tired of all the object casting I do to make it conform
to 1.4, which is not only error prone but slow, and there's quite a lot of
useful other Java 5 features I'd like to bring in. I really don't have a
clue how many use the Gantt chart apart from a few emails here and there and
what peoples requirements are as far as Java versions go. It seems at this
point most have moved to Java 5. But before I do anything drastic I thought
I'd check and see. I recall Nebula builds breaking under 5.0 or something,
but how long are we going to live under 1.4, at some point we got to move
on, right?

Feel free to chime in even if you don't use the widget. The other widgets I
don't mind leaving at 1.4 as the size of the code is considerably smaller.

Emil

--

Nebula Committer
http://www.hexapixel.com/
Re: Gantt -> Java 5.0? [message #55995 is a reply to message #55940] Mon, 14 July 2008 06:57 Go to previous messageGo to next message
Laurent Marchal is currently offline Laurent Marchal
Messages: 91
Registered: July 2009
Member
+1 for moving to java 5 !

Emil Crumhorn wrote:
> I was wondering if anyone has any major objections for the Gantt chart to
> move to use Java 5.
>
> I'm getting really tired of all the object casting I do to make it conform
> to 1.4, which is not only error prone but slow, and there's quite a lot of
> useful other Java 5 features I'd like to bring in. I really don't have a
> clue how many use the Gantt chart apart from a few emails here and there and
> what peoples requirements are as far as Java versions go. It seems at this
> point most have moved to Java 5. But before I do anything drastic I thought
> I'd check and see. I recall Nebula builds breaking under 5.0 or something,
> but how long are we going to live under 1.4, at some point we got to move
> on, right?
>
> Feel free to chime in even if you don't use the widget. The other widgets I
> don't mind leaving at 1.4 as the size of the code is considerably smaller.
>
> Emil
>
Re: Gantt -> Java 5.0? [message #58433 is a reply to message #55940] Thu, 28 August 2008 11:19 Go to previous message
Alexander Karnstedt is currently offline Alexander Karnstedt
Messages: 68
Registered: July 2009
Member
Wouldn't that make it harder to comply with Eclipse 3.3/3.4?

http://www.eclipse.org/eclipse/development/eclipse_project_p lan_3_4.html

.... as long as Eclipse states a vast compatibility with Java 1.4?

For instance we are using the Gantt chart within a RCP application and due to
third library constraints we could have moved to Java 5 just a couple of months
ago.

Alex


Emil Crumhorn schrieb am 13.07.2008 22:58:
> I was wondering if anyone has any major objections for the Gantt chart to
> move to use Java 5.
>
> I'm getting really tired of all the object casting I do to make it conform
> to 1.4, which is not only error prone but slow, and there's quite a lot of
> useful other Java 5 features I'd like to bring in. I really don't have a
> clue how many use the Gantt chart apart from a few emails here and there and
> what peoples requirements are as far as Java versions go. It seems at this
> point most have moved to Java 5. But before I do anything drastic I thought
> I'd check and see. I recall Nebula builds breaking under 5.0 or something,
> but how long are we going to live under 1.4, at some point we got to move
> on, right?
>
> Feel free to chime in even if you don't use the widget. The other widgets I
> don't mind leaving at 1.4 as the size of the code is considerably smaller.
>
> Emil
>
Re: Gantt -> Java 5.0? [message #591083 is a reply to message #55940] Mon, 14 July 2008 06:57 Go to previous message
Laurent Marchal is currently offline Laurent Marchal
Messages: 91
Registered: July 2009
Member
+1 for moving to java 5 !

Emil Crumhorn wrote:
> I was wondering if anyone has any major objections for the Gantt chart to
> move to use Java 5.
>
> I'm getting really tired of all the object casting I do to make it conform
> to 1.4, which is not only error prone but slow, and there's quite a lot of
> useful other Java 5 features I'd like to bring in. I really don't have a
> clue how many use the Gantt chart apart from a few emails here and there and
> what peoples requirements are as far as Java versions go. It seems at this
> point most have moved to Java 5. But before I do anything drastic I thought
> I'd check and see. I recall Nebula builds breaking under 5.0 or something,
> but how long are we going to live under 1.4, at some point we got to move
> on, right?
>
> Feel free to chime in even if you don't use the widget. The other widgets I
> don't mind leaving at 1.4 as the size of the code is considerably smaller.
>
> Emil
>
Re: Gantt -> Java 5.0? [message #591965 is a reply to message #55940] Thu, 28 August 2008 11:19 Go to previous message
Alexander Karnstedt is currently offline Alexander Karnstedt
Messages: 68
Registered: July 2009
Member
Wouldn't that make it harder to comply with Eclipse 3.3/3.4?

http://www.eclipse.org/eclipse/development/eclipse_project_p lan_3_4.html

.... as long as Eclipse states a vast compatibility with Java 1.4?

For instance we are using the Gantt chart within a RCP application and due to
third library constraints we could have moved to Java 5 just a couple of months
ago.

Alex


Emil Crumhorn schrieb am 13.07.2008 22:58:
> I was wondering if anyone has any major objections for the Gantt chart to
> move to use Java 5.
>
> I'm getting really tired of all the object casting I do to make it conform
> to 1.4, which is not only error prone but slow, and there's quite a lot of
> useful other Java 5 features I'd like to bring in. I really don't have a
> clue how many use the Gantt chart apart from a few emails here and there and
> what peoples requirements are as far as Java versions go. It seems at this
> point most have moved to Java 5. But before I do anything drastic I thought
> I'd check and see. I recall Nebula builds breaking under 5.0 or something,
> but how long are we going to live under 1.4, at some point we got to move
> on, right?
>
> Feel free to chime in even if you don't use the widget. The other widgets I
> don't mind leaving at 1.4 as the size of the code is considerably smaller.
>
> Emil
>
Previous Topic:GridViewer - Paging
Next Topic:CDateTime widget in a Table
Goto Forum:
  


Current Time: Wed Apr 23 17:45:07 EDT 2014

Powered by FUDForum. Page generated in 0.01965 seconds