Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Error when trying to build a P2 enabled product on Mac OS X / Cocoa
Error when trying to build a P2 enabled product on Mac OS X / Cocoa [message #555559] Fri, 27 August 2010 07:34
Youval Bronicki is currently offline Youval BronickiFriend
Messages: 14
Registered: July 2009
Junior Member
I've tried to P2 enabled my product (and Eclipse-based IDE) by checking 'Generate Metadata Repository' in the PDE product export wizard.

The exported product won't launch - the error log contains the message:

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini)

The same problem happens if I run a headless build with p2.gathering=true


If I don't check 'Generate Metadata Repository', the product works fine, but software updates don't work.

I'm using Eclipse 3.6 with OS=macosx, ARCH=x86_64, WS=cocoa

I'll appreciate any hints.

Youval
Previous Topic:how to detect whether a plug-in was installed or not when installing new features by update site
Next Topic:Re: Bundle Ad-Hoc Classloading Options In 3.6, Revisited
Goto Forum:
  


Current Time: Sun Dec 21 09:58:55 GMT 2014

Powered by FUDForum. Page generated in 0.02386 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software