Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Extension Point refuses to connect
Extension Point refuses to connect [message #553437] Tue, 17 August 2010 14:11
Frank Mising name is currently offline Frank Mising name
Messages: 6
Registered: July 2009
Junior Member
Another example of
How do you call "Everything compiles, but nothing works"? "Loose coupling"! Confused

Galileo with RCP Version: 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6
Build id: M20100211-1343

Had two plugins connected via extension point mechanism, which worked fine. Then I've installed the "RCP Book Tools", which required some Mylin packages. SW install worked fine without problems. Unfortunately I did not backup eclipse prior to that update.

Since that update:
IExtensionRegistry registry = Platform.getExtensionRegistry();
IConfigurationElement[] elements = registry.getConfigurationElementsFor(pluginid, extensionPointId);	

delivers an empty array and hence no access to the extension.
More strange: on the "Extension Points" Tab, clicking on "Find refererences" in fact finds the other plugin.
And v.v.: Clicking on "Find declaring extension point" in the other plugin finds the declarator.

My two plugins are different projects to "RCP-BookTool"-project, having nothing to do with it. As I said, worked before. Is my Eclipse now damaged due to that RCP-Book/Mylin install?

Where should I place a breakpoint within the startup-sequence of the RCP-stuff to see the "Now I'm going to look for extensions"-procedure behind the curtain?

Thanks
Frank

[Updated on: Tue, 17 August 2010 14:11]

Report message to a moderator

Previous Topic:Get corresponding view in AbstractHandler.execute()
Next Topic:Export an RCP Product with Features: Validation failes
Goto Forum:
  


Current Time: Thu Oct 23 00:59:03 GMT 2014

Powered by FUDForum. Page generated in 0.02276 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software