Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » EclipseLink 2.1 Upgrade failure
EclipseLink 2.1 Upgrade failure [message #550453] Fri, 30 July 2010 12:30 Go to next message
Gilbert  is currently offline Gilbert Friend
Messages: 25
Registered: October 2009
Junior Member
Hi

I've downloaded the latest JPA v2.1.0 (Moxy and SDO) through the Sotware update feature into Galileo from http://download.eclipse.org/rt/eclipselink/updates which replaced my old V1 jar files.

Now I can't get any of my JPA related projects to compile. They cannot find the JPA persistence stuff. I've even tried to create a new JPA project, but the setup wizard is only offering EclipseLink 1.0.x and 1.1.x. Looking at the Properties->Project Facets I can only see Java Persistence version 1.

Is there something else I need to upgrade as well? How do I persuade my JPA projects to see the new version?

Regards
Re: EclipseLink 2.1 Upgrade failure [message #550469 is a reply to message #550453] Fri, 30 July 2010 13:22 Go to previous messageGo to next message
Paul Fullbright is currently offline Paul FullbrightFriend
Messages: 200
Registered: July 2009
Senior Member
JPA 2.0 support was a feature added in Helios. With Helios, you should be able to either use EclipseLink 2.1 as a library with JPA 1.0 feature support (using Generic or EclipseLink 1.0.x, 1.1.x or 1.2.x features) or JPA 2.0 feature support (using Generic or EclipseLink 2.0.x or 2.1.x features).

Previous to Helios, you should still be able to use EclipseLink 2.1 as a library, but you will only get feature support up to EclipseLink 1.1.x. (You can still use EclipseLink 2.1 features, but the UI does not offer validation or configuration support for them.)
Re: EclipseLink 2.1 Upgrade failure [message #550483 is a reply to message #550469] Fri, 30 July 2010 14:05 Go to previous messageGo to next message
Gilbert  is currently offline Gilbert Friend
Messages: 25
Registered: October 2009
Junior Member
OK - I've downloaded Helios, fired it up and for some reason it needed me to re-download the Eclipse 2.1 support even though I'm pointing to my original workspace.

After re-starting, going into Properties->Java Persistence, still only allows me to select upto Platform 1.2.x although it's selecting the 2.1 JPA implementation. Should there be a Platform 2.x option there?

Regards
Re: EclipseLink 2.1 Upgrade failure [message #550489 is a reply to message #550483] Fri, 30 July 2010 14:18 Go to previous messageGo to next message
Paul Fullbright is currently offline Paul FullbrightFriend
Messages: 200
Registered: July 2009
Senior Member
You will need to upgrade the project to JPA version 2.0 before changing the platform, but all of that can be done from the project facets page.
Re: EclipseLink 2.1 Upgrade failure [message #550492 is a reply to message #550489] Fri, 30 July 2010 14:31 Go to previous messageGo to next message
Gilbert  is currently offline Gilbert Friend
Messages: 25
Registered: October 2009
Junior Member
Got it!

Thanks
Re: EclipseLink 2.1 Upgrade failure [message #550509 is a reply to message #550492] Fri, 30 July 2010 15:18 Go to previous message
Paul Fullbright is currently offline Paul FullbrightFriend
Messages: 200
Registered: July 2009
Senior Member
By the way, there is a Dali (JPA/EclipseLink tools) forum here: http://www.eclipse.org/forums/index.php?t=thread&frm_id= 113
Previous Topic:Understanding @XmlInverseReference
Next Topic:BatchUpdateException: invalid batch command: invalid SELECT batch command 0
Goto Forum:
  


Current Time: Sun Dec 21 13:35:09 GMT 2014

Powered by FUDForum. Page generated in 0.17010 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software