Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT - Tomcat: Running problem (please help, probably very easy!)(Tomcat, MySQL, Birt 2.6.0: Error when querying sixth or fifth report)
BIRT - Tomcat: Running problem (please help, probably very easy!) [message #549489] Mon, 26 July 2010 16:04
Federico Alvarez is currently offline Federico Alvarez
Messages: 2
Registered: July 2010
Junior Member
Hi everyone, I'm a newbie to BIRT and having the most awkward problem.

I designed in RCP my very first report, using BIRT 2.6.0, and accessing a MySQL 5.5.

When run with the tomcat viewer it works perfectly, until I query for the sixth o fifth time!!!

In this last run the webbrowser hangs in the "Processing, wait..." screen.

The logs show nothing weird (to me at last). And no output sent to Catalina.out or tomcat console.

What I was able to see is that in " /opt/tomcat6/webapps/birtviewer/documents/BIRT****/20100726_ 174500_***/ " are the "*.rptdocument" (this folder is the default tmp folder, the * are randomly generated, i have not played with this configuration). For the first 6 runs, there is a folder created and a file in each with a matching size of 155724 bytes. But for the 7th run the size is 62659 bytes.

The content of all files is the same, something like "RPTDOCV2", even in the one with less size.

For this failed run, the "***IMG***" temp folder is not created, for the others yes.

Reloading the "birtviewer" application "solves" the problem for 6 more runs, until another crush happens.

I tried using "run" instead of "frameset", but the result was the same (only difference is that no "*.rptdocument" is created).

Can anyone help me with this issue? Probably it is something silly I'm missing, maybe in design time.

I tried this in two different servers, both running Linux, Tomcat, Java 6, MySQL 5.5.

Thanks in advance.

Best regards,
Federico.
Previous Topic:Iterating over datasets, API documentation and cross tab sub reports
Next Topic:problem in generating PDF reports from linux system
Goto Forum:
  


Current Time: Tue Jul 29 07:02:35 EDT 2014

Powered by FUDForum. Page generated in 0.01625 seconds