Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » swtbot and junit3
swtbot and junit3 [message #549300] Mon, 26 July 2010 12:16 Go to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
hi, I'm a little confused so forgive me the basic question Smile

Does SWTBot still work with junit3 in Eclipse 3.6?


I'm asking this after trying to setup headless tests with swtbot and junit3 for a while. I was following http://wiki.eclipse.org/SWTBot/Ant, so I added org.eclipse.swtbot.eclipse.test.junit3-2.0.0.595-dev-e36.zip , together with eclipse-testFramework zip to my headless setup.
Because eclipse testFramewrok includes both junit 3.8 and 4.x, I manually removed org.junit4 and org.junit_4.8*
Now when trying to run tests, I figured that this actually broke swtbot, because lost of it's plugins depend on org.junit_4.3 in their manifests. So swtbot plugins are not resolved and my tests plugin doesn't resolve too.

thanks

Jacek
Re: swtbot and junit3 [message #549398 is a reply to message #549300] Mon, 26 July 2010 14:54 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 7/26/10 5:16 AM, Jacek Pospychala wrote:
> Now when trying to run tests, I figured that this actually broke swtbot,
> because lost of it's plugins depend on org.junit_4.3 in their manifests.
> So swtbot plugins are not resolved and my tests plugin doesn't resolve too.

AFAIK, all plugins depend on junit >=v4.3. If there's any particular
plugin that you see which is bound to a specific version please let us
know so we could fix it.

Also I'd recommend not unpacking the eclipse headless testing framework
when running SWTBot based tests. This is especially so because there
have been some changes to the eclipse's headless framework for eclipse
3.6 to play nice with junit4 that I'm completely unaware of.

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot
Re: swtbot and junit3 [message #549707 is a reply to message #549398] Tue, 27 July 2010 15:48 Go to previous messageGo to next message
Dru Welburn is currently offline Dru Welburn
Messages: 18
Registered: July 2010
Junior Member
I apologize if this is inappropriate (please let me know if it is), but I didn't see a way to contact you privately.

I am trying to find a tester with SWTBOT skills for a 2+ year contract with a research lab in Westchester, NY. Can you give me any advice where I can post this contract opening on an SWTBOT related site? Thank you.



Dru Welburn
dru at ivmost dot com

[Updated on: Tue, 27 July 2010 15:49]

Report message to a moderator

Re: swtbot and junit3 [message #549722 is a reply to message #549707] Tue, 27 July 2010 16:50 Go to previous message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
This forum would be fine as long as you mark it as [JOB] or something
similar in the subject line. Replying to an existing thread might not
get you much attention :)

There's also another more appropriate forum "eclipse.employment"
( http://www.eclipse.org/forums/index.php?t=thread&frm_id= 94) for this
where you might get more traction.

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot

On 7/27/10 8:48 AM, Dru Welburn wrote:
> I am apologize if this is inappropriate (please let me know if it is),
> but I didn't see a way to contact you privately.
>
> I am trying to find a tester with SWTBOT skills for a 2+ year contract
> with a research lab in Westchester, NY. Can you give me any advice where
> I can post this contract opening on a SWTBOT related site? Thank you.
>
>
Previous Topic:New release of SWTBot now available!
Next Topic:JOB: Tester with SWTBOT
Goto Forum:
  


Current Time: Wed Sep 17 13:34:45 GMT 2014

Powered by FUDForum. Page generated in 0.08838 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software