Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Is there a version of org.eclipse.ocl.ecore that is compatible with EMF 2.2?
Is there a version of org.eclipse.ocl.ecore that is compatible with EMF 2.2? [message #55233] Wed, 07 May 2008 20:51 Go to next message
Tim Myer is currently offline Tim Myer
Messages: 81
Registered: July 2009
Member
Question about the org.eclipse.ocl.ecore plug-in: I am looking for a
version of this plug-in that is compatible with EMF 2.2. Right now, on
the MDT archive site, I see a few releases, but none contains what I
need. OCL 1.0.1 is compatible with EMF 2.2, but it does not contain
org.eclipse.ocl.ecore. OCL 1.1.0 contains org.eclipse.ocl.ecore, but it
requires EMF 2.3. Does anyone have any suggestions for what I should do?
Re: Is there a version of org.eclipse.ocl.ecore that is compatible with EMF 2.2? [message #55260 is a reply to message #55233] Wed, 07 May 2008 21:23 Go to previous message
Eclipse User
Originally posted by: give.a.damus.gmail.com

Hi, Tim,

No, this plug-in was introduced in the OCL 1.1 release, concurrent with
EMF 2.3. The 1.0.x versions of MDT OCL are compatible with EMF 2.2 and
provide a rather different API in the org.eclipse.emf.ocl plug-in. That
API is still supported (though deprecated) in the 1.1 and later releases.

HTH,

Christian

Tim Myer wrote:
> Question about the org.eclipse.ocl.ecore plug-in: I am looking for a
> version of this plug-in that is compatible with EMF 2.2. Right now, on
> the MDT archive site, I see a few releases, but none contains what I
> need. OCL 1.0.1 is compatible with EMF 2.2, but it does not contain
> org.eclipse.ocl.ecore. OCL 1.1.0 contains org.eclipse.ocl.ecore, but it
> requires EMF 2.3. Does anyone have any suggestions for what I should do?
Previous Topic:[Announce] MDT OCL 1.2.0M7 is available
Next Topic:OCL extensions
Goto Forum:
  


Current Time: Fri Oct 31 17:23:01 GMT 2014

Powered by FUDForum. Page generated in 0.04300 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software