Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse on Ubuntu with OpenJDK hanging unless root
Eclipse on Ubuntu with OpenJDK hanging unless root [message #543892] Thu, 01 July 2010 00:16
Craig Foote is currently offline Craig FooteFriend
Messages: 195
Registered: July 2009
Senior Member
I suspect this is not the best place to ask about this so if anyone knows
of a better place please tell me. In the meantime I wonder if anyone here
has seen this or knows how to troubleshoot this problem.

I'm running Helios now but reproduced it with Galileo: if I run eclipse
as root everything works fine but if I run it as a normal user the
eclipse and Java processes hang on exit. Even if I cancel on the 'Select
Workspace' dialog. This is a recent problem and as it happens with both
3.5.2 and 3.6.0 as well I suspect it is a problem with OpenJDK not
eclipse. I just don't know where to start debugging this. I also run
JAlbum which starts a Java process but it exits cleanly.

If I run eclipse for a while and shut down, I find it suspicious that the
workspace/.metadata folder doesn't contain a .log file but it does
contain a .lock file. When I then kill the hung Java process, the .lock
file remains. If I kill the eclipse process, the Java process remains.
Killing the Java process ends the eclipse process.

I'm running a fully updated Ubuntu 10.04 (Lucid) 64-bit. I downloaded and
extracted eclipse; I didn't use the Ubuntu package install.

OpenJDK version info:

craig@notebook:~$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-0ubuntu2)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)


eclipse.ini:

-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.0. v20100503
-product
org.eclipse.epp.package.rcp.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m

Just the defaults really. I've never set the -vm option relying on the
system environment. As it starts I suspect it is finding Java ok - the
problem is on exit.

Again sorry for the noise but I need help on this. I prefer to stay with
OpenJDK and not switch to Sun's distro. Any other ideas greatly
appreciated.

Craig
Previous Topic:Single-class plugin patch?
Next Topic:bash plugin
Goto Forum:
  


Current Time: Mon Dec 22 08:45:53 GMT 2014

Powered by FUDForum. Page generated in 0.01719 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software