Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » JavaHL plug-in causing segmentation fault on Mac OS X
JavaHL plug-in causing segmentation fault on Mac OS X [message #542535] Fri, 25 June 2010 05:08 Go to next message
Kal Sze is currently offline Kal Sze
Messages: 7
Registered: July 2009
Junior Member

Are you having the same problem?[ 0 votes ]
1.Yes 0 / 0%
2.No 0 / 0%

After installing the "Native JavaHL 1.6 Implementation" feature (version 2.2.2.I20100512-1900), Eclipse crashes at start up.

If I start the eclipse executable from a shell, I can see the following error messages at the console, followed by a segmentation fault:

Quote:
svnjavahl: error: cannot set LC_ALL locale
svnjavahl: error: environment variable LC_CTYPE is UTF-8
svnjavahl: error: please check that your locale name is correct
Invalid memory access of location 0x8 rip=0x152b88eec

Segmentation fault


I have also uploaded the Mac OS X crash log at http://pastebin.org/357865.

Is it possible that it is caused by an incompatibility between the feature and the variant of subversion that I have installed via MacPorts? The variant I have installed is this:

subversion @1.6.12_0+bash_completion+no_bdb+tools+unicode_path

How do I resolve the problem (other than using SVNKit)?
Re: JavaHL plug-in causing segmentation fault on Mac OS X [message #543363 is a reply to message #542535] Tue, 29 June 2010 04:12 Go to previous message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Kal,

There's something wrong with your locale, please try to search in
internet, e.g.
http://www.cs.uu.nl/wiki/bin/view/Gw/NixTroubleshooting#Seve r_crashes_with_cannot_set_LC

> After installing the "Native JavaHL 1.6 Implementation" feature (version
> 2.2.2.I20100512-1900), Eclipse crashes at start up.
>
> If I start the eclipse executable from a shell, I can see the following
> error messages at the console, followed by a segmentation fault:
>
> Quote:
>> svnjavahl: error: cannot set LC_ALL locale
>> svnjavahl: error: environment variable LC_CTYPE is UTF-8
>> svnjavahl: error: please check that your locale name is correct
>> Invalid memory access of location 0x8 rip=0x152b88eec
>>
>> Segmentation fault
>
> I have also uploaded the Mac OS X crash log at http://pastebin.org/357865
>
> Is it possible that it is caused by an incompatibility between the
> feature and the variant of subversion that I have installed via
> MacPorts? The variant I have installed is this:
>
> subversion @1.6.12_0+bash_completion+no_bdb+tools+unicode_path
> How do I resolve the problem (other than using SVNKit)?


--
Best regards,
Igor Burilo
Previous Topic:Update site for Helios (svn connectors)
Next Topic:svn and jboss runtime
Goto Forum:
  


Current Time: Fri Aug 01 08:05:18 EDT 2014

Powered by FUDForum. Page generated in 0.01759 seconds