Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse 4.0 - confusing message(3.6? 4.0? e4?)
Eclipse 4.0 - confusing message [message #539140] Wed, 09 June 2010 14:26
Chris Lee Harasemchuk is currently offline Chris Lee Harasemchuk
Messages: 2
Registered: July 2009
Junior Member
I've actually got a few questions/comments - I'll try to organize them in one post since they're all somewhat related...

1. Target audience

From http://wiki.eclipse.org/Eclipse/Eclipse_SDK_4.0_FAQ

- the target audience is identified as developers writing plugins/products on top of the Eclipse platform
- it's recommended to not use Eclipse 4.0 as a Java IDE

As a plugin developer, these two statements seem contradictory - I should use it to write plugins, but I shouldn't use it as an IDE?


2. Finding Information on Eclipse 4.0

From the main site I can easily find http://www.eclipse.org/eclipse/development/, which mentions Eclipse 3.6, e4, and Eclipse 4.0, and the download site (http://www.eclipse.org/downloads/) provides links for 3.6 and e4, but not 4.0.

It took a lot of searching to eventually find the 4.0 FAQ (which answered some questions) and a place to download something actually branded as Eclipse 4.0 (http://download.eclipse.org/e4/sdk/ - the only place I've found this link was a post in this forum)

It would be better if this information (FAQs and download) was more easily findable from the main site...


3. Other plugin support for 4.0?

Assuming there's an answer to #1 above that still encourages plugin developers to develop against Eclipse 4.0, what are the plans for getting the other Eclipse tools/plugins (ie: GEF, EMF, DTP, etc) to work on the 4.0 platform? (Our plugins have dependencies on these)
Previous Topic:CSS styling with e4
Next Topic:Eclipse 4.0 - confusing message
Goto Forum:
  


Current Time: Tue Sep 02 07:59:00 EDT 2014

Powered by FUDForum. Page generated in 0.07861 seconds