Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar
568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538448] Mon, 07 June 2010 16:09 Go to next message
gachoki is currently offline gachoki
Messages: 10
Registered: October 2009
Junior Member
If you download SWTBot for GEF Testing/ the other packages from http://www.eclipse.org/swtbot/downloads.php, the zip files have all the needed plug-ins except for org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar and org.eclipse.gmf.bridge.trace_1.0.100.v20080425-1959.jar

For this reason, when you extract the zip file into your eclipse plug-ins directory, you still can't execute test-cases using Run/Debug as SWTBOT test-case menu option.

Workaround is to install SWTBOT through Update Manager/Update Site http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/

Hope the packaging in the downloadable zip files can be fixed soon to include all the required plug-ins so that there is an alternative install option for SWTBOT.
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538457 is a reply to message #538448] Mon, 07 June 2010 16:34 Go to previous messageGo to next message
Mariot Chauvin is currently offline Mariot Chauvin
Messages: 174
Registered: July 2009
Senior Member
Hi,

Comments below.

gachoki@us.ibm.com a écrit :
> If you download SWTBot for GEF Testing/ the other packages from
> http://www.eclipse.org/swtbot/downloads.php, the zip files have all the
> needed plug-ins except for
> org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar and
> org.eclipse.gmf.bridge.trace_1.0.100.v20080425-1959.jar


I am sorry, I don't understand what do you explain.
SWTBot for GEF does not depend from GMF, so why do you except some GMF plug-in to be included ?

>
> For this reason, when you extract the zip file into your eclipse
> plug-ins directory, you still can't execute test-cases using Run/Debug
> as SWTBOT test-case menu option.

Extracting zip file into your eclipse plug-ins is definitively not a supported way of installing plug-ins in eclipse based platform since Eclipse 3.4.


>
> Workaround is to install SWTBOT through Update Manager/Update Site
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/

Using the update manager/update site is the standard way to install SWTBot.

>
>
> Hope the packaging in the downloadable zip files can be fixed soon to
> include all the required plug-ins so that there is an alternative
> install option for SWTBOT.
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538464 is a reply to message #538457] Mon, 07 June 2010 16:47 Go to previous messageGo to next message
gachoki is currently offline gachoki
Messages: 10
Registered: October 2009
Junior Member
Hi,

I mentioned org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar and org.eclipse.gmf.bridge.trace_1.0.100.v20080425-1959.jar because those were the differences between the plug-in I got when I installed SWTBOT through update manager and installing SWTBOT through the downloadable zip files.

I understand the installing through the update manager is the recommended way to install plug-in but is there any reason why the downloadable zip files are missing required plug-ins?

In my situation, I use IDE and install required plug-ins through the update manager as normal but then I also need to transfer my test-cases and required plug-ins somewhere else where I execute them using Ant/Cmd line - so in such cases, I prefer just extracting the plugins to where in them to be, not using update manager, let me know if you recommend better solution/approach.

thanks.
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538488 is a reply to message #538464] Mon, 07 June 2010 17:20 Go to previous messageGo to next message
Pascal G is currently offline Pascal G
Messages: 157
Registered: July 2009
Senior Member
On 10-06-07 12:47 PM, gachoki@us.ibm.com wrote:
> Hi,
>
> I mentioned org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar and
> org.eclipse.gmf.bridge.trace_1.0.100.v20080425-1959.jar because those
> were the differences between the plug-in I got when I installed SWTBOT
> through update manager and installing SWTBOT through the downloadable
> zip files.
>
> I understand the installing through the update manager is the
> recommended way to install plug-in but is there any reason why the
> downloadable zip files are missing required plug-ins?
>
> In my situation, I use IDE and install required plug-ins through the
> update manager as normal but then I also need to transfer my test-cases
> and required plug-ins somewhere else where I execute them using Ant/Cmd
> line - so in such cases, I prefer just extracting the plugins to where
> in them to be, not using update manager, let me know if you recommend
> better solution/approach.
>
> thanks.
>

I use p2 director to manage my Eclipse test target. I did a simple
little bash script to update the version of SWTBot on the command line.
Very useful.

And it's the best and easiest way I found right now.

--
Pascal Gélinas | Software Developer
*Nu Echo Inc.*
http://www.nuecho.com/ | http://blog.nuecho.com/

*Because performance matters.*
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538569 is a reply to message #538488] Tue, 08 June 2010 02:42 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
Hi Pascal,

It would be great if you could put it on the snippets wiki page.

http://wiki.eclipse.org/SWTBot/Snippets

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot


On 6/7/10 10:50 PM, Pascal Gelinas wrote:
> I use p2 director to manage my Eclipse test target. I did a simple
> little bash script to update the version of SWTBot on the command line.
> Very useful.
>
> And it's the best and easiest way I found right now.
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538573 is a reply to message #538464] Tue, 08 June 2010 03:17 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 6/7/10 10:17 PM, gachoki@us.ibm.com wrote:
> I understand the installing through the update manager is the
> recommended way to install plug-in but is there any reason why the
> downloadable zip files are missing required plug-ins?

At some level, SWTBot requires, SWT, workbench, ui and a host of other
things. A package that contains all SWTBot dependencies and their
closure would probably be in the few 10s of MB and may cause issues when
for e.g. you're on a different version of swt, workbench and ui :)

Trust me, this is not something you'd like, if you look at the
alternatives :)

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538723 is a reply to message #538569] Tue, 08 June 2010 13:25 Go to previous messageGo to next message
Pascal G is currently offline Pascal G
Messages: 157
Registered: July 2009
Senior Member
On 10-06-07 10:42 PM, Ketan Padegaonkar wrote:
> Hi Pascal,
>
> It would be great if you could put it on the snippets wiki page.
>
> http://wiki.eclipse.org/SWTBot/Snippets
>

Alright, it's done.

--
Pascal Gélinas | Software Developer
*Nu Echo Inc.*
http://www.nuecho.com/ | http://blog.nuecho.com/

*Because performance matters.*
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538816 is a reply to message #538723] Tue, 08 June 2010 17:22 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 6/8/10 6:55 PM, Pascal Gelinas wrote:
> On 10-06-07 10:42 PM, Ketan Padegaonkar wrote:
>> Hi Pascal,
>>
>> It would be great if you could put it on the snippets wiki page.
>>
>> http://wiki.eclipse.org/SWTBot/Snippets
>>
>
> Alright, it's done.

Thanks a lot! Every bit of help is a lot of help :)

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538882 is a reply to message #538816] Tue, 08 June 2010 21:33 Go to previous messageGo to next message
gachoki is currently offline gachoki
Messages: 10
Registered: October 2009
Junior Member
Hello Pascal/Ketan,

do you know which application ID/options works/preferable for installing features/plug-ins from command line using eclipse 3.4? It seems like org.eclipse.equinox.p2.director is not available in 3.4, so I modified your example usage to use org.eclipse.equinox.p2.director.app.application but still I get errors e.g., for:

java -jar plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125. jar -application org.eclipse.equinox.p2.director.app.application -repository http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/ -metadataRepository http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/ -artifactRepository http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/ -consoleLog -nosplash -installIU org.eclipse.swtbot.eclipse.gef.feature.group -verifyOnly


I see the following errors:

!ENTRY org.eclipse.equinox.p2.director 4 0 2010-06-08 16:31:31.250
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2010-06-08 16:31:31.250
!MESSAGE Unable to satisfy dependency from org.eclipse.swtbot.junit4_x 2.0.0.568
-dev-e35 to requiredCapability: java.package/org.junit.runner.notification/4.5.0
.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2010-06-08 16:31:31.250
!MESSAGE Unable to satisfy dependency from org.eclipse.swtbot.junit4_x 2.0.0.568
-dev-e35 to requiredCapability: java.package/org.junit.runners/4.5.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2010-06-08 16:31:31.250
!MESSAGE Unable to satisfy dependency from org.eclipse.swtbot.junit4_x 2.0.0.568
-dev-e35 to requiredCapability: java.package/org.junit.runners.model/4.5.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2010-06-08 16:31:31.250
!MESSAGE No solution found because the problem in C:\DOCUME~1\ADMINI~1\LOCALS~1\
Temp\p2Encoding3232281181611985130.opb is unsatisfiable.
Installation failed.
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538897 is a reply to message #538882] Wed, 09 June 2010 01:19 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 6/9/10 3:03 AM, gachoki@us.ibm.com wrote:
> Hello Pascal/Ketan,
>
> do you know which application ID/options works/preferable for installing
> features/plug-ins from command line using eclipse 3.4? It seems like
> org.eclipse.equinox.p2.director is not available in 3.4, so I modified
> your example usage to use
> org.eclipse.equinox.p2.director.app.application but still I get errors
> e.g., for:
>
> java -jar plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.
> jar -application org.eclipse.equinox.p2.director.app.application
> -repository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -metadataRepository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -artifactRepository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -consoleLog -nosplash -installIU
> org.eclipse.swtbot.eclipse.gef.feature.group -verifyOnly
>
>
> I see the following errors:
>
> !ENTRY org.eclipse.equinox.p2.director 4 0 2010-06-08 16:31:31.250
> !MESSAGE Problems resolving provisioning plan.
> !SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2010-06-08 16:31:31.250
> !MESSAGE Unable to satisfy dependency from org.eclipse.swtbot.junit4_x
> 2.0.0.568
> -dev-e35 to requiredCapability:
> java.package/org.junit.runner.notification/4.5.0

Seems like you're using the -e35 bits! You need to download the eclipse
3.4 bits with a -e34 suffix.

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538903 is a reply to message #538897] Wed, 09 June 2010 03:32 Go to previous messageGo to next message
gachoki is currently offline gachoki
Messages: 10
Registered: October 2009
Junior Member
Hello Ketan,

I am using http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip, is that what you describe as the -e35 bits? or was it some wrong command line options used in my last post? If possible, can you give sample command line options that can successfully install SWTBot for GEF Testing (Ganymede Edition) on eclipse 3.4 based?
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #538921 is a reply to message #538903] Wed, 09 June 2010 06:06 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 6/9/10 9:02 AM, gachoki@us.ibm.com wrote:
> Hello Ketan,
>
> I am using
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip,
> is that what you describe as the -e35 bits? or was it some wrong command
> line options used in my last post? If possible, can you give sample
> command line options that can successfully install SWTBot for GEF
> Testing (Ganymede Edition) on eclipse 3.4 based?
>

The command line you provided works for me (with a few argument changes).

See my console at http://gist.github.com/431122

Could you try the same command line on a fresh eclipse with nothing else
installed in it ?

I should have been clear in my previous email.

SWTBot for ganymede will have version number '2.0.0.568-dev-e34', which
is what I meant when I was referring to -e35 bits.

What I'm confused about is that your error message from a previous email
says:

Unable to satisfy dependency from
org.eclipse.swtbot.junit4_x 2.0.0.568-dev-e35 to
requiredCapability: java.package/org.junit.runner.notification/4.5.0

There is no reason why '2.0.0.568-dev-e35' should come into picture
unless the command points to the swtbot galileo update site (which does
not seem to be the case) or have something else that's pulling from the
swtbot galileo repository.

--
Ketan
http://ketan.padegaonkar.name | http://eclipse.org/swtbot
Re: 568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar [message #539064 is a reply to message #538882] Wed, 09 June 2010 14:02 Go to previous message
Pascal G is currently offline Pascal G
Messages: 157
Registered: July 2009
Senior Member
On 10-06-08 05:33 PM, gachoki@us.ibm.com wrote:
> Hello Pascal/Ketan,
>
> do you know which application ID/options works/preferable for installing
> features/plug-ins from command line using eclipse 3.4? It seems like
> org.eclipse.equinox.p2.director is not available in 3.4, so I modified
> your example usage to use
> org.eclipse.equinox.p2.director.app.application but still I get errors
> e.g., for:
>
> java -jar plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.
> jar -application org.eclipse.equinox.p2.director.app.application
> -repository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -metadataRepository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -artifactRepository
> http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site/
> -consoleLog -nosplash -installIU
> org.eclipse.swtbot.eclipse.gef.feature.group -verifyOnly
>
>
> I see the following errors:
>
> !ENTRY org.eclipse.equinox.p2.director 4 0 2010-06-08 16:31:31.250
> !MESSAGE Problems resolving provisioning plan.
> !SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2010-06-08 16:31:31.250
> !MESSAGE Unable to satisfy dependency from org.eclipse.swtbot.junit4_x
> 2.0.0.568
> -dev-e35 to requiredCapability:
> java.package/org.junit.runner.notification/4.5.0

I revisited the little script to make it easier for people with another
version then mine... I also added a note how to manage an eclipse 3.4
installation, using eclipse 3.5 and p2.director.

For this error, my guess is that you have
org.eclipse.swtbot.junit4_x2.0.0.568-dev-e35 currently installed in your
eclipse 3.4, which is a no go. I'm pretty sure that the
uninstall/install went smoothly, and this is merely eclipse telling you
that it won't be able to start that bundle. Just delete it from your
plugins directory and you shouldn't have any error.

Hope this helps.

p.s.: you should remove the -verifyOnly option if you want p2.director
to uninstall/install the feature ;)
--
Pascal Gélinas | Software Developer
*Nu Echo Inc.*
http://www.nuecho.com/ | http://blog.nuecho.com/

*Because performance matters.*
Previous Topic:Accessing wizard error/warning messages?
Next Topic:Missing requirement package 'junit.framework 4.3.0'
Goto Forum:
  


Current Time: Tue Oct 21 05:28:26 GMT 2014

Powered by FUDForum. Page generated in 0.09710 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software