Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Plugins were not detected
Plugins were not detected [message #52834] Tue, 31 March 2009 18:53 Go to next message
Eclipse UserFriend
Originally posted by: tmothymarc.freenet.de

Hey all,

i've a couple of plugins, which i had initially developed under 3.3.
Now, i had move to 3.4 and after exporting them, any 3.4 distribution
won't found them.

I'm a bit confused, because when i test the plugins from within the
Eclipse 3.4 distribution (by launching an Eclipse Application), i can
access them?

May i have to configure some other properties? I have any more ideas.

Thx
Timothy
Re: Plugins were not detected [message #52861 is a reply to message #52834] Tue, 31 March 2009 19:01 Go to previous message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Timothy Marc wrote:
> Hey all,
>
> i've a couple of plugins, which i had initially developed under 3.3.
> Now, i had move to 3.4 and after exporting them, any 3.4 distribution
> won't found them.
>
> I'm a bit confused, because when i test the plugins from within the
> Eclipse 3.4 distribution (by launching an Eclipse Application), i can
> access them?
>
> May i have to configure some other properties? I have any more ideas.

How are you installing the plug-ins into 3.4?

I have a hunch it may be related to the new target platform preference
in 3.4:

http://help.eclipse.org/ganymede/topic/org.eclipse.pde.doc.u ser/guide/tools/preference_pages/target_platform.htm

"How PDE builds it target platform is dictated by the Build target
platform based on target's installed plug-ins preference. When this
preference is enabled, PDE will attempt to locate the target location's
list of installed plug-ins inside a configuration file (platform.xml or
bundles.info). If PDE finds this file, it will build the target platform
based on the plug-ins inside the configuration file. If it doesn't find
the file, PDE will just manually scan the target location directory for
the list of plug-ins."

Note, we have significantly updated the target platform story in 3.5...
it's a much better place ;)

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: Plugins were not detected [message #594324 is a reply to message #52834] Tue, 31 March 2009 19:01 Go to previous message
Chris Aniszczyk is currently offline Chris AniszczykFriend
Messages: 674
Registered: July 2009
Senior Member
Timothy Marc wrote:
> Hey all,
>
> i've a couple of plugins, which i had initially developed under 3.3.
> Now, i had move to 3.4 and after exporting them, any 3.4 distribution
> won't found them.
>
> I'm a bit confused, because when i test the plugins from within the
> Eclipse 3.4 distribution (by launching an Eclipse Application), i can
> access them?
>
> May i have to configure some other properties? I have any more ideas.

How are you installing the plug-ins into 3.4?

I have a hunch it may be related to the new target platform preference
in 3.4:

http://help.eclipse.org/ganymede/topic/org.eclipse.pde.doc.u ser/guide/tools/preference_pages/target_platform.htm

"How PDE builds it target platform is dictated by the Build target
platform based on target's installed plug-ins preference. When this
preference is enabled, PDE will attempt to locate the target location's
list of installed plug-ins inside a configuration file (platform.xml or
bundles.info). If PDE finds this file, it will build the target platform
based on the plug-ins inside the configuration file. If it doesn't find
the file, PDE will just manually scan the target location directory for
the list of plug-ins."

Note, we have significantly updated the target platform story in 3.5...
it's a much better place ;)

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Previous Topic:Plugins were not detected
Next Topic:EditorPart auto refresh
Goto Forum:
  


Current Time: Mon Nov 24 09:21:43 GMT 2014

Powered by FUDForum. Page generated in 0.03825 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software