Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » CNF : link helper
CNF : link helper [message #521701] Thu, 18 March 2010 14:22 Go to next message
Nathalie Lepine is currently offline Nathalie Lepine
Messages: 28
Registered: July 2009
Junior Member
Hi,

I am using the link helper between a CNF view and another editor and i
have a problem. When i select an element in the editor, the link helper
calls the commonViewer.select on the right element on the CNF view,
but if the element is not expanded, the selection in the CNF viewer is
not done. If the element on the CNF view is expanded, it works the
element is selected.
Have you already have this problem or can you help me to find any
solutions ?

Thanks.

Nathalie Lepine.
Re: CNF : link helper [message #521718 is a reply to message #521701] Thu, 18 March 2010 14:56 Go to previous messageGo to next message
Francis Upton IV is currently offline Francis Upton IV
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
There was a bug related to this that was fixed in 3.6M6 that might address this problem. Which version are you using?

Re: CNF : link helper [message #521721 is a reply to message #521718] Thu, 18 March 2010 10:12 Go to previous messageGo to next message
Nathalie Lepine is currently offline Nathalie Lepine
Messages: 28
Registered: July 2009
Junior Member
I am using Eclipse 3.3 and Eclipse 3.5. Is there a way to fix this problem ?

Francis Upton a écrit :
> There was a bug related to this that was fixed in 3.6M6 that might
> address this problem. Which version are you using?
Re: CNF : link helper [message #521726 is a reply to message #521721] Thu, 18 March 2010 15:25 Go to previous message
Francis Upton IV is currently offline Francis Upton IV
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
I don't' recommend using the Common Navigator in 3.3, that is very old and there were many problems in it that have been subsequently fixed. If you are looking for a released build, I suggest using 3.5.2, however the particular problem you might have been having was not fixed until 3.6M6, and therefore will not be in any 3.5.x release, as 3.5.2 is the last release we produce in the 3.5 series.

If you wish, you can verify that your problem does not exist in 3.6M6 and then I can identify the bug that caused the problem and provide a patch for you for 3.5.2 (and also put it in that source line so that builds for 3.5.x can include it, even though they are not done by Eclipse).


Previous Topic:How do you disable the prompt after a file has been modified externally?
Next Topic:What APIs should I investigate for contributing children to resources in the Project Explorer?
Goto Forum:
  


Current Time: Sun Sep 21 00:17:42 GMT 2014

Powered by FUDForum. Page generated in 0.02028 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software